gwibber-service crashed with SIGSEGV in pthread_mutex_lock()

Bug #600010 reported by sam tygier on 2010-06-29
388
This bug affects 85 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Ken VanDine
gwibber (Ubuntu)
High
Ken VanDine

Bug Description

Binary package hint: gwibber

i had recently had a desktop-couch crash, so may be related to that

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: gwibber-service 2.31.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-6.8-generic 2.6.35-rc3
Uname: Linux 2.6.35-6-generic x86_64
Architecture: amd64
Date: Tue Jun 29 23:14:21 2010
ExecutablePath: /usr/bin/gwibber-service
InterpreterPath: /usr/bin/python2.6
LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100629)
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7fd3d9aaf644 <pthread_mutex_lock+4>: mov 0x10(%rdi),%esi
 PC (0x7fd3d9aaf644) ok
 source "0x10(%rdi)" (0xc41ae800) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gwibber
StacktraceTop:
 pthread_mutex_lock () from /lib/libpthread.so.0
 px_proxy_factory_get_proxies ()
 ffi_call_unix64 ()
 ffi_call ()
 _CallProc ()
Title: gwibber-service crashed with SIGSEGV in pthread_mutex_lock()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

sam tygier (samtygier) wrote :

StacktraceTop:
 pthread_mutex_lock () from /lib/libpthread.so.0
 px_proxy_factory_get_proxies (self=0xc41ae7f0,
 ffi_call_unix64 ()
 ffi_call (cif=0x7fd3c3ffba20,
 _CallProc (pProc=<value optimized out>,

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Kamus (kamus) on 2010-07-23
visibility: private → public

Mine crashed after I'd received a Gwibber-account crash on attempting to add Facebook. I did a Synaptic reinstall and then it added Facebook but this error occurred.

Kamus (kamus) wrote :

Have you tried to reproduce this issue with gwibber 2.31.2-0ubuntu3? Do you follow any special steps to reproduce this problem? Thanks.

Changed in gwibber (Ubuntu):
status: New → Incomplete
LSL (spesialstyrker) wrote :

All I've done to get this error is open gwibber, and try to add my facebook account.

LSL (spesialstyrker) wrote :

I haven't tried it on a more recent version if one is out though

MarkieB (ubunt-u-markbenjamin) wrote :

I get it virtually every day - gwibber is in startup programs

gwibber is 2.31.2-0ubuntu3

Yeah I'm pretty sure my package is the latest version. I did a Synaptic
reinstall... I am running Maverick Alpha AMD64+ though so that may be
contributing to things.

It's probably my fault for being too lazy to visit my accounts through their
own portals...

On Thu, Jul 29, 2010 at 12:22 PM, MarkieB <email address hidden> wrote:

> I get it virtually every day - gwibber is in startup programs
>
> gwibber is 2.31.2-0ubuntu3
>
> --
> gwibber-service crashed with SIGSEGV in pthread_mutex_lock()
> https://bugs.launchpad.net/bugs/600010
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gwibber” package in Ubuntu: Incomplete
>
> Bug description:
> Binary package hint: gwibber
>
> i had recently had a desktop-couch crash, so may be related to that
>
> ProblemType: Crash
> DistroRelease: Ubuntu 10.10
> Package: gwibber-service 2.31.1-0ubuntu1
> ProcVersionSignature: Ubuntu 2.6.35-6.8-generic 2.6.35-rc3
> Uname: Linux 2.6.35-6-generic x86_64
> Architecture: amd64
> Date: Tue Jun 29 23:14:21 2010
> ExecutablePath: /usr/bin/gwibber-service
> InterpreterPath: /usr/bin/python2.6
> LiveMediaBuild: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100629)
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/gwibber-service
> ProcEnviron:
> SHELL=/bin/bash
> LANG=en_US.UTF-8
> SegvAnalysis:
> Segfault happened at: 0x7fd3d9aaf644 <pthread_mutex_lock+4>: mov
> 0x10(%rdi),%esi
> PC (0x7fd3d9aaf644) ok
> source "0x10(%rdi)" (0xc41ae800) not located in a known VMA region (needed
> readable region)!
> destination "%esi" ok
> Stack memory exhausted (SP below stack segment)
> SegvReason: reading unknown VMA
> Signal: 11
> SourcePackage: gwibber
> StacktraceTop:
> pthread_mutex_lock () from /lib/libpthread.so.0
> px_proxy_factory_get_proxies ()
> ffi_call_unix64 ()
> ffi_call ()
> _CallProc ()
> Title: gwibber-service crashed with SIGSEGV in pthread_mutex_lock()
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/gwibber/+bug/600010/+subscribe
>

Changed in gwibber (Ubuntu):
status: Incomplete → New
MarkieB (ubunt-u-markbenjamin) wrote :

not resolved yet, here I am as usual :-)

MarkieB (ubunt-u-markbenjamin) wrote :

as usual

MarkieB (ubunt-u-markbenjamin) wrote :

gosh, here again? :-D

so I'll be clearing gwibber from my startup applications now, that'll be one less bug reporter :-)

Jan Hülsbergen (jan-afoo) wrote :

Just had it happen to me for the first time about half an hour after installing/starting gwibber. No problems with desktopcouch beforehand.

Guy Van Sanden (gvs) wrote :

I have this bug on a clean Maverick install multiple times a day, Gwibber is running >8 hours / day.

kyleabaker (kyleabaker) on 2010-08-30
Changed in gwibber (Ubuntu):
status: New → Confirmed
Randy Barlow (rbarlow) wrote :

This still happens with gwibber-service 2.31.91-0ubuntu1.

James Lewis (james-fsck) wrote :

Confirmed still an issue in 2.31.91 in Maverick Beta. Gwibber service is notoriously unstable, I don't know if this is the only problem with it, but I have to watch it like a hawk.

sam tygier (samtygier) wrote :

still in 2.31.91-0ubuntu2

James Lewis (james-fsck) wrote :

Given the history of instability in the gwibber backend, could the front end either show a backend status, or monitor the backend and restart... I keep finding that I'm watching the front end, only to find that the back end went away hours ago.

Ken VanDine (ken-vandine) wrote :

This crash is happening in libproxy, when calling px_proxy_factory_get_proxies, but only when caching avatars. It doesn't appear to ever get triggered during other operations, just fetching the images.

Our libproxy version is very old, 0.3.1, upstream is up to 0.4.6. I did reproduce this crash with libproxy 0.4.6.

Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → ubuntu-10.10
Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
milestone: none → 2.32.0
status: New → Fix Committed
Changed in gwibber (Ubuntu):
importance: Medium → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.31.92-0ubuntu1

---------------
gwibber (2.31.92-0ubuntu1) maverick; urgency=low

  * New upstream release
    - Don't crash if there are streams configured for accounts that no longer
      exist (LP: #631263)
    - Delete associated streams when an account is deleted
    - Reuse worker pool of threads (LP: #624918)
    - Ensure the timer is reset on each refresh, prevents multiple timers
      created to perform the refresh operations causing crashes (LP: #600010)
    - Clicking on the message indicator should focus replies (LP: #549817)
    - When focusing replies stream from the indicator, clear the
      indicators (LP: #629623)
    - gwibber-service crashed with IOError in get_avatar_path() (LP: #626068)
    - gwibber-service crashed with GError in notify() (LP: #622812)
  * debian/gwibber-service.py
    - Added apport package-hook to attach the gwibber.log (LP: #384552)
 -- Ken VanDine <email address hidden> Fri, 03 Sep 2010 15:06:17 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Changed in gwibber:
status: Fix Committed → Fix Released
LSL (spesialstyrker) wrote :

I just got this error trying to add a Facebook account on gwibber on a Maverick amd64 RC fresh install with all latest updates as of this post.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers