tr.im should be removed from advanced dropdown in gwibber-preferences

Bug #583316 reported by Tomas Cassidy on 2010-05-20
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Unassigned
gwibber (Ubuntu)
Low
Unassigned
Nominated for Maverick by Tomas Cassidy
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: gwibber

In the gwibber-preferences dialog on the Messages tab, there is a dropdown for selecting a URL shortening service. According to the tr.im website at http://tr.im/, the service is closing down and shortening requests have already been disabled via the website. The tr.im API will be shut down at the end of 2010. tr.im should be removed from the list of available URL shortening services as it will no longer be operational when Ubuntu 9.10 and 10.04 are still supported, resulting in potential user problems if they attempt to use the option for tr.im after 2010.

Quote from tr.im website:

If you have tr.im embedded within any software please remove it. We would never just turn tr.im off and affect installed software and users unaware, but we would like to shut down the API and redirection service by the end of 2010, from the time of this writing, April 2010. This should give everyone plenty of time to transition to other services that can economically justify operating a URL shortener, or don't have the volume for this to be problem.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gwibber 2.30.0.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu May 20 22:39:26 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
PackageArchitecture: all
ProcEnviron:
 PATH=(cususername, user)
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
SourcePackage: gwibber

Related branches

Tomas Cassidy (tomas-cassidy) wrote :
Victor Vargas (kamus) wrote :

right, this option should be removed of shortening service list if is not working any more. Thanks!

Changed in gwibber (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Victor Vargas (kamus) on 2010-08-18
Changed in gwibber (Ubuntu):
status: Confirmed → Triaged

Accepted gwibber into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
Omer Akram (om26er) wrote :

Fixed version is already in Maverick.

Changed in gwibber:
status: New → Fix Released
Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Bilal Akhtar (bilalakhtar) wrote :

Verified in -proposed.

Omer Akram (om26er) wrote :

been testing gwibber 2.30.2 no regression found.

tags: added: verification-done
removed: verification-needed
Colin Watson (cjwatson) wrote :

I'm waiving the normal seven-day aging period on this bug because of Twitter being broken for everyone following the oauthpocalypse. Please shout if it's made anything worse.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.30.2-0ubuntu1

---------------
gwibber (2.30.2-0ubuntu1) lucid-proposed; urgency=low

   * New upstream release
    - Port twitter service to OAuth, basic auth is no longer
      supported (LP: #627565)
    - Remove the tr.im urlshortener, the service is closed (LP: #583316)
    - Better handling of unexpect results from twitter and
      identi.ca (LP: #613420)
    - Better handling of error responses from twitter, should log more
      and traceback less (LP: #613420)
  * debian/gwibber-service.install
    - Install files needed for twitter oauth
  * debian/control
    - Added build dep for python-oauth, twitter now uses it
 -- Ken VanDine <email address hidden> Wed, 01 Sep 2010 12:05:54 -0400

Changed in gwibber (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers