gwibber-accounts doesn't let you add your secret_key to the keyring

Bug #571224 reported by Ken VanDine on 2010-04-28
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Ken VanDine
gwibber (Ubuntu)
High
Ken VanDine
Lucid
Undecided
Unassigned
Maverick
High
Ken VanDine

Bug Description

Binary package hint: gwibber

When gwibber finds a facebook account without a secret_key stored in the gnome-keyring, it opens gwibber-accounts but gwibber-accounts doesn't actually provide you a way to save the secret_key. It needs to show the authorize button, same as it does for adding a new account.

Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
milestone: none → lucid-updates
status: New → Confirmed
Changed in gwibber:
status: New → Fix Committed
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High

Accepted gwibber into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed

Works for me now. Many thanks!

Martin Pitt (pitti) on 2010-05-23
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.30.0.1-0ubuntu3

---------------
gwibber (2.30.0.1-0ubuntu3) lucid-proposed; urgency=low

  * debian/patches/lp_569543.patch
    - Don't allow people to click "Add" before we have enough information
      from facebook to add the account (LP: #569543)

gwibber (2.30.0.1-0ubuntu2) lucid-proposed; urgency=low

  * debian/patches/handle_facebook_keyring.patch
    - Handle prompting the user to authorize gwibber to use facebook in cases
      where the account was synced and there is no local key stored in the
      keyring (LP: #571224)
  * debian/patches/dont_spawn_multiple_accounts_dialogs.patch
    - Don't fire gwibber-accounts for each failure, only spawn it
      once (LP: #564741)
 -- Ken VanDine <email address hidden> Mon, 03 May 2010 10:58:47 -0400

Changed in gwibber (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to maverick, too.

Changed in gwibber (Ubuntu Maverick):
status: Confirmed → Fix Released
Omer Akram (om26er) on 2010-07-10
Changed in gwibber:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers