multiple broadcast account windows popup when accounts not configured properly

Bug #564741 reported by Brian Curtis on 2010-04-16
54
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Ken VanDine
gwibber (Ubuntu)
High
Ken VanDine
Lucid
Undecided
Unassigned
Maverick
High
Ken VanDine

Bug Description

Binary package hint: gwibber

I'm not sure if this is a result of my deletion of all my ~/. files. (as a test of course) a while back, but the broadcast accounts window popped up multiple times as it requested me to insert a password for my identi.ca account as well as reauthorize facebook although it never made any visual notification that it wasn't authorized.
It seemed to pop-up at the update interval i specified in the preferences, and everytime it would pop-up again the amount of windows would appear to double (didn't verify exact numbers).

WORKAROUND: insert missing passwords from requested accounts and/or re-authorize facebook by deleting it and adding it again.

gwibber:
  Installed: 2.30.0.1-0ubuntu1
  Candidate: 2.30.0.1-0ubuntu1
  Version table:
 *** 2.30.0.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

gwibber-service:
  Installed: 2.30.0.1-0ubuntu1
  Candidate: 2.30.0.1-0ubuntu1
  Version table:
 *** 2.30.0.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Description: Ubuntu lucid (development branch)
Release: 10.04
Codename: lucid

Joseph Montanez (sutabi) wrote :

I also deleted my ~/. and when i restarted it kept popping up. Deleting the accounts and re-adding them fixed it.

Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
status: New → Confirmed
Changed in gwibber:
importance: Undecided → High
Changed in gwibber:
status: New → Fix Committed

Accepted gwibber into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gwibber (Ubuntu Lucid):
status: New → Fix Committed
tags: added: verification-needed
areskz (areskz) wrote :

Proposed package works fine.

Martin Pitt (pitti) on 2010-05-24
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.30.0.1-0ubuntu3

---------------
gwibber (2.30.0.1-0ubuntu3) lucid-proposed; urgency=low

  * debian/patches/lp_569543.patch
    - Don't allow people to click "Add" before we have enough information
      from facebook to add the account (LP: #569543)

gwibber (2.30.0.1-0ubuntu2) lucid-proposed; urgency=low

  * debian/patches/handle_facebook_keyring.patch
    - Handle prompting the user to authorize gwibber to use facebook in cases
      where the account was synced and there is no local key stored in the
      keyring (LP: #571224)
  * debian/patches/dont_spawn_multiple_accounts_dialogs.patch
    - Don't fire gwibber-accounts for each failure, only spawn it
      once (LP: #564741)
 -- Ken VanDine <email address hidden> Mon, 03 May 2010 10:58:47 -0400

Changed in gwibber (Ubuntu Lucid):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to maverick, too.

Changed in gwibber (Ubuntu Maverick):
status: Confirmed → Fix Released
Omer Akram (om26er) on 2010-07-10
Changed in gwibber:
status: Fix Committed → Fix Released
Adrienne (rykasimba) wrote :

I am on 2.30.2 and this bug is back. I have 3 accounts. I have deleted and readded them and the broadcast accounts box comes up every time it synchs.

bettlebrox (micktimony) wrote :

Same problem for me with 2.30.2-0ubuntu3. Also, I don't even have Gwibber running and the popups occurs every few minutes and I have to find the pid of the process and kill it. Very annoying behaviour and I've purged it for the time being.

David Elliott (davidrelliott) wrote :

Same story - did a clean maverick install, restored home folder, and am now getting the account authorization popup on every sync, even though the account is listed as authorized.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers