Strings in the side panel are not translatable

Bug #538981 reported by Gabor Kelemen on 2010-03-15
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Ken VanDine
Ubuntu Translations
High
Unassigned
gwibber (Ubuntu)
Medium
Ken VanDine

Bug Description

Binary package hint: gwibber

The stream names in the side pane are not translatable. These are from the gwibber/gwui.py file, in the generate_streams function. The problem with these is that the stream names are expected to be untranslated:

    for stream in ["messages", "replies", "images", "private"]:
      items.append({
        "name": stream.capitalize(),

This is simply not localizable, we need proper _("Messages") _("Replies") etc calls.

      default_streams = self.services[account["protocol"]]["default_streams"]

      if len(default_streams) > 1:
        for feature in default_streams:
          aname = self.features[feature]["stream"]
          item["items"].append({
            "name": aname.capitalize(),

This is about the same, except that the names are coming in this case from the service descriptions under gwibber/microblog/

It is also interesting that when I marked the Search item for translation, the Search bar did not appeared anymore. Translating the Home and Sent items seemed to work with simple _() calls.

Victor Vargas (kamus) on 2010-03-16
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
Victor Vargas (kamus) wrote :

This definitely needs to be translated and need some code changes because is still happening under 2.29.92-1, in this moment would be great if Ken or Ryan could teleport to this place and take a look into code. Thanks!

Changed in gwibber (Ubuntu):
status: New → Confirmed
David Planella (dpm) on 2010-03-24
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
tags: added: gwibber-i18n
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Omer Akram (om26er) wrote :

Is this bug related to bug 520462?

Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → 2.30.0
Changed in gwibber:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.30.0-0ubuntu1

---------------
gwibber (2.30.0-0ubuntu1) lucid; urgency=low

  * New upstream release
    - gwibber crashed with KeyError in action() (LP: #520492)
    - Strings in the side panel are not translatable (LP: #538981)
    - Strings in the *mako templates are not translatable (LP: #538987)
    - gwibber crashed with AttributeError in action() (LP: #444654)
 -- Ken VanDine <email address hidden> Wed, 14 Apr 2010 16:22:09 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Omer Akram (om26er) on 2010-04-15
Changed in gwibber:
status: Fix Committed → Fix Released
Gabor Kelemen (kelemeng) wrote :

Reopening.
The situation improved, but still not perfect - see attached screenshot.

Changed in gwibber (Ubuntu):
status: Fix Released → Confirmed
Changed in gwibber:
status: Fix Released → Confirmed
David Planella (dpm) wrote :

As the "Search" string seems to be somewhat special, I've filed bug 567127 separately.

As for the remaining untranslatable strings (Messages, Replies, etc.):

    for stream in ["messages", "replies", "images", "private"]:
      items.append({
        "name": stream.capitalize(),

Perhaps deferred translations and the N_() macro could be used:

http://docs.python.org/library/gettext.html#deferred-translations

The other untranslatable strings I'm not sure where they are shown on the UI:

      default_streams = self.services[account["protocol"]]["default_streams"]

Ken, Ryan, is it ok to reopen this bug, or would you prefer a new one to track the remaining issues?

Gabor Kelemen (kelemeng) wrote :

"As for the remaining untranslatable strings (Messages, Replies, etc.):"

These were fixed here:
http://bazaar.launchpad.net/~gwibber-committers/gwibber/trunk/revision/727

"The other untranslatable strings I'm not sure where they are shown on the UI:"

They are visible on my screenshot - the same Messages, Replies, etc, strings, only that these are specific to the various providers and come from gwibber/microblog/util/const.py - here the internal, provider specific stream names are translated to the user visible names: http://bazaar.launchpad.net/%7Egwibber-committers/gwibber/trunk/annotate/head%3A/gwibber/microblog/util/const.py#L117

Ken VanDine (ken-vandine) wrote :

It's fine to re-open this. I have a patch locally localizing the streams from the protocols but haven't looked at search. This will have to wait though and go in as an update after lucid.

David Planella (dpm) wrote :

There are still a few untranslatable strings in Gwibber maverick (highlighted in the screenshot). Ken, is that patch to make them translatable still waiting in the queue? Thanks!

Ken VanDine (ken-vandine) wrote :

The streams localization fix had gone into trunk a while ago and been released, but was dropped in the branch merge merging in the sqlite branch. I have ported it to the new code and it will go out in the next release. I think I also have a fix for the search streams.

Changed in gwibber:
status: Confirmed → Fix Committed
milestone: 2.30.0 → 2.31.4
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.31.4-0ubuntu1

---------------
gwibber (2.31.4-0ubuntu1) maverick; urgency=low

  * New upstream release
    - Merged back in i18n fixes from before the sqlite merge, they seem to
      have gotten lost (LP: #538981)
    - Make "Lists" translatable
    - Make "Search" translatable
    - Order the result of new_items by time so we get notifications in the correct
      order (LP: #499323)
    - Only notify for the last 10 messages (except responses), as it is that is
      100 seconds of notifications displaying.
    - Always notify for responses (mentions)
    - Cache avatars for notifications and client (LP: #527446)
    - Fixed scrolling problems including scrollwheel support (LP: #611276)
  * debian/gwibber.desktop
    - Changed the key looked at for autostart
  * debian/control
    - Added depends on python-oauth, required for buzz
 -- Ken VanDine <email address hidden> Tue, 03 Aug 2010 16:27:45 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Omer Akram (om26er) on 2010-08-09
Changed in gwibber:
status: Fix Committed → Fix Released
David Planella (dpm) on 2010-08-09
Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers