Gwibber needs to create a translation template on build

Bug #525726 reported by David Planella on 2010-02-22
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Translations
High
Unassigned
gwibber (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gwibber

Gwibber needs to create a translation template during the build process, so it can be uploaded to Launchpad Translations and translators can do their work.

For more information, see:

 * https://wiki.ubuntu.com/UbuntuDevelopment/Internationalisation/Packaging#Translation%20templates
 * https://wiki.ubuntu.com/UbuntuDevelopment/Internationalisation/RecipeVerifyingTranslationUploads
 * https://wiki.ubuntu.com/Translations/Upstream

David Planella (dpm) on 2010-02-22
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → High
David Planella (dpm) on 2010-02-25
tags: added: needs-pot-on-build
David Planella (dpm) wrote :

I've built the package locally and the template is generated just fine.

I think the problem is just that gwibber might have gotten promoted to main with a no change upload. This might mean it simply needs to be rebuilt and uploaded.

I tried to manually upload translations in the meantime, but since gwibber still has no templates, I could only try with the lp-translations-tools (https://code.launchpad.net/~jtv/lp-translations-tools/trunk). However, when testing the upload, it seems that there is a problem when logging in to staging (OOPS on https://staging.launchpad.net/+login), so I could not do it (I don't want to mess around with the production servers without having tested that on staging).

In short, I think gwibber just needs to be rebuilt and uploaded again.

David Planella (dpm) wrote :

This will be fixed in the next few hours. After talking to pitti on #ubuntu-desktop, he uploaded a new package (no change upload) so that the template (and upstream translations) is imported.

pitti tells me that this was because: "the same version is both superseded and published in lucid, which means that its component was moved and I just happen to know that it moved from universe to main" -> https://edge.launchpad.net/ubuntu/+source/gwibber/+changelog

Note that there will still be some untranslatable strings until bug 520462 is fixed upstream and the changes integrated in the package.

David Planella (dpm) wrote :

Template approved and available at https://translations.launchpad.net/ubuntu/lucid/+source/gwibber

(It might take a few hours for the translations to be imported)

Changed in ubuntu-translations:
status: Triaged → Fix Released
Changed in gwibber (Ubuntu):
status: New → Fix Released
Victor Vargas (kamus) on 2010-03-08
Changed in gwibber (Ubuntu):
importance: Undecided → High
David Planella (dpm) on 2010-03-24
tags: added: gwibber-i18n
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers