gwibber crashed with KeyError in action()

Bug #520492 reported by Ted Gould on 2010-02-11
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Ken VanDine
gwibber (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gwibber

Clicking on Facebook links.

ProblemType: Crash
Architecture: i386
Date: Thu Feb 11 08:49:07 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/gwibber
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: gwibber 2.29.1-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.32-12.17-generic
PythonArgs: ['/usr/bin/gwibber']
SourcePackage: gwibber
Title: gwibber crashed with KeyError in action()
Uname: Linux 2.6.32-12-generic i686
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape video

Ted Gould (ted) wrote :
tags: removed: need-duplicate-check
Ted Gould (ted) on 2010-02-11
visibility: private → public
Victor Vargas (kamus) wrote :

What version of gwibber do you have? I tried to open some links of my facebook account and I am unable to reproduce this issue. Please could you upgrade your gwibber version to the latest included in Lucid and check if this issue is still affecting you? Thanks in advance!

Changed in gwibber (Ubuntu):
status: New → Incomplete

Version: 2.29.90.1
Social network: Facebook

I have the same problem when I click the send time

Victor Vargas (kamus) wrote :

You are right @guigui, if I click on sender time and now I am able to reproduce this issue under Lucid too. Also I tried to reproduce this using gwibber daily version (up to date) and I don't get a crash but output this message:

ERROR:dbus.proxies:Introspect error on com.Gwibber.Accounts:/com/gwibber/Accounts: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name com.Gwibber.Accounts was not provided by any .service files
ERROR:dbus.proxies:Introspect error on com.Gwibber.Streams:/com/gwibber/Streams: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.ServiceUnknown: The name com.Gwibber.Streams was not provided by any .service files
Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/gwibber/client.py", line 367, in on_action
    getattr(actions, cmd).action(None, self, **query)
  File "/usr/lib/python2.6/dist-packages/gwibber/actions.py", line 111, in action
    util.load_url(msg["url"])
KeyError: 'url'

Anthony Hook (anthonyhook) wrote :

I'm having this issue on Lucid with the repo-version.

Michael B. Trausch (mtrausch) wrote :

I echo Anthony Hook.

I have marked the bug as confirmed.

Changed in gwibber (Ubuntu):
status: Incomplete → Confirmed
Victor Vargas (kamus) on 2010-03-05
Changed in gwibber (Ubuntu):
importance: Undecided → Medium
Victor Vargas (kamus) wrote :

Please could you upgrade to latest version of gwibber (2.29.92) and check if this problem is still affecting you? I have checked this and now works fine! Thanks!

Changed in gwibber (Ubuntu):
status: Confirmed → Incomplete

It's work in publication but in Image I have a problem too by clicking on the time (I think it's the same bug) in PPA version 3.31.1bzr676

Victor Vargas (kamus) on 2010-03-18
Changed in gwibber (Ubuntu):
status: Incomplete → Confirmed
Victor Vargas (kamus) wrote :

This problem is still occuring just like @guigi14100 said.

Changed in gwibber:
milestone: none → 2.30.0
Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.30.0-0ubuntu1

---------------
gwibber (2.30.0-0ubuntu1) lucid; urgency=low

  * New upstream release
    - gwibber crashed with KeyError in action() (LP: #520492)
    - Strings in the side panel are not translatable (LP: #538981)
    - Strings in the *mako templates are not translatable (LP: #538987)
    - gwibber crashed with AttributeError in action() (LP: #444654)
 -- Ken VanDine <email address hidden> Wed, 14 Apr 2010 16:22:09 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Changed in gwibber:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers