Avatars don't appear

Bug #455943 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2009-10-20
8
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gwibber (Ubuntu)
Medium
Alexander Sack

Bug Description

Binary package hint: gwibber

I see no avatars in gwibber. I uninstalled completely, removed config...

rm -rf .cache/gwibber/
rm -rf .gconf/apps/gwibber/

Reinstalled, setup accounts for twitter, identica, facebook, friendfeed..

See screenshot..

ProblemType: Bug
Architecture: i386
Date: Tue Oct 20 01:45:42 2009
DistroRelease: Ubuntu 9.10
Package: gwibber 2.0.0~bzr467-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic-pae
SourcePackage: gwibber
Uname: Linux 2.6.31-14-generic-pae i686
XsessionErrors:
 (gnome-settings-daemon:2309): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2444): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2437): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (Do:2459): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
 (gnome-panel:2436): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

This may seem like a totally unrelated issue but what graphics chipset/driver do you use?

I have two machines here, on the one using an intel chipset, I see this, with the nvidia driver, I don't - all else seems identical.

Also, if you can post rpm -qa | grep python ; rpm -q gwibber

Thanks

I use an Thinkpad Laptop with Intel Graphics (i965) using the i915 driver - and run it as 64-bit x86-64 system.

$ rpm -qa | grep python ; rpm -q gwibber
python-lxml-2.2.2-1.6.x86_64
python-xdg-0.17-2.2.x86_64
python-serial-2.4-4.2.noarch
python-gnome-menus-2.27.92-1.1.x86_64
xchat-python-2.8.6-43.14.x86_64
python-openssl-0.9-1.3.x86_64
libxml2-python-2.7.3-1.12.x86_64
python-urlgrabber-3.1.0-181.2.noarch
python-xml-2.6.2-5.4.x86_64
python-coherence-0.6.4-3.2.x86_64
python-orbit-2.24.0-1.4.x86_64
python-kdebase4-4.3.1-3.1.x86_64
python-gtk-2.16.0-1.1.x86_64
python-crypto-2.0.1-198.12.x86_64
python-beaker-1.4-1.1.noarch
python-feedparser-4.1-1.1.noarch
python-gdata-2.0.1-2.1.noarch
python-numpy-1.3.0-1.20.x86_64
python-gtkglext-1.1.0-109.7.x86_64
python-base-2.6.2-5.4.x86_64
python-tk-2.6.2-5.2.x86_64
python-opengl-3.0.0-1.2.noarch
gimp-plugins-python-2.6.7-3.2.x86_64
python-qt4-4.5.4-3.14.x86_64
python-gobject2-2.20.0-1.1.x86_64
python-cups-1.9.42-4.72.x86_64
python-cairo-1.8.6-1.1.x86_64
python-egenix-mx-base-3.1.2-1.1.x86_64
rpm-python-4.7.1-5.1.x86_64
libpython2_6-1_0-2.6.2-5.4.x86_64
python-curses-2.6.2-5.2.x86_64
python-cupshelpers-1.1.12-1.4.x86_64
gnome-python-desktop-2.27.3-1.4.x86_64
python-simplejson-2.0.9-1.5.x86_64
python-smbc-1.0.6-2.16.x86_64
python-setuptools-0.6c9-3.2.noarch
python-pam-0.5.0-68.8.x86_64
python-twisted-8.2.0-2.26.x86_64
python-webkitgtk-1.1.6-2.3.x86_64
python-gtksourceview-2.8.0-1.1.x86_64
python-gstreamer-0_10-0.10.16-1.5.x86_64
python-louis-1.7.0-1.1.x86_64
python-compizconfig-0.7.8-1.90.x86_64
python-mako-0.2.4-1.1.noarch
python-imaging-1.1.6-213.1.x86_64
python-zopeinterface-3.3.0-108.8.x86_64
python-gnome-2.28.0-1.1.x86_64
python-httplib2-0.5.0-2.2.noarch
python-kde4-4.3.1-2.4.x86_64
python-sip-4.8.2-3.1.x86_64
python-2.6.2-5.2.x86_64
python-satsolver-0.14.8-2.4.x86_64
python-notify-0.1.1-5.31.x86_64
dbus-1-python-0.83.0-27.5.x86_64
gwibber-1.2.0+bzr358-3.1.noarch

Doesn't seem to be something in the python stack - I have matching stacks on both machines. Nothing's changed in the gwibber in Factory - I'm actually using the trunk version from my own project on both my machines.

Something must have changed 'higher up' and I suspect it may be something to do with the xorg driver. I recall that the xorg stack in X11:Xorg changed so that on my nvidia machine, I could no longer compile the (slightly antiquated) version I was using and had to switch to the official packages - something about an ABI change.

I know it's a long shot but wondering whether sndirsch can help?

(Sorry, wasn't clear - meant that that Xorg change happened when I noticed images vanish and between M7 and M8)

Changes between M7 and M8:

- libdrm: No changes.
- Mesa: update from stable release 7.5 to stable bugfix release 7.5.1
- xorg-x11-server: update to 1.6.4 (bugfixes + removal of DGA framebuffer
  support)
- xorg-x11-driver-video: update to intel driver prerelease 2.8.99.902

Most likely it is related to the intel driver update. Please verify by downgrading xorg-x11-driver-video package to the one of M7.

The issue happens with and without KMS? Did you change to KMS with M8?

I'm on 11.1 so I'd need an old package from the OBS - is there one anywhere? Otherwise, Andreas, can you try with the M7 package on your system?

(KMS?)

(In reply to comment #6)
> I'm on 11.1 so I'd need an old package from the OBS - is there one anywhere?

No.

> Otherwise, Andreas, can you try with the M7 package on your system?

Of course Andeas, since he reported the bug report.

> (KMS?)

Kernel Mode setting. Andreas knows what I'm talking about. :-)

Guys, you're great!

downgrading to xorg-x11-driver-video-7.4-81.1.x86_64.rpm (from M7) fixes the problem for me.

KMS does not make a difference.

In that case this issue can easily be git bisected. Andreas, can you do this yourself? Instructions on

  http://www.x.org/wiki/radeonhd#head-21026d3aec5e838d5692e50e28dc304567b274c9

(replace radeonhd with intel; make sure the freshly built driver is used)

Stefan, what are the parameters for [good] and [bad] so that I can start the bisect?

I'm using 2.8.1 and 2.9.0 now for the bisect.

The culprit is:
Author: Chris Wilson <email address hidden> 2009-09-20 02:02:39
Committer: Chris Wilson <email address hidden> 2009-09-20 02:15:41
Parent: 33f98e4056706f4c30bb4327677ac49e82058231 (Don't destroy bufmgr at CloseScreen time)
Branches: master, remotes/origin/master
Follows: 2.8.99.901
Precedes: 2.8.99.902

    Avoid fallbacks for a1 src/mask

    Carl Worth did the hard work in identifying that the regression in
    cairo between X.org 1.6 and 1.7 was caused by cairo sending an a1
    mask to the server in 1.7 whereas in 1.6 cairo used local fallbacks
    (as the source was using RepeatPad, which triggers cairo's
    'buggy_pad_reflect' fallback for X.org 1.6). This was causing the driver
    to do a fallback to handle the a1 mask instead, which due to the GPU
    pipeline stall is much more expensive than the equivalent fallback in
    cairo.

    Reference:
      cairo's performance downgrades 4X with server master than server-1.6.
      https://bugs.freedesktop.org/show_bug.cgi?id=23184

    The fix is a relatively simple extension of the current
    uxa_picture_from_pixman_image() to use CompositePicture() instead of
    CopyArea() when we need to convert to a new format.

    Signed-off-by: Chris Wilson <email address hidden>

For reference:
$ git bisect log
# bad: [2841a4cd8c6c64fdf4b2203ab73b57b38a50f651] Increment version to 2.9.0
# good: [e6105d978a0217219cb2d60a672ae200c70bc68d] Increment version number to 2.8.1 for release.
git bisect start '2.9.0' '2.8.1'
# good: [5d50a949b3c5d0ad2bc4cf48ab25da1f707a4f6f] Increment version number to 2.8.0 for release.
git bisect good 5d50a949b3c5d0ad2bc4cf48ab25da1f707a4f6f
# good: [e51126c57132492c664f86981c55b166dbb54c79] Add cursor registers to debug dump output.
git bisect good e51126c57132492c664f86981c55b166dbb54c79
# good: [c2abfa8e54acab61250dba1e435760e3b1499c8c] Avoid fallbacks for compositing gradient patterns
git bisect good c2abfa8e54acab61250dba1e435760e3b1499c8c
# bad: [bd817e2d733dfdb1140874b06595ccd1ef39159b] Split i915/i830 composite_emit_primitive into two functions.
git bisect bad bd817e2d733dfdb1140874b06595ccd1ef39159b
# bad: [57fc09cef28bad2e3e8455b93ef2927118f8a3a3] Avoid fallbacks for a1 src/mask
git bisect bad 57fc09cef28bad2e3e8455b93ef2927118f8a3a3
# good: [ee9ad853574e3ee1a210db6207b84ecd466e08ee] Make sure DRM output properties are freed after we're done with them.
git bisect good ee9ad853574e3ee1a210db6207b84ecd466e08ee
# good: [33f98e4056706f4c30bb4327677ac49e82058231] Don't destroy bufmgr at CloseScreen time
git bisect good 33f98e4056706f4c30bb4327677ac49e82058231

Created an attachment (id=321820)
screenshot showing images - as it should be

Thanks a lot for bisecting that issue.

Committed upstream report http://bugs.freedesktop.org/show_bug.cgi?id=24478

SR'ed to openSUSE:Factory.

Binary package hint: gwibber

I see no avatars in gwibber. I uninstalled completely, removed config...

rm -rf .cache/gwibber/
rm -rf .gconf/apps/gwibber/

Reinstalled, setup accounts for twitter, identica, facebook, friendfeed..

See screenshot..

ProblemType: Bug
Architecture: i386
Date: Tue Oct 20 01:45:42 2009
DistroRelease: Ubuntu 9.10
Package: gwibber 2.0.0~bzr467-0ubuntu1
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic-pae
SourcePackage: gwibber
Uname: Linux 2.6.31-14-generic-pae i686
XsessionErrors:
 (gnome-settings-daemon:2309): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2444): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2437): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (Do:2459): Wnck-CRITICAL **: wnck_set_client_type got called multiple times.
 (gnome-panel:2436): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window

Laura Czajkowski (czajkowski) wrote :

1-2 avatars come through in gwibber but all the rest are blank.
DistroRelease: Ubuntu 9.10
Package: gwibber 2.0.0~bzr467-0ubuntu1

Alan Bell (alanbell) wrote :

for me at least commenting out line 51 of /usr/share/gwibber/ui/templates/defaultcss.mako fixed it

  background-image: url('');
  background-repeat: no-repeat;
/* -webkit-border-radius: 3px;
*/ -webkit-box-reflect:below 0px -webkit-gradient(linear, left top, left bottom, from(transparent)$
}

Changed in gwibber (Ubuntu):
status: New → Confirmed
Alan Bell (alanbell) wrote :

it works perfectly on another machine. Could the rendering be graphics card dependent? The one it didn't work on for me is an Intel chipset.

I tried commenting out line 51 as per Alans comment #3 and refreshed, and magically all the piccies came back

Alexander Sack (asac) wrote :

will unpatch the round border thing in our package for karmic to fix this for affected users (not upstream as this is a webkit or even X driver bug)

Changed in gwibber (Ubuntu):
assignee: nobody → Alexander Sack (asac)
importance: Undecided → Medium
status: Confirmed → In Progress
Alexander Sack (asac) wrote :

------------------------------------------------------------
revno: 81
committer: Alexander Sack <email address hidden>
branch nick: packaging
timestamp: Fri 2009-10-23 02:21:32 +0200
message:
  * remove round borders from css to fix invisible avatars for some graphic drivers (LP: #455943)
    - add debian/patches/01_lp455943.patch

Changed in gwibber (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.0.0~bzr476-0ubuntu1

---------------
gwibber (2.0.0~bzr476-0ubuntu1) karmic; urgency=low

  * new upstream snapshot - r476
    - fixes multithreading issues in gwibber-daemon probably causing a lot of random issues
    - reduce number of threads to minimum by running OperationManager and OperatinResultHandler
      run in glib mainloop
    - fix flickr time parsing issues that can trigger random sorting of messages in frontend
    - fix digg time parsing issues that can trigger random sorting of messages in frontend
    - quit gwibber daemon if you explicitly quit gwibber UI
  * remove round borders from css to fix invisible avatars for some graphic drivers (LP: #455943)
    - add debian/patches/01_lp455943.patch

 -- Alexander Sack <email address hidden> Fri, 23 Oct 2009 10:48:06 +0200

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released

According to upstream, this should be finally fixed with the 2.9.1 driver. Andreas, can you try drivers from X11:XOrg buildservice or latest FACTORY?

I've installed from X11:Xorg the package xorg-x11-driver-video-7.4-136.1.x86_64 which contains the intel 2.9.1 driver and gwibber shows all images perfectly.

Thanks!

James Ogley (riggwelter) wrote :

See https://bugzilla.novell.com/show_bug.cgi?id=545499 - this is an X server bug which is fixed in the latest upstream intel driver, I'll unpatch this in the openSUSE packages like the Karmic ones.

Alessio Caiazza (nolith) wrote :

I'm having this bug using lucid with Xming for remote login from a windows workstation.

How can I provide more infomation?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.