gwibber crashed with AttributeError in action()

Bug #444654 reported by Mike Linksvayer on 2009-10-06
714
This bug affects 140 people
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Ken VanDine
gwibber (Ubuntu)
High
Ken VanDine

Bug Description

Binary package hint: gwibber

Clicked "like" from individual status message context menu (invoked by clicking gears icon), program crashed.

Program should not have crashed. :)

$ lsb_release -rd
Description: Ubuntu karmic (development branch)
Release: 9.10

$ apt-cache policy gwibber
gwibber:
  Installed: 2.0.0~bzr449-0ubuntu1
  Candidate: 2.0.0~bzr449-0ubuntu1
  Version table:
 *** 2.0.0~bzr449-0ubuntu1 0
        500 http://us.archive.ubuntu.com karmic/universe Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
Architecture: i386
Date: Tue Oct 6 08:51:11 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gwibber
InterpreterPath: /usr/bin/python2.6
Package: gwibber 2.0.0~bzr449-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-11.36-generic
PythonArgs: ['/usr/bin/gwibber']
SourcePackage: gwibber
Title: gwibber crashed with AttributeError in action()
Traceback:
 Traceback (most recent call last):
   File "/usr/lib/python2.6/dist-packages/gwibber/actions.py", line 77, in action
     msg.ausernameount.get_client().like(msg)
 AttributeError: 'dbus.String' object has no attribute 'get_client'
Uname: Linux 2.6.31-11-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner video

tags: removed: need-duplicate-check
visibility: private → public
Foppe Hemminga (foppe) wrote :

I report identical error and it's reproducible in my setup.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Pedro Villavicencio (pedro) wrote :

confirming here, same crash with bzr version.

Changed in gwibber (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged

Moving priority to High (regression).

Also, just for completeness, still present in gwibber 2.0.0~bzr476-0ubuntu3 in Lucid.

Changed in gwibber (Ubuntu):
importance: Medium → High
tags: added: metabug
Nicolas DERIVE (kalon33) on 2010-02-11
tags: added: regression-potential

Same problem on 2.29.90.1

nick name (nick-name) wrote :

Want to delete a post

Randall Ross (randall) wrote :

Crashed while trying to delete a post.

jsterr (jonas-sterr) wrote :

Crashed while trying to delete a post [2]

The button like works in version 2.29.91 bzr654

The button delete this message works in version 2.29.91 bzr654

Omer Akram (om26er) wrote :

Thanks guigui14100 for that last comment. marking fix committed as per last comment

Changed in gwibber (Ubuntu):
status: Triaged → Fix Committed
Changed in gwibber:
status: New → Fix Committed
Omer Akram (om26er) wrote :

fixed in gwibber 2.29.92 if any one still face this feel free to open this bug again

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released
Changed in gwibber:
status: Fix Committed → Fix Released
Omer Akram (om26er) wrote :

I get this when I click on "view reply thread"

Changed in gwibber:
status: Fix Released → Confirmed
Changed in gwibber (Ubuntu):
status: Fix Released → Triaged
Omer Akram (om26er) wrote :

I am using gwibber 2.29.92

"I get this when I click on "view reply thread""
Same problem in version 2.31.1bzr676

description: updated
marcog (marc-garrison) wrote :

I get this error only when choosing "View reply thread." Choosing any other action launches Firefox.

patman023 (patman023) wrote :

View reply thread, on a Facebook post.

Pedro Villavicencio (pedro) wrote :

This is pretty easy to reproduce with the "View reply thread" on a facebook account:

Traceback (most recent call last):
  File "/usr/lib/python2.6/dist-packages/gwibber/actions.py", line 38, in action
    tab_label = msg.original_title if hasattr(msg, "original_title") else msg.text
AttributeError: 'dict' object has no attribute 'text'

nick (kcin1204) wrote :

crashed when i was in "facebook" i wanted to view a message thread. As soon as i pushed the button it crashed. Thanks for all the help guys!

tags: added: bugpattern-needed
solid_liq (miketdean) wrote :

This same bug is also in the amd64 version, which is why I originally posted a separate report for this which was subsequently marked as a duplicate.

Adam (brainpwranimation) wrote :

I get the crash from clicking 'View Reply Thread'

Z37A (juanzele) wrote :

Also affecting the AMD64 architecture

I also get this crash under Lucid with the daily build of yesterday.

I update system today. Program don't show 'reply thread', but don't crashed.

XuMuK (xumuk37) wrote :

Get it on "view reply thread".

JCollierDavis (jcollierdavis) wrote :

Mine crashed when clicked the "View Reply Thread"

tags: added: bugpattern-written
removed: bugpattern-needed
Anthony Batchelor (toeknee) wrote :

I also get this from clicking 'View Reply Thread'

godfromabove (geoffhudson) wrote :

Get this too when pressing View Reply Thread,
Also reply thread not upto date with version on firefox (even after force sync)

Crashed when clicking 'View Reply Thread' on Lucid

iamjabour (iamjabour) wrote :

crashed when I click in set up broadcast button.

iamjabour (iamjabour) wrote :

using

Description: Ubuntu lucid (development branch)
Release: 10.04

gwibber:
  Installed: 2.29.95-0ubuntu2
  Candidate: 2.29.95-0ubuntu2
  Version table:
 *** 2.29.95-0ubuntu2 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Same error when deleting a post

Strung (strung3) wrote :

Same error when asking all replies of a messsage on facebook

Diego Garcia (diego-xaethos) wrote :

Beating a dead horse: Crashes when clicking "View reply thread" on a Facebook message. Every other action works fine. Using Gwibber 2.29.95 on Lucid beta 2.

Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → 2.30.0
status: Confirmed → Fix Committed
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Linus C Unneback (linusu) wrote :

I was experimenting a bit and edited "/usr/lib/python2.6/dist-packages/gwibber/actions.py" at line 38. Instead of using msg.text I tried with msg['text'] since the error suggested that msg was of the type 'dict'. To correctly fix this line one needs to change everything on that line to:

tab_label = msg["original_title"] if "original_title" in msg else msg["text"]

Unfortunate, fixing this line makes makes the program crash on the next line instead.

AttributeError: 'GwibberClient' object has no attribute 'add_transient_stream'

Hope that it helps //Linus Unnebäck

Ken VanDine (ken-vandine) wrote :

Yeah, this is fixed in trunk and the 2.30 branch which will be released today or tomorrow. We actually had to remove the thread action, since it was never implemented in the 2.29 re-write.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.30.0-0ubuntu1

---------------
gwibber (2.30.0-0ubuntu1) lucid; urgency=low

  * New upstream release
    - gwibber crashed with KeyError in action() (LP: #520492)
    - Strings in the side panel are not translatable (LP: #538981)
    - Strings in the *mako templates are not translatable (LP: #538987)
    - gwibber crashed with AttributeError in action() (LP: #444654)
 -- Ken VanDine <email address hidden> Wed, 14 Apr 2010 16:22:09 -0400

Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Omer Akram (om26er) on 2010-04-15
Changed in gwibber:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers