gwibber crashed with DBusException in call_blocking()

Bug #422726 reported by Rick Spencer on 2009-09-01
212
This bug affects 46 people
Affects Status Importance Assigned to Milestone
gwibber (Ubuntu)
High
Ken VanDine

Bug Description

Binary package hint: gwibber

Seemed to occur when selecting a gwibber message from the new indicator applet.

ProblemType: Crash
Architecture: i386
Date: Tue Sep 1 11:15:25 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/gwibber
InterpreterPath: /usr/bin/python2.6
Package: gwibber 2.0.0~bzr396-0ubuntu1
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gwibber
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
PythonArgs: ['/usr/bin/gwibber']
SourcePackage: gwibber
Title: gwibber crashed with DBusException in call_blocking()
Uname: Linux 2.6.31-9-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers

tags: removed: need-duplicate-check
Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Alexander Sack (asac) wrote :

problem is missing exception handling for various dbus method calls. I think this requires some effort to for real everywhere as the dbus method calls are spread all around the code atm.

visibility: private → public
Changed in gwibber (Ubuntu):
status: New → Triaged
Alexander Sack (asac) wrote :

i created a MASTER bug to track all the call_blocking crashes. its bug 439325 ... I would suggest to merge all individual bugs into that as fixing all places that do a dbus call does not feel sustainable.

anyway, leave decision to ken.

Changed in gwibber (Ubuntu):
importance: Undecided → High
Ken VanDine (ken-vandine) wrote :

Thanks, good idea. I have done some work adding more exception handling, but I am having a problem getting dbus to connect again when it fails. I also want to make the dbus calls between the backend and frontend follow name changes, but that isn't working as the API advertises. I should be close though...

Changed in gwibber (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.0.0~bzr465-0ubuntu1

---------------
gwibber (2.0.0~bzr465-0ubuntu1) karmic; urgency=low

  * New upstream snapshot - r465
    - Fixes for dbus call blocking crashes (LP: #422726) (LP: #434833)
    - dbus client and server now follow name changes (LP: #439325) (LP: #434592)
    - Remember previous window size and position (LP: #422525)
    - Remember previous account tree splitter position
    - Remember previous input area size
    - Do not change input area height when resizing main window (LP: #422532)
    - Version themes to ensure only compatible themes are available
    - fix dict handling for facebook replies (LP: #436690)
    - facebook now uses pycurl instead of urllib2, fixes hangs (LP: #422864)
  * debian/preinst:
    - Moved from debian/postinst and added version compare
  * debian/control:
    - depend on python-pycurl, urllib2 was causing terrible problems
      with facebook (LP: #422864)

 -- Ken VanDine <email address hidden> Sun, 04 Oct 2009 20:40:40 -0400

Changed in gwibber (Ubuntu):
status: Fix Committed → Fix Released

I'm still suffering this! I'm with the last gwibber version, 2.0.0~bzr465-0ubuntu1.

Forget what I said, bug fixed. After update, i was still suffering from that, but after restart i didn't see this bug anymore.

hanzomon4 (hanzomon4) wrote :

I'm still getting this... and I'm all updated

®om (rom1v) wrote :

I have the same problem, with the last upgrades…

Patrick Nell (patrick-nell) wrote :

I, too, am still getting this... I'm using amd64 - it's not only i386.

Martin Albisetti (beuno) wrote :

This still happens with the latest and greatest. See dupe bug #455892

Changed in gwibber (Ubuntu):
status: Fix Released → New
Alexander Sack (asac) wrote :

martin, can you bzr branch lp:gwibber ... then kill your gwibber and run killall gwibber-daemon
then use ./bin/gwibber-daemon ... and in another terminal ./bin/gwibber in the branch and see if its fixed?

Hi Alexanderi try it later .. thanks .. ;)

2009/10/22 Alexander Sack <email address hidden>

> martin, can you bzr branch lp:gwibber ... then kill your gwibber and run
> killall gwibber-daemon
> then use ./bin/gwibber-daemon ... and in another terminal ./bin/gwibber in
> the branch and see if its fixed?
>
> --
> gwibber crashed with DBusException in call_blocking()
> https://bugs.launchpad.net/bugs/422726
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in “gwibber” package in Ubuntu: New
>
> Bug description:
> Binary package hint: gwibber
>
> Seemed to occur when selecting a gwibber message from the new indicator
> applet.
>
> ProblemType: Crash
> Architecture: i386
> Date: Tue Sep 1 11:15:25 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/gwibber
> InterpreterPath: /usr/bin/python2.6
> Package: gwibber 2.0.0~bzr396-0ubuntu1
> PackageArchitecture: all
> ProcCmdline: /usr/bin/python /usr/bin/gwibber
> ProcEnviron:
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
> PythonArgs: ['/usr/bin/gwibber']
> SourcePackage: gwibber
> Title: gwibber crashed with DBusException in call_blocking()
> Uname: Linux 2.6.31-9-generic i686
> UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare vboxusers
>

André Gondim (andregondim) wrote :

I still have the same problem, with the last upgrades…

Foppe Hemminga (foppe) on 2009-10-23
Changed in gwibber (Ubuntu):
status: New → Confirmed
blogdudel (blogdudel) wrote :

Fixed in Version 477 ? i get no Error again .. !!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers