Ubuntu

Honor gnome proxy setting

Reported by Ken VanDine on 2008-08-20
672
This bug affects 121 people
Affects Status Importance Assigned to Milestone
Gwibber
Wishlist
Ken VanDine
gwibber (Ubuntu)
Wishlist
Unassigned

Bug Description

Currently gwibber seems to expect a direct connection to the net, no use of a proxy. Gwibber should really query gnome for proxy information and use it for connecting to the net. You could also consider using libproxy.

Jorge O. Castro (jorge) on 2008-08-21
Changed in gwibber:
status: New → Confirmed
bigbrovar (bigbrovar) wrote :

true it would be nice if proxy support is added to gwibber for many of use who are behind a network proxy

David Morris (dave-greenacre) wrote :

This would be great, as I'm unable to use it until this is implemented.

seoinin (seoinin) wrote :

Hi folks,
I also would love proxy support for gwibber as I cannot use it on my work network without going through a proxy.
Thanks
John

Changed in gwibber:
importance: Undecided → Medium
zzz (oldman-deactivatedaccount) wrote :

Unfortunately there is a problem upstream with using proxies via urllib2 for secure https connections -- http://bugs.python.org/issue1424152

Therefore, to fix this bug, we would also need to switch to only using http methods when the proxy is enabled.

Ali Ross (gnu2tux) wrote :

me too! - Can't use gwibber without proxy honouring!

FuePi (fuepi) wrote :

Was thrilled to find gwibber as one of the few non-air, multi-account twitter-able apps.
IMHO this is a major bug as it prevents me and others from using gwibber at all.

Implementing the usual behavior, i.e. let the user choose between using system proxy settings or providing a proxy host/script, would improve the usability a lot.

Appreciating your great work,
FuePi

Mehall (mehall) wrote :

I can't wait till the upstream bug is resolved. it's at "patch testing" just now, and I hope it can get rolled out soon!

Ryan Paul (segphault) wrote :

This is supposedly fixed upstream in Jaunty. Can anyone confirm that or let me know what the status is in other distros?

FuePi (fuepi) wrote :

On a clean install of Jaunty "apt-get install gwibber" installs gwibber 0.8.0, on Intrepid I have gwibber 0.9.2. Neither one supports/recognizes my network proxy setting.

Thijs Thiessens (t-thiessens) wrote :

Im using ubuntu on Jaunty. Gwibber just stops responding to anything if you are behind a proxy. It doesn't respect the gnome proxy setting. This means I can not use it @ work! :) The program looks nice though! ;)

2GooD (david+launchpad) wrote :

This was fixed in Python 2.6 only days ago: http://svn.python.org/view?view=rev&revision=72880

Gwibber through proxy will work when we get the patch in included in Python, either through an upstream release or as an Ubuntu patch.

I patched httplib.py and urllib.py locally and now I'm tweeting through a proxy! (@davideriksson)

Jonathan Lumb (jonolumb) wrote :

Look forward to this one rolling out - Gwibber is my preferred Twitter interface for Gnome as it is one of the few "native" apps available. However, I live in China and the government has recently blocked access to Twitter - so I can no longer use Gwibber as there is no proxy support available. A great shame... I'll have to use a firefox extension for the time being, not exactly ideal!

Alexander Sack (asac) wrote :

is this still a problem in current karmic gwibber (or in current gwibber.daily?)

Changed in gwibber (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Alexander Sack (asac) wrote :

setting upstreamed bugs to "Triaged"

Changed in gwibber (Ubuntu):
status: Confirmed → Triaged
Dalton Scavassa (daltux) wrote :

<quote>
is this still a problem in current karmic gwibber (or in current gwibber.daily?)
</quote>

Yes, it's still an issue here with 1.2.0~bzr346-0ubuntu1~daily1~jaunty

this is still a problem on debian squeeze with trunk gwibber.

Salil (hellfeuer) wrote :

gwibber works fine with a proxy for me.

I launch it from a terminal that has http_proxy and https_proxy set.

FuePi (fuepi) wrote :

Still an issue on Ubuntu 9.04 with Gwibber 0.9.2.

$ env|grep proxy
http_proxy=http://proxy-001:3128
https_proxy=http://proxy-001:3128
$ gwibber &

This produces the error
"retrieve messages HTTPError: HTTP Error 400: Bad Request"
for the protocol twitter.

Salil (hellfeuer) wrote :

Ok it works for me with facebook and gmail, and both use https.

I think this may be happening because twitter.py sets the headers argument explicitly. In which case the solution is to simply move the authorization into the url (https://username:pass@blah), and allow urllib to set the headers appropriately (which is what I do with gmail, and it seems to work).

Unfortunately I don't have a twitter account so I can't try this out.

Lionel Dricot (ploum) wrote :

Confirming that twitter and identi.ca still don't work with the latest karmic. Sad...

Did anyone try the fix I suggested?

On Tue, Oct 13, 2009 at 4:40 PM, Lionel Dricot <email address hidden> wrote:

> Confirming that twitter and identi.ca still don't work with the latest
> karmic. Sad...
>
> --
> Honor gnome proxy setting
> https://bugs.launchpad.net/bugs/259830
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Lionel Dricot (ploum) wrote :

helifeuer > I use a proxy without autorisation (no login needed) so I don't see what I could change.

Salil (hellfeuer) wrote :

That shouldn't matter.

Use https://username:<email address hidden> in the 'connect' method, where
username and password are your twitter username and pass (I'm not suggesting
you hard code this.. use self.get_auth(), but prepend the info to the url
instead of instead of passing it as the headers argument in urllib2.urlopen)

If you do this, and if you https_proxy is set correctly, then urllib2 should
do the rest.

On Tue, Oct 13, 2009 at 5:38 PM, Lionel Dricot <email address hidden> wrote:

> helifeuer > I use a proxy without autorisation (no login needed) so I
> don't see what I could change.
>
> --
> Honor gnome proxy setting
> https://bugs.launchpad.net/bugs/259830
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Pezz (p3zz) wrote :

Running Ubuntu 9.10 / karmic final and both the version of Gwibber in the normal repo, and the daily repo version (2.0.0-bzr478-0ubuntu2~daily1) do not work via a proxy (squid proxy auth required).

* Setting the Gnome Network Proxy setting has no effect.
* Exporting http_proxy and https_proxy in a terminal then running it has no effect.
* Made a script, exported those two vars, then run Gwibber and it does not work.

Tailing the access log of Squid shows Gwibber isn't even trying to connect to the proxy.

At this time, unless you have direct Internet access, it appears you cannot use Gwibber. Weird thing is, exporting those vars used to work (before version 2).

Would be great to see this fixed and working.

Pezz (p3zz) wrote :

Sorry, typo: I meant to say "(squid proxy, no auth required)"

Pezz (p3zz) wrote :

In the latest nightly (490) either http_proxy or https_proxy is working. I can get my Twitter feed, but without images and Facebook still does not work at all.

Ken VanDine (ken-vandine) wrote :

Ryan: Could this be related to the different modules using a different lib for getting messages? Like facebook using pycurl and twitter using urllib2?

Changed in gwibber:
assignee: nobody → Ryan Paul (segphault)
2GooD (david+launchpad) wrote :

@Pezz: I have filed https://bugs.launchpad.net/gwibber/+bug/487477 about missing images for the Twitter feed.

Pezz (p3zz) wrote :

@2GooD: When using Gwibber nightly (490) from home, no proxy, I see Twitter images fine, and Facebook works.

Images are only missing from Twitter when I need to go via a proxy, so I guess it's related to this bug.

oliwek (oliwek2) wrote :

I have the same problem here at work behind a proxy (Lucid daily build, gwibber 2.0.0)... that's really a pity after having used to such an alternative for both twitter and identi.ca
Launching it from terminal with http_proxy and https_proxy set doesn't help either....

Mehdi Hassanpour (mehdi) wrote :

after export http_proxy I run "gwibber-daemon" in one terminal and "gwibber" in another terminal. This is the only way I found to have gwibber running...

Jamal Fanaian (jamalta) wrote :

This still doesn't seem to be working (at least not using a socks proxy, haven't tested HTTP). The way I am testing it is by setting a proxy in Gnome, and shutting down the proxy connection. Gwibber is still able to get the data although other applications (tested with Chromium) are not, since they are relying on the proxy configuration.

Jamal Fanaian (jamalta) wrote :

It seems like this is an issue with most applications in Gnome, not just Gwibber (bug #479630).

godavid (godavid) wrote :

+1. I really need proxy feature in gwibber too.

Ryan Paul (segphault) on 2010-03-08
Changed in gwibber:
milestone: none → 3.0

This is first version of the patch to add GNOME proxy settings support. Several notes:
* Would be nice to test it with different proxy authentications, set CURLAUTH_ANY to get most secure way, but not sure how properly it works;
* Facebook client activation page doesn't work, should take a look;

Omer Akram (om26er) on 2010-03-25
tags: added: patch

Rudamentary patch for proxy support using libproxy (it checks for proxies supporing url, if there is none, proxy is not set. If there is authentification, it sets curl to autodetection for most secure method). Facebook widget is another target, but it uses webkit so it will be more complicated.

Changed in gwibber (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
samurailink3 (samurailink3) wrote :

Still an issue on 10.04:
Linux Macaroni 2.6.32-19-generic #28-Ubuntu SMP Wed Mar 31 17:46:20 UTC 2010 i686 GNU/Linux

Amaeth (dfoxpro) wrote :

>godavid wrote on 2010-02-09: #34
>+1. I really need proxy feature in gwibber too.
----------------------------
+1

Changed in gwibber:
assignee: Ryan Paul (segphault) → Ken VanDine (ken-vandine)
ktp (kari-petersen) wrote :

#36 says that the Facebook widget uses webkit. I found the following regarding webkit and gnome proxy settings:
https://bugs.launchpad.net/ubuntu/+source/pywebkitgtk/+bug/424833 links to https://bugs.webkit.org/show_bug.cgi?id=25263 and the bad news is, that they won't fix because the problem seems to be in libsoup. There is also a bug filed under https://bugzilla.gnome.org/show_bug.cgi?id=605048

Maybe someone can sort this out. For me qwibber is rendered useless at this time, because I need to have a proxy.

I see this as a major fault.

Two high-profile items for Lucid are the integration of Social Networking and integration of Ubuntu One. Both of these features are blocked for anybody behind a proxy.

skre (stefan-kremer) wrote :

I agree #40. Especially business users have to use a proxy. I can't understand why a lot of applications don't use gnome proxy settings.

While not wanting to turn this into discussion thread, as staunch Ubuntu supporter I agree that we have ignored proxy users for a while. For brighter side, we have definite plans for releasing proxy supporting Gwibber in PPA for Lucid within 2 months, so proxy users won't be left out in the cold. I will try to research posiblity to add some support for XMPP in Empathy.

Nigel Babu (nigelbabu) wrote :

Thanks Pēteris for the patch, I've added patch-needswork tag for now, when you've fixed the facebook issues and this is ready for prime time, please feel free to change it back to patch tag.

tags: added: patch-needswork
removed: patch
Sassan (sassanh) wrote :

It's pretty much unusable here in Iran as they filtered facebook, twiter, flicker, etc.
I even tried to setup a transparent (intercepting) proxy and then connect to facebook with gwibber running on a machine behind this proxy but facebook authentication needs https and as you know there's no way making https work with transparent proxy (Man in the middle attack).
I read all the python sources and ended up knowing that it's almost impossible to make webkit module for python to use proxy.
Well after all I wanna kindly mention that for us (who live in a country with huge usage of filtering like Iran, China, etc) it'd be nice if Ubuntu and softwares made in it's community give a full support for proxy services.

BTW it's getting two months :)

Regards
--
Sassan

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 2.31.1-0ubuntu1

---------------
gwibber (2.31.1-0ubuntu1) maverick; urgency=low

  * New upstream release
    - Added GetVersion method to the API
    - added libproxy support for gwibber-service (LP: #259830)
 -- Ken VanDine <email address hidden> Thu, 24 Jun 2010 12:11:42 -0400

Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Sassan (sassanh) wrote :

Well thank you for your immediate action, I appreciate it, you made CurlDownloader use libproxy and it probably solved the problem, I say probably because I'm unable to test it because I can't authenticate my facebook account, and I can't authenticate it because facebook authentication dialog (which is in lib/gtk/facebook.py) uses webkit it still doesn't respect gnome proxy and I can't make it use gnome proxy. If you make webkit use proxy (any kind of proxy - gnome-network-proxy, defined in py file, etc) you're my hero :D

Regards
--
Sassan

Changed in gwibber (Ubuntu):
status: Fix Released → In Progress
Omer Akram (om26er) wrote :

you were not able to add facebook account cuz that was a bug which is now fixed.

Changed in gwibber (Ubuntu):
status: In Progress → Fix Released
Changed in gwibber:
status: Confirmed → Fix Released
John (john-e-francis) wrote :

only partially working for me in 2.30.1 under Karmic.

- gwibber does not seem to check the proxy settings when it starts, it doesn't pick up changes to the Gnome proxy settings until I logout/login.

- authenticating a facebook account doesn't appear to be aware of proxy settings. I get a "cannot resolve hostname" error page, which is what would be expected if the proxy is not used.

Sassan (sassanh) wrote :

It is not fixed, I can't login to facebook and the login widget doesn't respect my proxy, please don't change the status of this bug to fixed until it's been confirmed by at least one person who's experiencing the problem.

regards
--
Sassan

Changed in gwibber:
status: Fix Released → In Progress
Changed in gwibber (Ubuntu):
status: Fix Released → In Progress

Not working at least with twitter.

Linux gandalf 2.6.32-24-generic #41-Ubuntu SMP Thu Aug 19 01:12:52 UTC 2010 i686 GNU/Linux

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"

Last full update: 23 august 2010

gwibber_2.30.1-0ubuntu1

Proxy settings are set in gnome settings.

Michael Hall (mhall119) wrote :

Using Gwibber 2.31.92, and it does not seem to use the proxy for any of the protocols.

Linux mhall-laptop 2.6.32-24-generic #42-Ubuntu SMP Fri Aug 20 14:24:04 UTC 2010 i686 GNU/Linux

Distributor ID: Ubuntu
Description: Ubuntu 10.04.1 LTS
Release: 10.04
Codename: lucid

Version: 2.31.92~bzr837-0ubuntu1~daily1~lucid
From: deb http://ppa.launchpad.net/gwibber-daily/ppa/ubuntu lucid main

wiz (wiz) wrote :

Buzz not working in 10.10 beta

BehzadSh (behzadsh) wrote :

gwibber-daily doesn't work either :|

Vadim Rutkovsky (roignac) wrote :

Due to http://code.google.com/p/pywebkitgtk/issues/detail?id=53 any OAuth dialog will be unavailable (i.e Facebook, Twitter and Buzz).

Harsh Kumar (harsh1kumar) wrote :

Bug exists in Ubuntu 10.10

Please fix this bug. Its annoying that ubuntu is shipping applications these days with no proxy support.

Bob Morton (bobmorton) wrote :

thanks for the help

[url=http://www.google.com]thanks[/url]

[http://www.google.com thanks]

temsa (florian-traverse) wrote :

Seems to work partially fine with proxy (not sure, however) on an Mint Isadora updated with Ubuntu 10.10 packages : Any "browser based" (like connection to facebook or twitter account) feature won't work (I had to use proxychains), but message sending/retrieval seems to work fine after service subscriptions

Changed in gwibber (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody

Linux pulsarx 2.6.32-27-generic #49-Ubuntu SMP Wed Dec 1 23:52:12 UTC 2010 i686 GNU/Linux

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"

Gwibber 2.91.3

I confirm, simply it doesn't work under proxy.

If I try to add any account (facebook, twitter, identi.ca), it gives me this message:
-----
Unable to load page

Problem occurred while loading the URL https://graph.facebook.com/oauth/authorize?redirect_uri=http%3A%2F%2Fwww.facebook.com%2Fconnect%2Flogin_success.html&type=user_agent&display=popup&client_id=71b85c6d8cb5bbb9f1a3f8bbdcdd4b05

Cannot connect to destination
----

...of course my network connection is fine.

Libproxy is now disabled in source code. And the authentication, that uses python-webkit is unabled to use http proxy.

Changed in gwibber:
assignee: Ken VanDine (ken-vandine) → nobody
Changed in gwibber:
status: In Progress → Triaged
Changed in gwibber (Ubuntu):
status: In Progress → Triaged
Changed in gwibber:
status: Triaged → Confirmed
assignee: nobody → Ken VanDine (ken-vandine)

the two published patches do not work, i look forward to, like many users, use gwibber at work...

Changed in gwibber:
milestone: 3.0 → 3.2

It still has not been fixed. Sad. This is with oneiric released with 3.2.0.1

Peter Ivanov (emzak) wrote :

No proxy support in 3.2.1 either.

sammcj (sammcj) wrote :

A major faulty, I cannot believe this still has not been fixed, no gwibber at work!

Denis A. Grigoriev (dgreenday) wrote :

This is a hack to get twitter working behind proxy. I don't know how to make this gwibber-wide :(
I'll try to look for ways to do it.

Gwibber 2.32.0.1, Ubuntu 10.10

--- twitter.py 2011-12-06 17:41:26.741085914 +0400
+++ /usr/share/pyshared/gwibber/lib/gtk/twitter.py 2011-12-06 17:42:12.421057531 +0400
@@ -16,6 +16,15 @@

 sigmeth = oauth.OAuthSignatureMethod_HMAC_SHA1()

+#dirty ugly proxy hack
+import ctypes
+libgobject = ctypes.CDLL('/usr/lib/libgobject-2.0.so.0')
+libsoup = ctypes.CDLL('/usr/lib/libsoup-2.4.so.1')
+libwebkit = ctypes.CDLL('/usr/lib/libwebkit-1.0.so.2')
+proxy_uri = libsoup.soup_uri_new('http://127.0.0.1:5865')
+session = libwebkit.webkit_get_default_session()
+libgobject.g_object_set(session, "proxy-uri", proxy_uri, None)
+
 class AccountWidget(gtk.VBox):
   """AccountWidget: A widget that provides a user interface for configuring twitter accounts in Gwibber
   """

Bilal Shahid (s9iper1) wrote :

Thanks for your patch, unfortunately our busy developers haven't been able to review your patch in a timely manor. The gwibber codebase has seen significant change and it is likely this patch no longer applies. Please review it again and if it is still applicable, update it to work with the latest gwibber trunk. We will be doing a patch review day in the next few weeks and would like to review your patch. Thanks again for your contribution!

Changed in gwibber:
status: Confirmed → Incomplete
tags: added: patch-day-old
removed: patch-needswork
Vladimir Scherbaev (zemik) wrote :

gwibber 3.4.1-0ubuntu1 in Ubuntu 12.04. Still don't work behind proxy.

same here. Ubuntu 12.04

Brian Thorne (hardbyte) wrote :

I changed line 127 of /usr/share/gwibber/plugins/twitter/gtk/twitter/__init__.py to use https instead of http which seemed to get through my work proxy:

http_url="https://api.twitter.com/oauth/access_token",

KARTHIK (kannankarthik1992) wrote :

Ubuntu 12.04

Using Empathy 3.4.2.3

I am using an authenticated proxy.

Empathy still not working behind authenticated proxy.

Bilal Shahid (s9iper1) on 2012-12-13
Changed in gwibber:
status: Incomplete → Confirmed
importance: Medium → Wishlist
akatdim (akatdim) wrote :

Ubuntu 12.10
Gwibber 3.6.0 has same bug, but Empathy works fine.

Changed in gwibber:
status: Confirmed → Fix Committed
Changed in gwibber (Ubuntu):
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.