Twitter auth does not work. API Change.

Bug #1190479 reported by Philipp Hügelmeyer on 2013-06-13
178
This bug affects 35 people
Affects Status Importance Assigned to Milestone
gwibber (Ubuntu)
Undecided
Unassigned
Precise
High
Unassigned

Bug Description

[Impact]
Gwibber's support for Twitter is completely broken because Twitter retired v1 API support.

[Test Case]
- Open Gwibber,
- Add a twitter account
- make sure that some messages appear.

[Regression Potential]
None, Gwibber is just broken without this fix.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
euda (eiichirou) on 2013-06-24
description: updated
Tom Brossman (tom.brossman) wrote :

See comments 6 and 7 at duplicate 1190575 for a workaround.

https://bugs.launchpad.net/ubuntu/+source/gwibber/+bug/1190575

Either I made some silly mistake, or the workarounds described in bug 1190575 do not work for me (1190575 discussed this for Quantal, I am on Precise).

asasoft (asasoft) wrote :

Workaround work fine for me on Precise.

description: updated
Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
Changed in gwibber (Ubuntu Precise):
importance: Undecided → High
Changed in gwibber (Ubuntu Quantal):
importance: Undecided → Medium
importance: Medium → High

Hello Philipp, or anyone else affected,

Accepted gwibber into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gwibber/3.4.2-0ubuntu2.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gwibber (Ubuntu Precise):
status: New → Fix Committed
tags: added: verification-needed
Changed in gwibber (Ubuntu Quantal):
status: New → Fix Committed
Dave Walker (davewalker) wrote :

Hello Philipp, or anyone else affected,

Accepted gwibber into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gwibber/3.6.0-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Philipp Wendler (philw85) wrote :

The gwibber package 3.4.2-0ubuntu2.3 on Ubuntu Precise works successfully.
I tested account setup with authorization and receiving tweets, both of which were not working before.
I did not test other actions such as writing a tweet.

tags: added: verification-done
removed: verification-needed
tags: added: verification-done-precise
tags: added: verification-needed
removed: verification-done
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.4.2-0ubuntu2.3

---------------
gwibber (3.4.2-0ubuntu2.3) precise-proposed; urgency=low

  * debian/patches/lp_1190479.patch
    - Switch to Twitter v1.1 as v1 has been retired (LP: #1190479)
 -- Ken VanDine <email address hidden> Mon, 08 Jul 2013 15:34:38 -0400

Changed in gwibber (Ubuntu Precise):
status: Fix Committed → Fix Released
David Mackie (dmackie) wrote :

Doesn't work for me.

Enrico Rosina (e-rosina) wrote :

Hello all,

Thank you for the fix, you are smart people!

A few days ago I received an automatic update and I was finally able to create an account in gwibber.
This is my configuration:

Ubuntu 12.04 (precise)
3.2.0-49-generic
Gwibber 3.4.2

Best regards
Enrico

tenwit (tenwit) wrote :

This works for me now. At least receiving tweets is working. Also on 12.04 with gwibber 3.4.2.
tyvm!

Adolfo Jayme (fitojb) on 2014-09-04
no longer affects: gwibber (Ubuntu Quantal)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers