[raring] Enters infinite loop if gwibber service cannot be started

Bug #1112487 reported by Roman Yepishev on 2013-02-01
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gwibber (Ubuntu)
Undecided
Unassigned

Bug Description

Gwibber now suffers from bug 1112106 and unity-gwibber-service is unhappy:
unity-gwibber-daemon-Message: daemon.vala:79: ACCOUNT PROVIDER: twitter

(process:6753): libunity-CRITICAL **: unity_filter_get_filtering: assertion `self != NULL' failed

(process:6753): libunity-CRITICAL **: unity_filter_get_filtering: assertion `self != NULL' failed

** (process:6753): CRITICAL **: file /home/ken/src/gwibber/trunk/libgwibber/streams.vala: line 102: unexpected error: Error calling StartServiceByName for com.Gwibber.Streams: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/gwibber-service exited with status 1 (g-dbus-error-quark, 25)

** (process:6753): CRITICAL **: file /home/ken/src/gwibber/trunk/libgwibber/service.vala: line 94: unexpected error: Error calling StartServiceByName for com.Gwibber.Service: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/gwibber-service exited with status 1 (g-dbus-error-quark, 25)
...

And it takes 99% of the CPU while printing this over and over:
(process:6753): unity-gwibber-daemon-CRITICAL **: __lambda4_: assertion `iter != NULL' failed

(process:6753): dee-CRITICAL **: dee_analyzer_analyze_real: assertion `data != NULL' failed

(process:6753): dee-CRITICAL **: dee_model_is_last: assertion `DEE_IS_MODEL (self)' failed

(process:6753): dee-CRITICAL **: dee_model_get_last_iter: assertion `DEE_IS_MODEL (self)' failed

(process:6753): dee-CRITICAL **: dee_model_is_last: assertion `DEE_IS_MODEL (self)' failed

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: unity-lens-gwibber 3.6.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-3.7-generic 3.8.0-rc5
Uname: Linux 3.8.0-3-generic x86_64
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Fri Feb 1 15:12:08 2013
InstallationDate: Installed on 2013-01-04 (28 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130104)
MarkForUpload: True
SourcePackage: gwibber
UpgradeStatus: No upgrade log present (probably fresh install)

Roman Yepishev (rye) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers