Ubuntu

Can't add my Facebook account

Reported by Dante Díaz on 2012-09-29
506
This bug affects 105 people
Affects Status Importance Assigned to Milestone
Gwibber
High
Unassigned
gwibber (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

Steps to reproduce:
1. Open gwibber
2. Open the accounts window
3. Select and add new Facebook account
4. Authorize using password

What should happen:
Facebook account is added to the accounts list

What happens:
Message appears: "Success"

Ubuntu version: 12.04.1 LTS
Gwibber version: 3.4.2

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gwibber 3.4.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-31.50-generic 3.2.28
Uname: Linux 3.2.0-31-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.0.1-0ubuntu13
Architecture: amd64
Date: Sat Sep 29 10:37:49 2012
ExecutablePath: /usr/bin/gwibber
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64+mac (20120823.1)
SourcePackage: gwibber
UpgradeStatus: No upgrade log present (probably fresh install)

Dante Díaz (dante) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwibber (Ubuntu):
status: New → Confirmed
Matt Hewitt (rudefyet) wrote :

Same problem here, although within the past day the message has changed to:

SECURITY WARNING: The above URL is NOT NOT VALID FOR A CASH CARD OR GIFT CARD. Giving away the URL may result in your account being HIJACKED.

Dante Díaz (dante) wrote :

Yes, the message has changed for me too, weird.

redman (patrick-libert) wrote :

Same problem for me

Same bug, but I only have the "Success" message and no more.

Fabian Leopold (fl2586) wrote :

I also have only the "Success" message and nothing more.

Pascal Allegra (pascal79) wrote :

Me too, I have "Success" message.

Cristian Delgado (cjdg-2k2) wrote :

I have the same

same problem...

José Antonio Rey (jose) wrote :

Confirmed in gwibber as per comments.

Changed in gwibber:
status: New → Confirmed

Same problem here. But just show "Success" message, nothing more.

DanielC (zooide) wrote :

Same problem:

Adding a facebook account only appears "Success" (fresh install 64 bits Ubuntu 12.04, Fedora 17 and Debian Wheezy, Unity and Gnome Shell )

no longer affects: gwibber (Fedora)
robert (rebeve31337) wrote :

Same here ... i only get the "Success" message and nothing happends

Eduardo Elortegui (eelortegui) wrote :

Same problem Adding a facebook account only appears "Success".

Ubuntu 64 bits 12.04 upgraded from 11.10.

Same here Fresh install Ubuntu 12.04.1 64 bits...

same problem here with 12.04 fresh install.

Bilal Shahid (s9iper1) wrote :

assigning to kenvandine !

Changed in gwibber (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
Changed in gwibber:
importance: Undecided → High
assignee: nobody → Ken VanDine (ken-vandine)
Yotis (yotisvag-g) wrote :

Same here
Ubuntu 12.04 LTS amd64

security vulnerability: no → yes
Iván Azuara (darkside-se) wrote :

Same problem Adding a facebook account only appears "Success" message and nothing more.
with Ubuntu 12.04.1 LTS 32 bit

Roberto Loi (junkyard-t) wrote :

Same problem here. Ubuntu 12.04.1 LTS @ 32 bit. Success message, but can't add my account, really frustrating. Tried to add my account multiple times, nothing interesting happened.

Changed in gwibber (Ubuntu):
status: Triaged → Confirmed
Valerio Valrosso (v-valrosso) wrote :

The same for me.

Phillip Temple (philliptemple) wrote :

Same here. 64-bit Ubuntu 12.04. Only message "Success" and nothing else except the close button. No account added. Gwibber remains completely blank.

Phillip.

Bilal Shahid (s9iper1) wrote :

still a bug of fixed with the updates i didnt face it again !!

tags: added: verification-needed
Changed in gwibber (Ubuntu):
status: Confirmed → Fix Committed
Changed in gwibber:
status: Confirmed → Fix Committed
Konrad (konradmb) wrote :

Bilal, how did you manage to update it on Ubuntu Precise?

Bilal Shahid (s9iper1) wrote :

is this still present ?
on my side its working fine with precise

Bilal Shahid (s9iper1) wrote :

opps i guess its a mistake by me i changed the wrong bug status by mistake

Changed in gwibber (Ubuntu):
status: Fix Committed → Triaged
Changed in gwibber:
status: Fix Committed → Confirmed
Konrad (konradmb) wrote :

It's good that you've checked this. :)

Marco Scannadinari (zheoffec) wrote :

+1 I also have this problem.

Roberto Loi (junkyard-t) wrote :

Didn't understand if Bilal has a fix or is planned an update for Gwibber!

Konrad (konradmb) wrote :

He made a mistake because he thought that it is working.

Roberto Loi (junkyard-t) wrote :

Understood, thanks Konrad!

Kdawg (spotify8520) on 2012-10-18
Changed in gwibber (Ubuntu):
status: Triaged → Fix Released
Bilal Shahid (s9iper1) on 2012-10-18
Changed in gwibber (Ubuntu):
status: Fix Released → Triaged
importance: Medium → High
Roberto Loi (junkyard-t) wrote :

Works on Ubuntu 12.10, i tried and everything works well. But not on 12.04.

Konrad (konradmb) wrote :

So we should file a backport request?

precise: gwibber (3.4.0-0ubuntu4)
quantal: gwibber (3.6.0-0ubuntu1)

Konrad (konradmb) on 2012-10-18
summary: - Gwibber not add my Facebook account
+ Can't add my Facebook account
Konrad (konradmb) on 2012-10-18
description: updated
information type: Public Security → Public
Ken VanDine (ken-vandine) wrote :

Steps to verify the fix:
1) launch gwibber-accounts and attempt to add a new facebook account
2) Verify new facebook account shows up in the list of accounts

Regression potential:
 None, the fix is a more reliable way to detect loading of the success page.

Changed in gwibber (Ubuntu):
milestone: none → precise-updates
Changed in gwibber:
status: Confirmed → Fix Committed
Bilal Shahid (s9iper1) on 2012-10-18
Changed in gwibber (Ubuntu):
status: Triaged → Fix Committed
Changed in gwibber (Ubuntu):
status: Fix Committed → Triaged
Scott O'Nanski (s-onanski) wrote :

Still blank for me. Ubuntu 12.04, 64bit.

Nope Ubuntu 12.04.1 all updates on day, the problem persists.
I Have deleted the gwiber folder in user acount to create a new profile and the same.

Rob (rstreeter78) wrote :

I am having the same issue Ubuntu 12.04 LTS I have tried to fix it and have had no luck

Colin Guillas (cguillas) wrote :

Also affected

lggregorio (luiz-gregorio) wrote :

I am also affected with the same "success" message when adding Facebook account. Other accounts as Identi.ca or Twitter are working fine.
Using Linux Mint 13 64-bits, Gwibber 3.4.2

polux (poloruv) on 2012-10-24
Changed in gwibber:
status: Fix Committed → Fix Released
DanielC (zooide) wrote :

How can i fix it?
im still having this problem (Ubuntu 12.04.1 fresh reinstall 64 bits totally updated on Unity and Gnome)

Pedro Rosado (pdvrosado) wrote :

Using ubuntu 11.10 - gwibber version 3.2.1.

this happens not only with facebook. It does the same "sucess" thing and none account added, in all the other services.

Gorrunyo (gorrunyo) wrote :

Same problem here

madnux (madnux) wrote :

Bump

Still don't working with facebook account.

Brian Murray (brian-murray) wrote :

Before this can be accepted as an SRU for 12.04, this needs to be fixed in 13.04. I don't see any indication that this has been fixed there.

Divan (divan-santana) wrote :

Briamn, this is fixed in 12.10 so I don't see why it wouldn't be fixed in 13.04(unless I'm missing something)?

David (david-mihet) wrote :

Same problem on Ubuntu 12.04.1 64bit

franKeinas (frankeinas) wrote :

Same problem on Ubuntu 11.04 and 11.10. Any solution?

Ruben Rocha (ruben-silvarocha) wrote :

Is this fixed on 12.04? Im waiting for this bug to be fixed because i want to use LTS version. Until then im using 12.10 but its not the same...

Rob (rstreeter78) on 2012-11-22
description: updated
Abelardo (abelardotomasjb) wrote :

That response from Brian Murray is very much PATHETIC.. Ubuntu 12.04 is the LTS and is supposed to be challenging Mountain Lion 10.8, how you expect people to use Ubuntu as main OS, if the answer is "this has to be fixed first in 13.04"?? this is pretty much a lazy and pathetic answer. BTw I have a PhD in Computer Eng so I know what I am talking about. This attitude is bad.

Sorry if you got offended, but sometimes we need to talk straight.

Bests,
Abelardo

Ken VanDine (ken-vandine) wrote :

This bug never effected 12.10 or 13.04, the fix was uploaded to precise-proposed on 10/18 however it must have been rejected. Not sure why.

Changed in gwibber (Ubuntu):
status: Triaged → Invalid
Changed in gwibber (Ubuntu Precise):
importance: Undecided → High
status: New → Confirmed
Ken VanDine (ken-vandine) wrote :

I've uploaded gwibber 3.4.2-0ubuntu2.1 to precise-proposed again. We need to wait for the SRU team to review it and approve.

Changed in gwibber (Ubuntu):
milestone: precise-updates → none
Matt Biddle (eightbitalpha) wrote :

Has this bug been fixed in 12.04 and if so when will it land? I am currently running Gwibber v3.4.2 and still unable to add my facebook account.

Hello Dante, or anyone else affected,

Accepted gwibber into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gwibber/3.4.2-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gwibber (Ubuntu Precise):
status: Confirmed → Fix Committed

Just added this from the proposed repository to my system and it added my Facebook account as opposed to getting Success. Changed tag to verification-done.

tags: added: verification-done
removed: verification-needed
Ruben Rocha (ruben-silvarocha) wrote :

Will this fix be packaged to other versions like 10.04.4? Lucid has the same problem...

Andreas Wilhelm (andywilhelm) wrote :

Installed it from the precise-proposed repo and added my facebook account.
Now the account is listed but no Messages show up. And in the Settings it still says "Authorize with Facebook",
not "authorized" like the Twitter account. Already deleted the config files, but it didn't help.
Any Ideas?

Ruben Rocha (ruben-silvarocha) wrote :

I tested on my wifes netbook. Installed the proposed updates for gwibber, removed account, cleared caches and related gwibber config files. Added the account and now it adds correctly but gwibber is not getting any data from facebook. The gwibber window stays blank.

Oscar Craviotto (ocraviotto) wrote :

Same here (12.04 on x86-64), just as described in comments #58 and #59 above, account now is added but gwibber does not aquire data and in account settings it still says "authorize with facebook". Should a new bug report be opened?

Piotr (piotrtokaj) wrote :

I get the "Success" message and nothing else, I tried installing the proposed but I get this:

sudo apt-get install gwibber/precise-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Release 'precise-proposed' for 'gwibber' was not found

Scott Kitterman (kitterman) wrote :

Please file a new bug for the follow on issue (after checking that there isn't one already).

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.4.2-0ubuntu2.1

---------------
gwibber (3.4.2-0ubuntu2.1) precise-proposed; urgency=low

  * debian/patches/lp_1058672.patch
    - Use webkit's onload-event instead of title changed to detect successful
      facebook login. Facebook changed the login_success.html file from html
      to plain text which does not have a title set. (LP: #1058672)
 -- Ken VanDine <email address hidden> Thu, 18 Oct 2012 11:24:24 -0400

Changed in gwibber (Ubuntu Precise):
status: Fix Committed → Fix Released
el_gallo_azul (el-gallo-azul) wrote :

I installed the updates today in Ubuntu 12.04 which included updates for Gwibber and for the 3 plugins: Facebook, Twitter, and identi.ca.

Gwibber is now version 3.4.2.

After completing the update I did the following:
1. Removed Gwibber from within Facebook 'My Apps'.
2. Added a Facebook account again to Gwibber. It looked better than before except...
3. No Facebook entries appeared in Gwibber.
4. I looked at Accounts again in Gwibber. There is now a Facebook account in the list of accounts, unlike before today. Twitter says 'el_gallo_azul has been authorised by Twitter' like it did before today's updates, but Facebook still has the 'Authorise' button and the text 'Authorise with Facebook'.
5. I then restarted the computer, removed Gwibber from Facebook's 'My Apps', and added a Facebook account to Gwibber again.
6. Right now, the Facebook account still shows in Gwibber's list of accounts, but no Facebook entries appear on Gwibber's home page, and Gwibber's Facebook account still appears as in point 4 above.

w00t! (cha-0s) wrote :

same here as el_gallo_azul (el-gallo-azul) described

Having the same problem on Ubuntu 12.10 x64

tagMacher (tagmacher) wrote :

Situation same as for el_gallo_azul on Ubuntu 12.04 LTS 64-bit with Gwibber updated to same version.

tagMacher (tagmacher) wrote :

I am having the same problem as el_gallo_azul. Gwibber versions are as follows:

divakar@beta:~$ sudo dpkg --list "gwibber*"
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Description
+++-===========================-===========================-======================================================================
ii gwibber 3.4.2-0ubuntu2.1 Open source social networking client for GNOME
ii gwibber-service 3.4.2-0ubuntu2.1 Open source social networking client for GNOME
un gwibber-service-buzz <none> (no description available)
un gwibber-service-digg <none> (no description available)
ii gwibber-service-facebook 3.4.2-0ubuntu2.1 Facebook plugin for Gwibber
un gwibber-service-flickr <none> (no description available)
un gwibber-service-foursquare <none> (no description available)
un gwibber-service-friendfeed <none> (no description available)
ii gwibber-service-identica 3.4.2-0ubuntu2.1 Identi.ca plugin for Gwibber
un gwibber-service-pingfm <none> (no description available)
un gwibber-service-qaiku <none> (no description available)
un gwibber-service-statusnet <none> (no description available)
ii gwibber-service-twitter 3.4.2-0ubuntu2.1 Twitter plugin for Gwibber
un gwibber-themes <none> (no description available)

Please advise if these are the latest versions with the bug-fix.

Keyur Mehta (ksmehta2004) wrote :

I am facing same problem in ubuntu 12.04 LTS....
After authorizing my Facebook account in Broadcast Account... when I open Gwibber, it doesnt show anything except just "Refreshing"....

Skyler (skylerzio) wrote :

Just adding that I am having this error on Ubuntu 12.04 LTS and EasyPeasy 1.6 (Ubuntu 10.04?).

12.04 will not refresh facebook status updates, EasyPeasy showed success without an added account.

Also, while I know its not in regards to Gwibber, Empathy is having a similar problem, where it can not connect with the proper facebook info; Maybe Facebook changed something?

Avery (docaltmed) wrote :

Facebook account still nonfunctional on 12.04 LTS.

eden6000 (eden6000) wrote :

+1 for Facebook account still not working on 12.04 LTS with proposed upgrades enabled

SK (skhere4u) wrote :

Does not work for me either. Have tried all solutions given including re-install. Is there a better app than Gwibber?

Thanks
SK

Ckon Mapy (koupykon) wrote :

Hi every body! I think Gwibber dev should take the bug more seriouly than that according to the importance we place on it.
I have the same problem and I have let my launchpad page active for a week and up until now nothing appends. So hope Gwibber dev will solve that soon.

Regards

Dante Díaz (dante) wrote :

Hello everyone.

If you have a problem with the Facebook stream on Gwibber, maybe it can help you:

http://planetared.com/2013/01/solucionar-error-de-facebook-en-gwibber-para-ubuntu-12-04-y-12-10/ (spanish, but just check the code)

A temporary solution.

The bug described in comment #66 might actually be this one: https://bugs.launchpad.net/gwibber/+bug/1007262

Roy Feldman (roy-feldman) wrote :

I just tried the fix Dante posted and it worked for me. I am running 12.04 64 bit. Finally I can see my Facebook feed in Gwibber! :-)

Quoting Dante:

http://planetared.com/2013/01/solucionar-error-de-facebook-en-gwibber-para-ubuntu-12-04-y-12-10/ (spanish, but just check the code)

Thanks Dante

Mik Wind (evilpollo) wrote :

in Ubuntu 12.10
this bug and this other one might be the same:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1131192

whereas the actual bug is now in whichever program is used to manage all the social accounts

Evgeniy Dyakonov (xevyk82) wrote :

Ubuntu 12.10 x86 same problem

It seems it's happening again in Ubuntu 12.10. It was working fine till the last Ubuntu update one or two weeks ago.
I tried to remove Facebook account and recreate it, but it's still opening the browser and showing the 'Success' message.

fgerst (doogie-gmx) wrote :

Ubuntu 12.10 x86_64 same problem

Mohsen Naderi (mjmohsen) wrote :

the bug has been fixed for me; I connected my facebook account yesterday and it works fine in Sympathy now. Can't see facebook updates in Gwibber yet though.

John Hart (jlhart68) wrote :

I have the bug also and my Gwibber has not sync'd in 95 days. At this rate I don't see much use in Gwibber as it does not work.

I am using Ubuntu 12.04LTS

Ruben Rocha (ruben-silvarocha) wrote :

If your facebook feed is not updating please apply this workarround http://www.webupd8.org/2013/01/fix-facebook-not-working-with-gwibber.html

Baldrick (bheath-nz) wrote :

Does exactly the same thing in Empathy too! Full message, Ubuntu 13.04 x64. Fresh install.

Changed in gwibber:
assignee: Ken VanDine (ken-vandine) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers