doesn't refresh due to utf8 handling issue

Bug #1055762 reported by Sebastien Bacher on 2012-09-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gwibber
Undecided
Ken VanDine
gwibber (Ubuntu)
Medium
Ken VanDine

Bug Description

Using quantal beta2, gwibber-service in french hits that issue:

" File "/usr/share/gwibber/plugins/facebook/__init__.py", line 370, in __call__
    return getattr(self, opname)(**args)
  File "/usr/share/gwibber/plugins/facebook/__init__.py", line 394, in receive
    return [self._message(post) for post in data["data"]]
  File "/usr/share/gwibber/plugins/facebook/__init__.py", line 273, in _message
    m["html"] += " " + _("at") + " <p><b>%s</b></p>" % m["location"]["name"]
UnicodeDecodeError: 'ascii' codec can't decode byte 0xc3 in position 1: ordinal not in range(128)"

replacing the 2 _("at") instances with _("at").decode('utf8') fixes the issue, thanks Ken ;-)

Related branches

Sebastien Bacher (seb128) wrote :

(the real line is 272, I added a print debug statement)

summary: - doesn't refresh to utf8 handling issue
+ doesn't refresh due to utf8 handling issue
Changed in gwibber:
status: New → Fix Committed
Changed in gwibber (Ubuntu):
milestone: none → ubuntu-12.10
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Ken VanDine (ken-vandine)
Changed in gwibber:
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → 3.6
Changed in gwibber:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.5.91-0ubuntu1

---------------
gwibber (3.5.91-0ubuntu1) quantal; urgency=low

  * New upstream release
    - Default action on the preview should be view, retweet could
      be dangerous (LP: #1058222)
    - work around bug in libunity's SocialPreview by explicitly
      setting title and subtitle (LP: #1058198)
    - decode the translated string for "at" (LP: #1055762)
 -- Ken VanDine <email address hidden> Fri, 28 Sep 2012 16:17:00 -0400

Changed in gwibber (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers