should start on login only if accounts are configured

Bug #1046360 reported by Sebastien Bacher on 2012-09-05
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
Telepathy Indicator
High
Ken VanDine
gwibber (Ubuntu)
High
Ken VanDine
Quantal
High
Ken VanDine
indicator-messages (Ubuntu)
High
Unassigned
Quantal
High
Unassigned
telepathy-indicator (Ubuntu)
High
Ken VanDine
Quantal
High
Ken VanDine

Bug Description

The autostart should probably be conditional to a gsettings key which is written on account configuration it would be better for:

- login time (less services to start)

- the indicator-messages menu, it shouldn't list unused entries (gwibber is added on logging atm since the service is started)

- memory usage

Related branches

Sebastien Bacher (seb128) wrote :

indicator-messages added to the list since it impacts on the "no messaging icon should be displayed by default" (bug #1046331)

summary: - should't autostart if no account is configured
+ should start on login only if accounts are configured
Changed in gwibber (Ubuntu Quantal):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
status: New → Confirmed
Changed in telepathy-indicator (Ubuntu Quantal):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → High
status: New → Confirmed
Changed in indicator-messages (Ubuntu Quantal):
status: New → Confirmed
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

Discussing on IRC, in the gwibber case the autostart is conditional but the service is autostarted by unity

we have 2 gwibber issues there:

- the autostart key is not written since the port to libaccounts

- messaging_menu_app_register() is called even if there is no account configured, it should probably be not

gwibber should ideally put its lens invisible if no account is configured as well

other issues from unityn the lens shouldn't be started on login

Sebastien Bacher (seb128) wrote :

open bug #1046377 " [lens] should set itself invisible if no account is configured"

Changed in gwibber (Ubuntu Quantal):
importance: High → Medium
Changed in telepathy-indicator (Ubuntu Quantal):
importance: High → Medium
milestone: none → ubuntu-12.10
Changed in gwibber (Ubuntu Quantal):
milestone: none → ubuntu-12.10
Changed in telepathy-indicator (Ubuntu Quantal):
importance: Medium → High
Changed in gwibber (Ubuntu Quantal):
importance: Medium → High
Changed in indicator-messages:
importance: Undecided → High
no longer affects: indicator-messages
Changed in telepathy-indicator:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwibber - 3.6.0-0ubuntu1

---------------
gwibber (3.6.0-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release
    - Add disabling online search support, requires libunity 6.7 or
      later, thanks to Didier Roche (LP: #1054746)
    - Don't let the lens start gwibber-service unless data is
      needed (LP: #1046360)
  * debian/control
    - bump build depends for libunity-dev to >= 6.8
 -- Ken VanDine <email address hidden> Thu, 04 Oct 2012 12:16:49 -0400

Changed in gwibber (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in indicator-messages (Ubuntu Quantal):
status: Confirmed → Invalid
Changed in telepathy-indicator (Ubuntu Quantal):
status: Confirmed → In Progress
milestone: ubuntu-12.10 → quantal-updates
Ken VanDine (ken-vandine) wrote :

Steps to verify the fix for telepathy-indicator:

1) Switch to a guest session
2) Note the messaging menu shouldn't be displayed at all
3) Open System Settings and go to "Online Accounts"
4) Add an account that support IM (gtalk, facebook, etc)
5) You should see the messaging menu icon appear in the panel including presence icons and a PIP next to Empathy

Regression potent:
 - Worst case would be lack of messaging menu integration for empathy, if it fails

The fix is being included as a distro patch so reverting the change would be as simple as dropping the patch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telepathy-indicator - 0.3.0-0ubuntu2

---------------
telepathy-indicator (0.3.0-0ubuntu2) quantal-proposed; urgency=low

  * debian/patches/lp_1046360.patch
    - Don't register with the messaging menu unless there are
      accounts that can use it (LP: #1046360)
 -- Ken VanDine <email address hidden> Fri, 12 Oct 2012 12:40:08 -0400

Changed in telepathy-indicator (Ubuntu Quantal):
status: In Progress → Fix Released
Changed in telepathy-indicator:
status: New → Fix Released
assignee: nobody → Ken VanDine (ken-vandine)
Changed in telepathy-indicator:
status: Fix Released → Fix Committed
Ted Gould (ted) on 2013-10-14
Changed in telepathy-indicator:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers