gwenview package lacks some dependencies and fails to display pictures

Bug #1529873 reported by Michael Mess on 2015-12-29
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gwenview (Ubuntu)
Undecided
Unassigned

Bug Description

Gwenview fails to display images and brings up the following Error window:

Error - Gwenview
URL cannot be listed
file:///home/user/somedirectory

Workaround: (apport information was taken after applying missing dependencies with the following commands)
sudo apt-get install kio kinit kdelibs-bin kded5

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: gwenview 4:14.12.3-0ubuntu1
ProcVersionSignature: Ubuntu 3.19.0-42.48-generic 3.19.8-ckt10
Uname: Linux 3.19.0-42-generic x86_64
ApportVersion: 2.17.2-0ubuntu1.8
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue Dec 29 15:32:31 2015
InstallationDate: Installed on 2015-05-31 (212 days ago)
InstallationMedia: Xubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422.1)
SourcePackage: gwenview
UpgradeStatus: No upgrade log present (probably fresh install)

Thank you for reporting this bug to Ubuntu. Vivid Vervet reached EOL on Feb 4. 2016.
See this document for currently supported Ubuntu releases: https://wiki.ubuntu.com/Releases

I've tried recreating this bug with your release and was unable to, given the information you've provided. Please upgrade to the latest version and re-test. If the bug is still reproducible, increase the verbosity of the steps to recreate it so we can try again.

Do feel free to report any other bugs you may find.

Changed in gwenview (Ubuntu):
status: New → Incomplete
Natalia Bidart (nataliabidart) wrote :

Hi,

I'm suffering from this bug from many releases now. Currently I'm running Xenial, and I just opened gwenview and got the exact same message the bug describes:

URL cannot be listed file:///home/<user>

After installing what the description suggest:

sudo apt-get install kio kinit kdelibs-bin kded5

I don't get errors for file:// urls, but I get this:

URL cannot be listed
remote:/

Please let me know if you need more information from my system. Thanks!

Changed in gwenview (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwenview (Ubuntu):
status: New → Confirmed
kimo (ubuntu-oldfield) wrote :

To reproduce this problem:
boot off the xubuntu live image (tested with 16.04) and run
sudo apt-get install gwenview
gwenview .

This displays a dialogue box with:
Error - Gwenview
URL cannot be listed
file://home/xubntu
[OK]

After which gwenview opens, but it is unable to browse directories.

This bug looks like missing dependencies for gwenview or one of its dependencies.

Johnny Baloney (itdev) wrote :

The problem is still present in 15.12.3 and the workaround solves the issue.

Linux 4.4.0-31-generic #50-Ubuntu SMP Wed Jul 13 00:07:12 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

Package: gwenview
Status: install ok installed
Priority: optional
Section: graphics
Installed-Size: 4505
Maintainer: Ubuntu Developers <email address hidden>
Architecture: amd64
Version: 4:15.12.3-0ubuntu1

shelleyfrank (michael-pienaar) wrote :

On a new install of Linux Mint 18 XFCE 64bit:

sudo apt-get install kio kinit kdelibs-bin kded5

didn't solve the issue, but

sudo apt-get install kinfocenter

did. When kinfocenter is installed an array of dependencies is installed that takes care of the bug.

Julien (jcanivet) wrote :

when launched in a terminal I get the following comment :

org.kde.kurifilter-shorturi: "/"
org.kde.kurifilter-shorturi: (2) path=cmd= "/"
org.kde.kurifilter-shorturi: path = "/" isLocalFullPath= true exists= true url= QUrl("file:///")
org.kde.kurifilter-ikws: "/" : QUrl("file:///") , type = 2
couldn't create slave: "Impossible de créer le module d'entrée / sortie :\nklauncher a retourné : Protocole « file » inconnu.\n"

I tried the solution listed there (sudo apt-get install kinit kio kio-extras kded5 kinfocenter) but it didn't solve the issue

I am running Ubuntu 16.04 LTS upgraded from 14.04 on which there was no issue at all.

Hrotkó Gábor (roti-al) wrote :

With a new install of 16.04, the workaround: 'sudo apt-get install kinit kio kio-extras kded5 kinfocenter' helped.
One should really check the missing dependencies.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers