Moving a file results in wrong pre-filled filename

Bug #1468609 reported by Vanessa Dannenberg on 2015-06-25
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Gwenview
Fix Released
Medium
gwenview (Ubuntu)
Undecided
Unassigned

Bug Description

This is running under Xubuntu 15.04 with the kubuntu-desktop package installed.

Action: Execute the application, navigate to or select a folder full of images, open the folder, and select exactly one image. Press F8 or do File -> Move to...

Result: you'll be presented with a dialog box asking for the target folder, but where the filename should be displayed near the top of the window, "<copyMoveOrLink>" is displayed instead. If you then proceed to choose a target directory and move the file, the file gets renamed to "<copyMoveOrLink>" (with the <> signs).

Expected result: The file should be moved without displaying or being given a gibberish filename. :-)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gwenview (Ubuntu):
status: New → Confirmed
vedavata (vedavrata) wrote :

Yes, i have the same problem:
during "Move To..." or "Copy To...", instead of file name/names GwenView gives this:
 <copyMoveOrLink>
...

vedavata (vedavrata) wrote :

Gwenview
Version 5.0.0 pre
Using KDE Frameworks 5.9.0

Still an issue with the copy found in Debian 8.7 "sid" repository as well, as of 2017-03-13. Gwenview's "About" dialog gives a version number of 16.08.3 (using KDE Frameworks 5.28.0, QT 5.7.1).

Oded Arbel (oded-geek) wrote :

It wasn't an issue for me in previous Ubuntu versions, but with Kubuntu artful (17.10) it started happening to me as well.

Artem Astafyev (artem-astafyev) wrote :

It seems it has been fixed in 17.08.1: https://bugs.kde.org/show_bug.cgi?id=362474.

Oded Arbel (oded-geek) wrote :

I've installed a build of the latest git as of now (supposedly the current state of the 17.11 release) and the fix in the KDE upstream bug 362474 indeed fixed it in that Gwenview now remembers the last path used (which was the purpose of that report) and also doesn't show `<copyMoreOrLink>` as the default file name to copy, move or link to (as was the problem details in KDE upstream bug report 373629 that was marked as a duplicate of the above bug report).

Now instead it doesn't pre-fill the copy, move or link dialog with any file name - which is not a huge improvement.

Changed in gwenview:
importance: Unknown → Medium
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.