gweled plays annoying sound which can't be switched off

Bug #90499 reported by Caspar Clemens Mierau
6
Affects Status Importance Assigned to Milestone
Gweled
Fix Released
Low
Unassigned
gweled (Ubuntu)
Fix Released
Medium
Siegfried Gevatter
Declined for Gutsy by Henrik Nilsen Omma

Bug Description

Binary package hint: gweled

I hope this is more a bug than a feature: gweled on Feisty Herd5 plays an annouying sound that you only can stop by exiting the application. For me that makes the program unusuable.

Related branches

Revision history for this message
Benjamin Rubin (bnrubin) wrote :

I can confirm that as of 0.7-2ubuntu1 that Gweled has music and sounds that cannot be toggled on or off. There is no section in the preferences that has anything to do with audio.

Revision history for this message
Caspar Clemens Mierau (leitmedium) wrote :

As Feisty is heading towards release I'd be nice to have this annonying feature either be switchable or just turned off.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

I confirm this bug. Even the --disable-sound switch on the command line doesn't work.

Changed in gweled:
status: Unconfirmed → Confirmed
Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

This is a preliminary quick-dirty patch to add a preferences to start/stop the background music.

Unfortunatly, this patch suffer two major flaws :

1) Gweled will freeze if you check/uncheck too quickly. I really don't understand why, must be a thread race or something
2) The preference is not saved and, by default, the music play at the start of the application

(to apply this patch, just apt-get source gweled and then patch)

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

the following patch fixes all the previous issues (yes, even the thread one, I understood what happened) and it works great.

Is there an active universe maintener for this package or must I build and submit the package ?

Revision history for this message
Caspar Clemens Mierau (leitmedium) wrote :

Thanks for the efforts to patch against this feature issue. To ask a stupid question: Is there a howto where I can see how to compile ubuntu src packages, patch them with the test patches, install and delete them afterwards?

Best,

Caspar.

Revision history for this message
Emmet Hikory (persia) wrote :

    I am having difficulties applying your patch against gweled 0.7-2ubuntu1. There are two hunks that fail when applied against main.c, and my manual merge attempt leads to compilation failures from undefined references to music_init, music_play, and music_stop. Would you mind regenerating the patch against a fresh `apt-get source gweled`?

    Thank you.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

Emmet, I'm not specialist at making patch. Could you tell me exactly the command I must use so it's easier for you ? Assume that I have an "orig" folder and a "modified" one.

Revision history for this message
John Reese (jreese) wrote :

This is still not fixed in Gutsy as of Tribe 5, and it really needs to be. This is a popular game, and the forced music (and lack of working command-line switch) is a big detraction from using it.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

I still have the "patched" source code available. Just tell me how to pack a correct patch or where to send the code so someone else can make it a patch

Revision history for this message
Henrik Nilsen Omma (henrik) wrote :

This bug was nominated for Gutsy but does currently not qualify for a 7.10 stable release update (SRU) and the nomination is therefore declined.
According the the SRU policy, the fix should already be deployed and tested in the current development version before an update to the stable releases will be considered. With 7.10 now released, that policy applies to this bug. See: https://wiki.ubuntu.com/StableReleaseUpdates .
The bug is not being closed as work will continue on fixing it for the next release, Hardy Heron (8.04). If the state of this bug should change such that it qualifies for the SRU process, please contact the person who originally declined it and ask them to re-evaluate it. To help improve the state of this bug see: https://wiki.ubuntu.com/Bugs/HowToTriage .

Changed in gweled:
importance: Undecided → Medium
Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

I've tried to contact the Debian packager without success. I'm ready to work on my patch, to rebuild a package, to do anything to solve this bug. But WHO should I contact to do this ?

Revision history for this message
Siegfried Gevatter (rainct) wrote :

Please provide a patch that applies correctly against the latest source (0.7-2ubuntu4) and I'll get this into Hardy.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

I reworked my patch so it applies cleanly to the source of the hardy deb package.

1) apply with patch -p0 < music.patch in the gweled-0.7 folder

2) WARNING : you have to remove the mikmod-disable-disk-writers.diff in debian/patches. My patch includes the feature of the mikmod-disable-disk patch.

3) It compiles cleanly on Gutsy but I cannot launch the binary : Gdk-CRITICAL **: gdk_pixmap_new: assertion `(width != 0) && (height != 0)' failed. I think it's not related to my patch because it does the same if I compile the hardy package without patching it.

I hope this solve the problem

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

Ooops, I sent the wrong file.

Here's the one to use :

1) download the patch in your $HOME folder
2) dget -x http://archive.ubuntu.com/ubuntu/pool/universe/g/gweled/gweled_0.7-2ubuntu4.dsc
3) cd gweled-0.7
4) patch -p0 < ../music_preference.patch
5) rm debian/patches/mikmod-disable-disk-writers.diff
6) Build the package (I did with "debuild -i -us -uc -b")

It should work on Hardy, unfortunatly, I don't have an Hardy install to test.

Changed in gweled:
assignee: nobody → ploum
Revision history for this message
Guybrush88 (guybrush) wrote :

@lionel: i tried to do what you've done on hardy but it doesn't work on it. point 4 and point 6 don't work for me.

point 4 gives me that nothing exists in the folder with that name

point 6 gives me that:
davide@Linuxster:~/gweled-0.7$ debuild -i -us -uc -b
dpkg-checkbuilddeps: Unmet build dependencies: cdbs gnome-pkg-tools librsvg2-dev libmikmod2-dev
debuild: fatal error at line 993:
You do not appear to have all build dependencies properly met, aborting.
(Use -d flag to override.)
If you have the pbuilder package installed you can run
/usr/lib/pbuilder/pbuilder-satisfydepends as root to install the
required packages, or you can do it manually using dpkg or apt using
the error messages just above this message.

Revision history for this message
Siegfried Gevatter (rainct) wrote : Re: [Bug 90499] Re: gweled plays annoying sound which can't be switched off

Lionel: Thanks, I'll have a look at it soon this week (I'd look at it
today but I've to study for an exam :/).

Guybrush88: If point 4 fails then you haven't followed the 1st one
(save music_preference.patch in your home folder). For point 6 to work
you have to run "sudo aptitude install cdbs gnome-pkg-tools
librsvg2-dev libmikmod2-dev" first; but this won't create a .deb
(which seems to be what you want), to get an installable .deb run
"dpkg-buildpackage -rfakeroot" instead (after installing those missing
packages).

--
Siegfried-Angel Gevatter Pujals (RainCT)
GNU/Linux User #438657. Ubuntu User #11680.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

Guybrush88 : here's an alternative method :

0) sudo apt-get build-dep gweled
1) dget -x http://archive.ubuntu.com/ubuntu/pool/universe/g/gweled/gweled_0.7-2ubuntu4.dsc
2) cd debian/patches
3) rm mikmod-disable-disk-writers.diff
4) wget http://launchpadlibrarian.net/12350957/music_preference.patch
5) cd ../..
6) sudo debuild -i -us -uc -b

it should produces a lot of stuffs and a .deb file that you can install to try

I'm a bit worried about that crash and I hope it's only related to the fact I'm still in Gutsy

Changed in gweled:
status: Confirmed → In Progress
Revision history for this message
Siegfried Gevatter (rainct) wrote :

In the meantime I'm subscribing the MOTU Release Team for them to approve this change for Hardy, as we are in Feature Freeze now and adding a new configuration option is a new feature.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 90499] Re: gweled plays annoying sound which can't be switched off

Sounds like a bug fix to me. No FFe needed, but please test carefully and
watch the package for bug reports after uploading.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

I tried on Hardy and I still have the crash :
"(gweled:28803): Gdk-CRITICAL **: gdk_pixmap_new: assertion `(width != 0) && (height != 0)' failed"

I really don't understand because my patch doesn't involve playing with this.

I will give it a close look this week.

Revision history for this message
StefanPotyra (sistpoty) wrote :

unsubscribing motu-release. As Scott wrote, no FFe needed, as it's bug fix only.

Revision history for this message
Siegfried Gevatter (rainct) wrote :

Lionel: Any news about that crash?

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

sorry, I will not be able to look at it before the end of this week. But it's very high on my todo list. (Now that I'm in Hardy, it should be easier)

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

I solved the crash simply by deleting the .gweled file.

It's because the binary preferences file is no more compatible (because I added the music preference to it).

So, in itself, my patch is correct.

Because I believe there are no critical data in any .gweled file, I suggest to simply comply to XDG specifications and put a new gweled file in .config without taking into account the old .gweled file.

Revision history for this message
Lionel Dricot (ploum-deactivatedaccount) wrote :

Bug #201509 with patch. Applying both path would make some user loose their preferences but will solves two bugs for the price of one ;-)

Revision history for this message
Siegfried Gevatter (rainct) wrote :

Thanks for your patch, I'll upload it in some minutes!

Changed in gweled:
assignee: ploum → rainct
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gweled - 0.7-2ubuntu5

---------------
gweled (0.7-2ubuntu5) hardy; urgency=low

  * debian/patches/music_preference.diff:
     - Add an option to disable the music (LP: #90499); thanks to Lionel
       Dricot.
  * debian/patches/xdg_pref.diff:
     - Place the configuration file inside ~/.config/ instead of directly
       into the home directory, to follow FD.o's recommendations and to
       workaround a issue which the previous patch would cause otherwise
       (LP: #201509); thanks to Lionel Dricot.
  * debian/patches/desktop-file.diff
     - Remove the deprecated Encoding field.
     - Improve the Comment and add a Catalan translation of it.
  * debian/control.in, debian/control:
     - Bump Standards Version to 3.7.3.
     - Add a Homepage field to the Source stanza.
     - Change "Gnome" in the long description to be all-uppercase.
     - Raise the debhelper dependency's minimum version to 5.0.51~, as
       older versions don't include dh_icons.
  * debian/copyright:
     - Change formatting and make lintian happy about "Author(s)".
     - Add the copyright statement (found in src/callbacks.c) and the
       full GPL header.
  * debian/menu:
     - Quote needs and section's values as suggested by linda and lintian.
  * debian/rules:
     - Add a dh_icons call.

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Mon, 07 Apr 2008 20:34:42 +0200

Changed in gweled:
status: Fix Committed → Fix Released
Changed in gweled:
importance: Undecided → Low
status: New → Fix Committed
importance: Low → Medium
Changed in gweled:
milestone: none → 0.8
Changed in gweled:
importance: Medium → Low
Changed in gweled:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers