Ubuntu

Gweled quit working after update

Reported by Computer Geek on 2006-04-11
32
Affects Status Importance Assigned to Milestone
Gweled
Critical
Unassigned
gweled (Ubuntu)
Medium
MOTU

Bug Description

I did the regular 6.06 Dapper updates one day... i noticed that gweled was one of the upgraded packaged.

Well i run gweled the next day and all that comes up is a blank window no game... the menus don't even do anything not even Help --> about for File --> Quit.

Changed in gweled:
assignee: nobody → motu
Emmet Hikory (persia) wrote :

Confirmed by #39568 and on my system

Changed in gweled:
status: Unconfirmed → Confirmed
bartenev (bartenev) wrote :

I've tried compling the game from source (version 7.0) and got the same bug.
Then I appended -rdynamic option for GCC, and this solved the issiue.
I guess, the package needs to be rebuit with this option...

Andrew Conkling (andrewski) wrote :

I'm not sure about that compile flag, but FWIW I get a bunch of libglade errors like the following:
"(gweled:17754): libglade-WARNING **: could not find signal handler 'drawing_area_button_event_cb'."

Matt Fletcher (mattfletcher) wrote :

I get the same result from a new install of Xubuntu

Barry deFreese (bddebian) wrote :

Uploaded with adding -rdynamic CFLAG. Seems to fix this for me. Thank you.

Changed in gweled:
status: Confirmed → Fix Committed
Emmet Hikory (persia) wrote :

Built on all architectures.

Changed in gweled:
status: Fix Committed → Fix Released
tim_o (tle) wrote :

It is fixed here after today's update. Finally, I can waste my time on this again...

Changed in gweled:
status: New → Fix Committed
importance: Undecided → Critical
milestone: none → 0.8
Changed in gweled:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers