pressing space removes menu

Bug #30441 reported by Bronsen on 2006-02-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gweled
Low
Unassigned
gweled (Ubuntu)
Low
MOTU

Bug Description

After starting gweled I press space (for whatever reasons) and see the menu bar removed from the application; it shows up in the upper left corner of the screen. Pressing space again, restores the menu to its original position.

Even after starting a game it is possible to remove and restore the menu bar. However, it is possible only once: after restoration of the menu bar, pressing space no longer has any visible effect on it.

This does not conflict with game play at all - the game can be continued all the time with no ill effects.

Emmet Hikory (persia) wrote :

I've seen this in other programs as well - most notably with TEG. I suspect a widget issue in the libraries (although I don't know which is responsible).

Changed in gweled:
assignee: nobody → motu
Andy Price (andy-price) wrote :

Confirmed on an up-to-date dapper install. The package looks in bad shape (gweled 0.6-2build1 on dapper) as the maintainer discontinued development at version 0.7 seemingly in May 2005[1] admittedly using libraries that are going to be/have been deprecated and not having time for it any more.

[1: http://sebdelestaing.free.fr/gweled/ ]

Changed in gweled:
status: Unconfirmed → Confirmed
Andreas Gnau (rondom) wrote :

From what I can see, he says this about the use of the gnome scores library.

This is still an issue on Feisty Herd5, though not a severe problem as you can toggle by repeat to press space. I guess, too, this is a widget issue.

Guybrush88 (guybrush) wrote :

confirmed on ubuntu hardy alpha 5

Lionel Dricot (ploum) wrote :

Emmet, can you confirm that it happens on other application too ? Because if it's the case, it's definitely a Gtk bug (it seems to be).

If Gweled depend on deprecated libraries, please open bug about it, I might take a look about them.

Daniel T Chen (crimsun) wrote :

(Demoting importance due to workaround.)

Changed in gweled:
importance: Medium → Low
Paul Elms (scifly) wrote :

This is still a bug in jaunty.

Changed in gweled:
importance: Undecided → Low
status: New → Fix Committed
Changed in gweled:
milestone: none → 0.8
Lionel Dricot (ploum) wrote :

Daniele > could you please tell me how the bug was fixed ? I'm very curious about it as I looked in the code a few times, finding nothing.

Daniele Napolitano (dnax88) wrote :

@Lionel: Just dropped deprecated BonoboUI code in the Glade file (now GtkBuilder). Was a old GNOME "feature"...

Changed in gweled:
status: Fix Committed → Fix Released
Daniele Napolitano (dnax88) wrote :

Fixed in Ubuntu 10.10 Maverick.

Changed in gweled (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers