High score incorrectly reported

Bug #244064 reported by Andrew on 2008-06-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Gweled
Low
Unassigned
gweled (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gweled

Every time the game reports that it was a high score even when it wasn't

Ubuntu Hardy
Gweled 0.7-2ubuntu5

Trygve Vea (trygve-vea-gmail) wrote :

I agree with the reporter, and I took the liberty to fix it.

As far as I can tell, this only occurs on timed gameplay.

Charlie_Smotherman (cjsmo) wrote :

This has been fixed in jaunty

Changed in gweled (Ubuntu):
status: New → Fix Released
Trygve Vea (trygve-vea-gmail) wrote :

I beg to differ.

Jaunty comes with the same package as Intrepid, and gweled_0.7-2ubuntu6 still has this error. I need to point out that it only occurs during timed gameplay.

And to specify the problem further; The problem is that the highscore-window which pops up when the game is ended, displays the wrong text. This is caused by show_hiscores being called with a positive value.

show_hiscores is designed to be called with an integer from 0-10 as the argument, where 0 indicates that you didn't get on the highscore-list (or, just show the highscore list) --- and where 1-10 indicates which position you got on the list. If the argument is above 0 it displays the text.

And as you can see in my patch, I remove the line which calls show_hiscores(gi_score), which would usually call it with a value exceeding 10, and therefore only affect the text saying "You made the highscore list", when you may not have done so. In addition, if you actually make the highscore list, the intention of show_hiscores is to make your position appear in bold. This will in timed gameplay always appear with a regular font, because show_hiscores get called twice (where the second one changes the font back to regular).

My patch does in practice not show the highscore if you don't make the list, and if you make the list it shows your position in bold with the correct text.

If one would also like to show the highscore even if you don't make the list, one could probably apply my patch and remove the line " if (hiscore_rank > 0)", so that show_highscores(hiscore_rank) gets called no matter how the game ended.

Changed in gweled:
status: New → Fix Committed
importance: Undecided → Low
milestone: none → 0.8
Changed in gweled:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers