Get rid of .gweled file and follow fd.o specifications

Bug #201509 reported by Lionel Dricot on 2008-03-12
4
Affects Status Importance Assigned to Milestone
Gweled
Low
Unassigned
gweled (Ubuntu)
Wishlist
Siegfried Gevatter

Bug Description

Binary package hint: gweled

Gweled shouldn't create a .gweled file.

According to fd.o specification, it should put user preferences in
$XDG_CONFIG_HOME.

Any user data should go to $XDG_DATA_HOME (High-scores ?).

Any cache stuffs should go to $XDG_CACHE_HOME.

More infos : http://standards.freedesktop.org/basedir-spec/latest/ar01s03.html

The reason why I'm reporting this bug :
http://ploum.frimouvy.org/?184-cleaning-user-preferences-keeping-user-data

Related branches

Lionel Dricot (ploum) wrote :

Trivial patch to fix the bug

Note : we don't import old preferences.

Changed in gweled:
assignee: nobody → ploum
Jorge Castro (jorge) on 2008-03-13
Changed in gweled:
status: New → Confirmed
Lionel Dricot (ploum) on 2008-03-13
Changed in gweled:
status: Confirmed → In Progress
antistress (antistress) wrote :

"Note : we don't import old preferences."

For release note, you can look at what Totem dev did :
"NEWS: totem-2.21.94:
Note that configuration files are now in ~/.config/totem/ instead
of ~/.gnome2/Totem. You will need to move the files by hand"

Siegfried Gevatter (rainct) wrote :

I'd like to get feedback from someone else about this patch.

Lionel Dricot (ploum) wrote :

Do you want that I make this patch import the old preferences file if it exists ? Would it makes you accept the patch ?

Also, I've created an Ubuntu proposal for this XDG spec : http://brainstorm.ubuntu.com/idea/6557/

There's also a gnome goal suggestion :
http://live.gnome.org/GnomeGoals/XDGConfigFolders

If you can get it ready before the 10th, yes. Else try to convince
some other MOTU and if he agrees that we want this I'll upload it.
Thanks.

Siegfried Gevatter (rainct) wrote :

(Convincing that other MOTU would have to be before the 10th, too.)

Lionel Dricot (ploum) wrote :

For the record, here's the proposal to follow this spec :
http://brainstorm.ubuntu.com/idea/6557/

Lionel Dricot (ploum) wrote :

I think that we can safely get rid of the old preferences because, currently, preferences only contain :

- The size of the board (small, medium or large)
- the game type (normal or against clock)

 so, the only thing that will happen is that some user will see the size of the board resetted to "medium" instead of large and small and the game type will be reset to "normal".

I think adding backward compatibility code for such a little thing is too much overhead for no real gain : reseting the option is a matter of second.

Also, a warning could be provided in the release note.

If you don't agree then some code should be added that check for old config files but, unless we change the config file format to XML, it will become quickly unmaintenable if we add more options later.

Lionel Dricot (ploum) wrote :

Also, it has to be noted as a side-joke that for a very long time, gweled preferences were not working so gweled users are used to preferences reset ;-)

Changed in gweled:
assignee: ploum → rainct
importance: Undecided → Wishlist
Siegfried Gevatter (rainct) wrote :

I'll upload a new revision including this patch in a few minutes. Thank you for working on this!

Changed in gweled:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gweled - 0.7-2ubuntu5

---------------
gweled (0.7-2ubuntu5) hardy; urgency=low

  * debian/patches/music_preference.diff:
     - Add an option to disable the music (LP: #90499); thanks to Lionel
       Dricot.
  * debian/patches/xdg_pref.diff:
     - Place the configuration file inside ~/.config/ instead of directly
       into the home directory, to follow FD.o's recommendations and to
       workaround a issue which the previous patch would cause otherwise
       (LP: #201509); thanks to Lionel Dricot.
  * debian/patches/desktop-file.diff
     - Remove the deprecated Encoding field.
     - Improve the Comment and add a Catalan translation of it.
  * debian/control.in, debian/control:
     - Bump Standards Version to 3.7.3.
     - Add a Homepage field to the Source stanza.
     - Change "Gnome" in the long description to be all-uppercase.
     - Raise the debhelper dependency's minimum version to 5.0.51~, as
       older versions don't include dh_icons.
  * debian/copyright:
     - Change formatting and make lintian happy about "Author(s)".
     - Add the copyright statement (found in src/callbacks.c) and the
       full GPL header.
  * debian/menu:
     - Quote needs and section's values as suggested by linda and lintian.
  * debian/rules:
     - Add a dh_icons call.

 -- Siegfried-Angel Gevatter Pujals (RainCT) <email address hidden> Mon, 07 Apr 2008 20:34:42 +0200

Changed in gweled:
status: Fix Committed → Fix Released
Changed in gweled:
status: New → Fix Committed
importance: Undecided → Low
milestone: none → 0.8
Changed in gweled:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments