gwaterfall lacks a .desktop file

Bug #124791 reported by Timmie on 2007-07-08
4
Affects Status Importance Assigned to Milestone
gwaterfall (Debian)
Fix Released
Unknown
gwaterfall (Ubuntu)
Low
Unassigned

Bug Description

Hello,
gwaterfalll lacks a .desktop file. After installation it just vanishes.
Why couldn't have one as similar to gnome-specimen?

Are there any guidelines for desktop-files.

Greetings!

Related branches

Siegfried Gevatter (rainct) wrote :

Thanks for your notice.

You can read about creating .desktop files here: https://wiki.ubuntu.com/MOTU/Packages/DesktopFiles . The latest specifications for the files are available here: http://standards.freedesktop.org/desktop-entry-spec/latest/ .

Also, you can find a list of possible categories for the menu entry here: http://standards.freedesktop.org/menu-spec/latest/apa.html . Every .desktop file needs at least one main category, and can have many additional categories.

If you are on Gutsy you can check if a .desktop file is correct running "desktop-file-validate <package>.desktop" on a terminal (this command is provided by the package "desktop-file-utils", which has many deprecations on Feisty).

Changed in gwaterfall:
importance: Undecided → Low
Siegfried Gevatter (rainct) wrote :

(Bug confirmed, the package provides a .menu but not a .desktop.)

Did you ask about the guidelines because you want to add it yourself?

If so tell it and, when you start working on it, change this bug's status to «In Progress» and assign it to yourself. Else I'll do this ;).

Changed in gwaterfall:
assignee: nobody → rainct
status: New → Confirmed
Timmie (timmie) wrote :

> Did you ask about the guidelines because you want to add it yourself?
I thought. But it may take some time. If you know how to do this quickly then you may take the lead. ;-)

Siegfried Gevatter (rainct) wrote :

No problem, go on if you want.

Changed in gwaterfall:
assignee: rainct → nobody

Hi Siegfried,
I think I will try to fix this bug which seems quite easy to work on, but if I do so, I will need your help, because it's the first time I try to fix or package something "for real".
If I set the bug status to "In progress" and if it appears after that I am unable to fix it, would it still be possible to set back the status to "Confirmed ?"

So, I'm now going to try my first bug fix. :)

Changed in gwaterfall:
assignee: nobody → nicolas-robin
status: Confirmed → In Progress
Siegfried Gevatter (rainct) wrote :

Yes, you can always set it back. And don't worry, it isn't that difficult.

If you need help feel free to ask here, send me a mail or ping me on irc.freenode.net (RainCT).

Some usefull pages to solve this bug are:

 - https://wiki.ubuntu.com/MOTU/Packages/DesktopFiles

 - http://standards.freedesktop.org/desktop-entry-spec/latest/ (for the .desktop file)

 - http://standards.freedesktop.org/menu-spec/latest/apa.html (categories for the .desktop file)

If you need more detailed instructions just ask in any of the ways I mentioned before and I'll write a steep-by-steep explanation for you or whatever is needed ;).

Here is the debdiff, thanks to RainCT :)

Here is the second debdiff, which solves some packaging mistakes ( newbies are newbies... )

Changed in gwaterfall:
status: In Progress → Fix Committed
Changed in gwaterfall:
status: Fix Committed → Confirmed
Changed in gwaterfall:
assignee: nicolas-robin → nobody
status: Confirmed → Fix Committed
status: Fix Committed → Confirmed

bug forwarded upstream

Changed in gwaterfall:
status: New → Unknown
Changed in gwaterfall:
status: Unknown → New
Daniel Holbach (dholbach) wrote :

Please call dh_desktop in debian/rules somewhere, or make use of gnome.mk instead of autotools.mk.

Changed in gwaterfall:
status: Confirmed → Incomplete

Here is a new debdiff, where debian/rules has been fixed.

Changed in gwaterfall:
status: Incomplete → Confirmed
Daniel Holbach (dholbach) wrote :

Uploaded. Thanks.

Changed in gwaterfall:
status: Confirmed → In Progress

gwaterfall (0.1-4ubuntu1) gutsy; urgency=low

  * Added .desktop file (LP: #124791)
  * Updated maintainer field to match DebianMaintainerField spec
  * Corrected grammatical errors in description

 -- Nicolas Robin <email address hidden> Wed, 15 Aug 2007 22:17:12 +0200

Changed in gwaterfall:
status: In Progress → Fix Released

I'm unsubscribing Ubuntu Sponsors for universe as there is no more uploads needed for Ubuntu.

Artur Rona (ari-tczew) on 2009-10-02
tags: added: patch
removed: bitesize desktop-file
Changed in gwaterfall (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.