[SRU] There is no executable in this package

Bug #1513567 reported by cariboo on 2015-11-05
144
This bug affects 25 people
Affects Status Importance Assigned to Milestone
gwakeonlan (Debian)
Fix Released
Unknown
gwakeonlan (Ubuntu)
Medium
Unassigned
Xenial
High
Unassigned

Bug Description

List of files from gwakeonlan 0.5.1-1.1 (in Ubuntu 16.04 Xenial) package:

/usr/share/doc/gwakeonlan/changelogwakeonlang.Debian.gz
/usr/share/doc/gwakeonlan/copyright

List of files from gwakeonlan 0.5.1-1.2 Ubuntu Yakkety (or Wily) packages:

/usr/bin/gwakeonlan
/usr/share/applications/gwakeonlan.desktop
/usr/share/doc/gwakeonlan/README
/usr/share/doc/gwakeonlan/changelog.Debian.gz
/usr/share/doc/gwakeonlan/changelog.gz
/usr/share/doc/gwakeonlan/copyright
/usr/share/doc/gwakeonlan/translators
/usr/share/gwakeonlan/gWakeOnLan-0.5.1-py2.6.egg-info
/usr/share/gwakeonlan/gwakeonlan.glade
/usr/share/gwakeonlan/gwakeonlan.svg
/usr/share/locale/de/LC_MESSAGES/gwakeonlan.mo
/usr/share/locale/en_US/LC_MESSAGES/gwakeonlan.mo
/usr/share/locale/es/LC_MESSAGES/gwakeonlan.mo
/usr/share/locale/fr/LC_MESSAGES/gwakeonlan.mo
/usr/share/locale/it/LC_MESSAGES/gwakeonlan.mo
/usr/share/locale/nl/LC_MESSAGES/gwakeonlan.mo
/usr/share/locale/ru/LC_MESSAGES/gwakeonlan.mo
/usr/share/locale/sk/LC_MESSAGES/gwakeonlan.mo
/usr/share/man/man1/gwakeonlan.1.gz

[Regression Potential]
Updating gwakeonlan to ver 0.5.1-1.2 from Yakkety can't cause any regression because current package in Xenian is empty ;)

Hans Joachim Desserud (hjd) wrote :

Thanks for reporting this issue.

I can confirm this issue affects gwakeonlan 0.5.1-1.1 on Ubuntu Xenial by comparing the list of files for 15.10 [1] and Xenial [2]. I found that the same issue has also been reported in Debian, so I have attached a bug watch.

[1] http://packages.ubuntu.com/wily/all/gwakeonlan/filelist
[2] http://packages.ubuntu.com/xenial/all/gwakeonlan/filelist

Changed in gwakeonlan (Ubuntu):
status: New → Confirmed
tags: added: xenial
Changed in gwakeonlan (Debian):
status: Unknown → New
Changed in gwakeonlan (Ubuntu):
importance: Undecided → Medium
TenLeftFingers (tenleftfingers) wrote :

Working package available for manual installation on 16.04 here: http://www.muflone.com/gwakeonlan/english/download.html#tabs|Tabs_Group_name:Tab_v051

Changed in gwakeonlan (Debian):
status: New → Fix Committed
summary: - Xenial:There is no executable in this package
+ [Xenial] There is no executable in this package

also ubuntu 16.06 affected, no executable in package.

Changed in gwakeonlan (Debian):
status: Fix Committed → Fix Released
Hans Joachim Desserud (hjd) wrote :

Based on the Debian bug report there should be a fix available, and version 0.5.1-1.2 in Ubuntu Yakkety seems to have restored the packaged content. See http://packages.ubuntu.com/yakkety/all/gwakeonlan/filelist for list of files.

This is a significant bug in Ubuntu. In order to get the fix into 16.04 of Ubuntu, someone should start looking at the SRU Procedure [1] to bring the need to a developer's attention.

 [1]: https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

tags: added: regression-release
description: updated
summary: - [Xenial] There is no executable in this package
+ [SRU] There is no executable in this package
mtb-cliff (pagedynamix) wrote :

I tried installing from http://www.muflone.com/gwakeonlan/english/download.html#tabs|Tabs_Group_name:Tab_v051, but I get the following error reports when trying to run it whether it is installed with gdebi, or software centre.

/usr/local/lib/python2.7/dist-packages/gwakeonlan/functions.py:24: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/gwakeonlan/app.py", line 35, in startup
    self.ui = MainWindow(self, self.settings)
  File "/usr/local/lib/python2.7/dist-packages/gwakeonlan/ui.py", line 34, in __init__
    self.loadUI()
  File "/usr/local/lib/python2.7/dist-packages/gwakeonlan/ui.py", line 58, in loadUI
    builder.add_from_file(FILE_UI_MAIN)
GLib.Error: g-file-error-quark: Failed to open file '/usr/share/gwakeonlan/ui/main.glade': No such file or directory (4)
Traceback (most recent call last):
  File "/usr/local/lib/python2.7/dist-packages/gwakeonlan/app.py", line 52, in activate
    self.ui.run()
AttributeError: 'Application' object has no attribute 'ui'

mtb-cliff (pagedynamix) wrote :

I finally got it to work by first performing:
sudo apt-get remove --auto-remove gwakeonlan
and then deleting /usr/local/bin/gwakeonlan
then reinstalling the v051 from http://www.muflone.com/gwakeonlan/english/download.html#tabs|Tabs_Group_name:Tab_v051 via gdebi.

However, when I run this version it doesn't use the files from ~/.config/gwakeonlan

ITEAS (info-tux-pc) wrote :

Please insert the binary ... oh my god ;(

handband2 (handband2) wrote :

I got it working by installing the following:

sudo apt install gwakeonlan python-xdg

Andreas Moog (ampelbein) on 2017-05-26
Changed in gwakeonlan (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Changed in gwakeonlan (Ubuntu):
status: Confirmed → Fix Released
Andreas Moog (ampelbein) wrote :

I uploaded a fixed package to the archive, the SRU team will review and comment. Here is my changelog:

 gwakeonlan (0.5.1-1.1ubuntu0.1) xenial; urgency=medium
 .
   * Stable Release Update: (LP: #1513567)
     The previous package was empty due to a packaging error, this update uses
     the packaging from version 0.5.1-1.2, this includes:
     - drop cdbs
     - use setuptools
     - use compat level 9

Changed in gwakeonlan (Ubuntu Xenial):
status: Triaged → In Progress
Ioann (yanunim95) wrote :

Hi.

I'm using ubuntu 16.04.
After installation of gwakeoflan i haven found any executables.

Here is list of installed files

/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/gwakeonlan
/usr/share/doc/gwakeonlan/changelog.Debian.gz
/usr/share/doc/gwakeonlan/copyright

This bug seems to have either not been fixed correctly or the bug was reintroduced. I've just installed and there is again no binary file. Please re-open.

Get:1 http://ie.archive.ubuntu.com/ubuntu xenial/universe amd64 gwakeonlan all 0.5.1-1.1 [2,230 B]

Is missing the binary.

Hans Joachim Desserud (hjd) wrote :

Thanks for checking in.

0.5.1-1.1 is the original version (ie the one where the bug was first reported), so that is naturally still missing the binary.

The fix should be in 0.5.1-1.1ubuntu0.1 which should currently be in progress for 16.04, but I cannot really find a trace of it anywhere (https://launchpad.net/ubuntu/+source/gwakeonlan). Is it stuck in review somewhere?

Robie Basak (racb) wrote :

Sorry, the SRU review queue is quite long at the moment.

This looks fine, but your upload was missing the Launchpad-Bugs-Fixed field. To save time I've re-uploaded a fixed changes file for you. Please make sure to use Ubuntu's dpkg-gencontrol next time.

Changed in gwakeonlan (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial

Hello cariboo, or anyone else affected,

Accepted gwakeonlan into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gwakeonlan/0.5.1-1.1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

rpr nospam (rpr-nospam) wrote :

I've tested gwakeonlan 0.5.1-1.1ubuntu0.1 and it works fine.

tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gwakeonlan - 0.5.1-1.1ubuntu0.1

---------------
gwakeonlan (0.5.1-1.1ubuntu0.1) xenial; urgency=medium

  * Stable Release Update: (LP: #1513567)
    The previous package was empty due to a packaging error, this update uses
    the packaging from version 0.5.1-1.2, this includes:
    - drop cdbs
    - use setuptools
    - use compat level 9

 -- Andreas Moog <email address hidden> Fri, 26 May 2017 15:32:37 +0200

Changed in gwakeonlan (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gwakeonlan has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.