Ubuntu

browse/import photos from camera broken in 12.04

Reported by Frank Trcka on 2012-05-07
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
gvfs
Unknown
Medium
gvfs (Ubuntu)
Low
Unassigned

Bug Description

Description: Ubuntu 12.04 LTS
Release: 12.04
gvfs-backends:
  Installed: 1.12.1-0ubuntu1

I have a Canon A20.
Camera is detected OK, can display directories. But when I try to enter the directory with photos in it, the window stops responding and process gvsfd-gphoto2 starts continuously increasing its memory usage until I turn the camera off or kill the process. This problem has been repeated on several different machines.
Camera and photo browsing works no problem in 11.10.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed

I have the same problem with a Canon Digital Ixus V3 / Ubuntu 12.04. I killed gvsfd-gphoto2 when it was using more than 2.5 GB of memory. There are 100MB of jpg-pictures and 10 MB of mpg-movies (only a few seconds) saved on the camera. With Ubuntu 11.10 browsing/copying works just fine.

Same problem like #2.

ubuntu4me (ubuntu4me-rogers) wrote :

I am experiencing the same issue with my Canon PowerShot A40

mmalmeida (mmalmeida) wrote :

I have a Canon 20D and seem to have the exact same problem.

I've tried connecting the camera via usb (normal, not PTP, mode) on 3 computers:

- Laptop 1 with Ubuntu 12.04
- Laptop 2 with Ubuntu 12.04
- Desktop with Ubuntu 10.10

On both Ubuntu 12.04 machines, in Nautilus:
1) I can open the [Camera]/DCIM directory;
2) When I try to open a xxxCanon directory the computer will freeze, hard drive will start to be hammered and will stay like that indefinitely

I'm currently reporting this on my desktop with 10.10 *while* importing the pictures from the exact same camera and usb cable. It's importing without any problems or hickups.

How can I help you guys figure this out? It's a blocker bug for using the computer with the camera.

guwrt (royguertin) wrote :

Same problem with my Canon A40. I am using Ubuntu 12.04 LTS. This problem was not in the previous versions since 2008. I own my cam since 2002.

When I kill the process gvsfd-gphoto2 and I plug in my cam via the usb cable, nothing happens and the cam is not mounted automatically.

I use Gthumb and Shotwell and the issu is the same.

Sebastien Bacher (seb128) wrote :

@wild_oscar: your issue seems a different one, if the computer freezes it seems an xorg or kernel issue, could you open a new bug report using ubuntu-bug?

Alexey (alekseypg) wrote :

fresh install ubuntu 12.04 + Cannon G5 camera = not working.. under 11.10 worked.

mmalmeida (mmalmeida) wrote :

@seb128 - the description seems pretty similar to this one, though: the computer freezes because it doesn't have resources to keep up with hdd hammering. If I plug the camera off it resumes.

I will report the bug as you suggested and will link it here, so you can decide if they're related.

Same issue with Canon 350D
It was working with 10.10, 11.04 and 11.10, but it doesn't work with 12.04.
Shotwell starts to communicate with the camera (LED is blinking), but after 15 minutes, the application crashes (it is using much RAM).
Same issue with other programs: digikam, pcmanfm

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gvfs (Ubuntu):
importance: Undecided → Low
mmalmeida (mmalmeida) wrote :

@Sebastien:

I've just added it in Gnome bugs: Bug 679251 https://bugzilla.gnome.org/show_bug.cgi?id=679251

Is this enough? Where should we move from here?

Sebastien Bacher (seb128) wrote :

@wild_oscar: thanks, let's wait to see what the GNOME guys say about the issue

Changed in gvfs (Ubuntu):
status: Confirmed → Triaged
Changed in gvfs:
importance: Unknown → Medium
status: Unknown → New
Kåre Särs (kare-sars-iki) wrote :

The bug must be in gphoto2 as I get the same problem on 12.04 with gphoto2 commandline tool and with kio_camera.

Sebastien Bacher (seb128) wrote :

Is that still an issue with that update:
https://launchpad.net/ubuntu/+source/libgphoto2/2.4.13-1ubuntu1.2

"libgphoto2 (2.4.13-1ubuntu1.1) precise-proposed; urgency=low

  * Add 85-fix-hang-during-file-download.patch to fix regression introduced
    in v2.4.13 which causes gphoto to hang while downloading from camera.
    (LP: #981062)"

Alexey (alekseypg) wrote :

bug fixed.. downloading photos from camera is worked.. thx

guwrt (royguertin) wrote :

Same for me. Bug seem to be fixed. Downloading photos from my Canaon A40 is ok now. Thanks for your support.

Changed in gvfs (Ubuntu):
status: Triaged → Fix Released
Changed in gvfs:
status: New → Unknown
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.