gvfsd-gphoto2 crashed with SIGABRT in __libc_message()

Bug #984993 reported by Grizz Granlien on 2012-04-18
176
This bug affects 26 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Critical
gvfs (Ubuntu)
High
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
High
Unassigned

Bug Description

[ Decscription ]

gvfsd-photo2 crashes with a segfault because a mutex is freed twice

This is currently #6 on errors.ubuntu.com:

https://errors.ubuntu.com/bucket/?id=%2Fusr%2Flib%2Fgvfs%2Fgvfsd-gphoto2%3A***%20glibc%20detected%20***%20%2Fusr%2Flib%2Fgvfs%2Fgvfsd-gphoto2%3A%20double%20free%20or%20corruption%20(fasttop)%3A%20ADDR%20***

[ Test case ]

I don't have a clear reproducer; see that the crash dropps off on errors with the SRUed version.

[ Regression Potential ]

Check that gvfs works correctly, and that no crashes appear on errors.ubuntu.com

I clicked on update manager and it craps out.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gvfs-backends 1.12.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-23.36-generic-pae 3.2.14
Uname: Linux 3.2.0-23-generic-pae i686
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu4
Architecture: i386
Date: Wed Apr 18 09:16:38 2012
ExecutablePath: /usr/lib/gvfs/gvfsd-gphoto2
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcCmdline: /usr/lib/gvfs/gvfsd-gphoto2 --spawner :1.2 /org/gtk/gvfs/exec_spaw/4
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_CA.UTF-8
Signal: 6
SourcePackage: gvfs
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 g_mutex_clear () from /lib/i386-linux-gnu/libglib-2.0.so.0
Title: gvfsd-gphoto2 crashed with SIGABRT in raise()
UpgradeStatus: Upgraded to precise on 2012-04-18 (0 days ago)
UserGroups: adm admin cdrom dialout dip fax floppy fuse lpadmin plugdev sambashare sudo tape vboxusers video

StacktraceTop:
 __libc_message (do_abort=2, fmt=0xb73163bc "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0x8e60778) at malloc.c:5007
 g_mutex_impl_free (mutex=0x8e60778) at /build/buildd/glib2.0-2.32.1/./glib/gthread-posix.c:113
 g_mutex_clear (mutex=0x8e60854) at /build/buildd/glib2.0-2.32.1/./glib/gthread-posix.c:187
 release_device (gphoto2_backend=0x8e60820) at gvfsbackendgphoto2.c:621

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
summary: - gvfsd-gphoto2 crashed with SIGABRT in raise()
+ gvfsd-gphoto2 crashed with SIGABRT in __libc_message()
tags: removed: need-i386-retrace
tags: added: quantal running-unity
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
Changed in gvfs (Ubuntu):
importance: Medium → High
Michael Terry (mterry) on 2012-10-10
Changed in gvfs (Ubuntu):
assignee: nobody → Michael Terry (mterry)
Michael Terry (mterry) on 2012-10-10
Changed in gvfs (Ubuntu):
assignee: Michael Terry (mterry) → nobody
Changed in gvfs:
importance: Unknown → Medium
status: Unknown → New
Changed in gvfs:
importance: Medium → Critical
status: New → Fix Released
Iain Lane (laney) on 2013-03-05
description: updated
Changed in gvfs (Ubuntu Raring):
status: Confirmed → Fix Released
Changed in gvfs (Ubuntu Quantal):
status: New → In Progress
Changed in gvfs (Ubuntu Precise):
status: New → In Progress

Hello Grizz, or anyone else affected,

Accepted gvfs into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gvfs/1.12.1-0ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gvfs (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

This fix is included with the upload of gvfs 1.14.2-0ubuntu0.1 which is being tracked in bug 1072508.

Changed in gvfs (Ubuntu Quantal):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

The are only a couple of errors regarding version 1.12.1-0ubuntu1.2 (and 1.14.2-0ubuntu0.1) so I am marking this as verification-done.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.12.1-0ubuntu1.2

---------------
gvfs (1.12.1-0ubuntu1.2) precise; urgency=low

  * debian/patches/clear-mutex-once.patch: Backport patch from upstream to
    make sure to not call g_clear_mutex twice; fixing a crash (LP: #984993)
 -- Iain Lane <email address hidden> Tue, 05 Mar 2013 12:43:42 +0000

Changed in gvfs (Ubuntu Precise):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) wrote :

quantal has seen the end of its life and is no longer receiving any updates. Marking the quantal task for this ticket as "Won't Fix".

Changed in gvfs (Ubuntu Quantal):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.