icedtea-netx should handle jnlp mime type

Bug #949823 reported by Timo Aaltonen on 2012-03-08
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
desktop-file-utils (Ubuntu)
Low
Unassigned
gvfs (Ubuntu)
Low
Unassigned

Bug Description

Even if you have icedtea-netx installed and open a jnlp link from firefox, it'll offer to open it using firefox which results in a new tab and a new popup (= a loop). Same thing with nautilus; firefox is the default app to open it, and "icedtea web start" is fourth on the list!

Therefore, Icedtea-netx should bump the priority claiming to support this mimetype so that it's the preferred way to open such links.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: icedtea-netx 1.2~pre3-3ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.94-0ubuntu2
Architecture: amd64
Date: Thu Mar 8 10:29:14 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/zsh
SourcePackage: icedtea-web
UpgradeStatus: Upgraded to precise on 2012-02-16 (21 days ago)

Timo Aaltonen (tjaalton) wrote :
Changed in icedtea-web (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in icedtea-web (Ubuntu):
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :
Sebastien Bacher (seb128) wrote :

reassigning to gvfs as well, it should not default to the handle for a subtype when there is an handler for the exact type

Changed in desktop-file-utils (Ubuntu):
importance: Undecided → Low
status: New → In Progress
affects: icedtea-web (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
importance: Medium → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package desktop-file-utils - 0.20-0ubuntu2

---------------
desktop-file-utils (0.20-0ubuntu2) precise; urgency=low

  * debian/defaults.list:
    - set icedtea-netx-javaws as default jnlp handler (lp: #949823)
 -- Sebastien Bacher <email address hidden> Wed, 11 Apr 2012 16:01:16 +0200

Changed in desktop-file-utils (Ubuntu):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

settings invalid for gvfs, I tracked that down this week and it was a glib issue, see bug #901171 for the details but basically if there was no default handler for the exact mimetype if would prefer the default handler for a subtype to an handle for the exact type.

Said different if java source is a subclass of xml with no default handler for java_source and firefox default for xml it would pick firefox (the default for the subtype)

Changed in gvfs (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers