Regression: nautilus not mounting network share in ~/.gvfs

Bug #945399 reported by Laurent Dinclaux on 2012-03-03
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Low
Unassigned

Bug Description

When accessing a network share, nautilus doesn't mount it in ~/.gvfs as it used to.

In fact in 12.04, that ~/.gvfs is simply not there...

It is a serious issue as most app can't access network share using smb:// like, for eg. Ecplipse.

Here we use Ubuntu on all our worksations and we have a developmment server where every employe connect thru SMB (gvfs) to work on it. With such a bug, Ubuntu become useless to us.

Apps running in Wine aren't able to access network shares either if not mounted in .gvfs .

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: nautilus 1:3.3.90-0ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.94-0ubuntu1
Architecture: amd64
Date: Sat Mar 3 15:58:23 2012
EcryptfsInUse: Yes
GsettingsChanges: org.gnome.nautilus.window-state geometry '800x550+49+24'
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120301)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Laurent Dinclaux (dreadlox) wrote :
Changed in nautilus (Ubuntu):
status: New → Confirmed
Laurent Dinclaux (dreadlox) wrote :

Can this bug get any attention please? Is it a bug? A removed feature?

That feature saved my life when it appear, I work a lot on SMB shares.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, do you have gvfs-fuse installed?

Changed in nautilus (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Laurent Dinclaux (dreadlox) wrote :

Yes as I can:

- mkdir ~/Mount
- /usr/lib/gvfs/gvfs-fuse-daemon ~/Mount

And I then see my shares in that ~/Mount folder. (I used ~/Mount in case an update would bring back ~/.gvfs)

Also when browsing using nautilus, the location bar still shows smb:// (intended behaviour maybe?)

Changed in nautilus (Ubuntu):
status: Incomplete → Confirmed
Laurent Dinclaux (dreadlox) wrote :

Xubuntu 12.04 seems affected too: http://ubuntuforums.org/showthread.php?p=11741223

Laurent Dinclaux (dreadlox) wrote :

The mount point is now ~/.cache/gvfs, that sould be stated somewhere...

Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
Sebastien Bacher (seb128) wrote :

it will be fixed in 1.11.5
"* fuse: Keep using ~/.gvfs as fallback"

Changed in nautilus (Ubuntu):
status: Invalid → Fix Committed
affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.11.5-1ubuntu1

---------------
gvfs (1.11.5-1ubuntu1) precise; urgency=low

  * Merge with Debian experimental. Remaining Ubuntu changes:
    - debian/control.in: Drop libbluray-dev build dependency (not in main).

gvfs (1.11.5-1) experimental; urgency=low

  [ Michael Biebl ]
  * Bump Build-Depends on cdbs and debhelper for multiarch support.
  * Replace Depends on fuse-utils with fuse, as fuse-utils is now only a
    transitional package depending on fuse.

  [ Martin Pitt ]
  * debian/watch: Watch for development versions in experimental.
  * New upstream release:
    - fuse: Keep using ~/.gvfs as fallback (LP: #945399)
  * Drop 02_deprecated.patch: Fixed upstream.
  * debian/control.in: Bump glib build dependency as per configure.ac.
  * debian/copyright: Move to copyright format 1.0.
  * debian/control.in: Bump Standards-Vesion to 3.9.3.
 -- Martin Pitt <email address hidden> Wed, 21 Mar 2012 09:24:41 +0100

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers