gvfsd-smb crashed with SIGSEGV in g_vfs_job_run()

Bug #912972 reported by Federico Tello Gentile on 2012-01-06
150
This bug affects 35 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
High
Michael Terry
Precise
High
Michael Terry

Bug Description

I was importing music into rhythmbox from a shared folder. The other computer is also Precise.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: gvfs-backends 1.10.1-1ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Fri Jan 6 20:24:18 2012
ExecutablePath: /usr/lib/gvfs/gvfsd-smb
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: /usr/lib/gvfs/gvfsd-smb --spawner :1.1 /org/gtk/gvfs/exec_spaw/4
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=es_AR:es
 LANG=es_AR.UTF-8
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 g_vfs_job_run () from /usr/lib/i386-linux-gnu/gvfs/libgvfsdaemon.so
 ?? () from /usr/lib/i386-linux-gnu/gvfs/libgvfsdaemon.so
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
 start_thread () from /lib/i386-linux-gnu/libpthread.so.0
Title: gvfsd-smb crashed with SIGSEGV in g_vfs_job_run()
UpgradeStatus: Upgraded to precise on 2011-12-31 (6 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

StacktraceTop:
 g_vfs_job_run (job=0x9248168) at gvfsjob.c:198
 job_handler_callback (data=0x9248168, user_data=0x91d5200) at gvfsdaemon.c:144
 g_thread_pool_thread_proxy (data=0x91d5138) at /build/buildd/glib2.0-2.31.6/./glib/gthreadpool.c:317
 g_thread_proxy (data=0x91d5550) at /build/buildd/glib2.0-2.31.6/./glib/gthread.c:801
 start_thread (arg=0xb6bd6b70) at pthread_create.c:304

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report

This bug and most duplicates seem to happen when running rhythmbox on a smb location, it might just be that music import exercice the connection quite a lot in those case

visibility: private → public
Changed in gvfs (Ubuntu):
importance: Medium → High
Changed in gvfs (Ubuntu Precise):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Michael Terry (mterry) on 2012-04-12
Changed in gvfs (Ubuntu Precise):
assignee: Canonical Desktop Team (canonical-desktop-team) → Michael Terry (mterry)
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.12.0-0ubuntu6

---------------
gvfs (1.12.0-0ubuntu6) precise; urgency=low

  * debian/patches/dont-crash-on-null-job.patch:
    - Add one more is-null check for later in the same code path.
  * debian/patches/ref-jobs-in-thread.patch:
    - Add some refs to various user_data arguments. Specifically,
      to jobs when pushed to other threads until their job is actually
      run (LP: #912972). Also, to GVfsChannels when they are passed to
      data-write functions. Since those callbacks aren't cancelled when
      the channel dies, the channel should live long enough to complete
      them.
 -- Michael Terry <email address hidden> Thu, 12 Apr 2012 15:14:55 -0400

Changed in gvfs (Ubuntu Precise):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers