gvfsd-smb crashed with SIGSEGV in g_vfs_job_emit_finished()

Bug #838464 reported by whoop on 2011-09-01
264
This bug affects 34 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
High
Unassigned

Bug Description

It crashed during duplicate check with gthumb over a network using samba...

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gvfs-backends 1.9.3-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-9.15-generic 3.0.3
Uname: Linux 3.0.0-9-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Sep 1 02:10:01 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/lib/gvfs/gvfsd-smb
ProcCmdline: /usr/lib/gvfs/gvfsd-smb --spawner :1.1 /org/gtk/gvfs/exec_spaw/4
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7f75daec06d4 <g_vfs_job_emit_finished+4>: movzbl 0x28(%rdi),%eax
 PC (0x7f75daec06d4) ok
 source "0x28(%rdi)" (0x00000028) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 g_vfs_job_emit_finished () from /usr/lib/gvfs/libgvfsdaemon.so
 ?? () from /usr/lib/gvfs/libgvfsdaemon.so
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_simple_async_result_complete () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
Title: gvfsd-smb crashed with SIGSEGV in g_vfs_job_emit_finished()
UpgradeStatus: Upgraded to oneiric on 2011-08-31 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

whoop (whoopwhoop) wrote :

StacktraceTop:
 g_vfs_job_emit_finished (job=0x0) at gvfsjob.c:323
 send_reply_cb (source_object=0x1fef8a0, res=<optimized out>, user_data=0x21028d0) at gvfschannel.c:613
 async_ready_callback_wrapper (source_object=0x1fef8a0, res=0x1f79c00, user_data=0x21028d0) at /build/buildd/glib2.0-2.29.16/./gio/goutputstream.c:574
 g_simple_async_result_complete (simple=0x1f79c00) at /build/buildd/glib2.0-2.29.16/./gio/gsimpleasyncresult.c:749
 write_async_cb (fd=<optimized out>, condition=<optimized out>, data=<optimized out>) at /build/buildd/glib2.0-2.29.16/./gio/gunixoutputstream.c:469

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gvfs (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
visibility: private → public
Changed in gvfs (Ubuntu):
importance: Medium → High
Ugo Riboni (uriboni) wrote :

I seem to be getting the same crash when adding an smb folder to rhythmbox (bug #959228 reported separately but marked as duplicate of this bug)

Sergei Genchev (sgenchev) wrote :

 I hit this bug also when adding SMB folder to rhyrhmbox.

Andy Stevens (stevensa) wrote :

Me too. Maybe rhythmbox hits the share particularly hard? My music folder's on a NAS device via smb: and I've got it set to scan for changes.

Matthijs (tijs) wrote :

Also when trying to extract a cd via Rhythmbox to my NAS.

Also happens with Rhythmbox when I scan in a new folder via samba on one of my raid servers or my NAS . Usually Banshee handles this with no problem and auto scanning but I have it disabled for the moment.

Matthijs (tijs) wrote :

Banshee handdles the NAS via samba without problems, with Rhythmbox it goes wrong.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.12.0-0ubuntu5

---------------
gvfs (1.12.0-0ubuntu5) precise; urgency=low

  * debian/patches/metadata-dont-flush-null-tree.patch:
    - Don't try to flush a tree that doesn't exist. Fixes crash bug
      LP: #405432. Patch from upstream's Christian Kellner.
  * debian/patches/metadata-nuke-junk-data.patch:
    - If metadata file is bogus, erase it and start over. Related to
      above bug, to be able to recover from junk data in addition to
      not crashing. Patch from upstream's Christian Kellner.
  * debian/patches/dont-crash-on-null-job.patch:
    - Don't try to announce the finish of a NULL job. LP: #345754,
      LP: #838464
  * debian/patches/check-gdu-pool.patch:
    - If gdu_pool_new() returns NULL, handle it gracefully.
      LP: #832379
  * debian/patches/handle-inactive-vfs.patch:
    - If the VFS never initialized, don't crash when creating volume
      monitors. LP: #832533
 -- Michael Terry <email address hidden> Wed, 11 Apr 2012 16:01:32 -0400

Changed in gvfs (Ubuntu):
status: Confirmed → Fix Released
Ugo Riboni (uriboni) wrote :

I just upgraded my system, rebooted, tried to import music from a SMB share into rhythmbox and I still get the crash.

$ apt-cache policy gvfs
gvfs:
  Installed: 1.12.0-0ubuntu5
  Candidate: 1.12.0-0ubuntu5
  Version table:
 *** 1.12.0-0ubuntu5 0
        500 http://ubuntu.grn.cat/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

Should the bug be reopened ?

Ugo Riboni (uriboni) wrote :

Nevermind, the stack trace for the crash I still get is different. I reported the new bug as bug 979840

To post a comment you must log in.