when attaching a usb based music player to a usb port banshee does not open

Bug #826806 reported by Carla Sella on 2011-08-15
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Low
Unassigned

Bug Description

During test case: "Test Port Recognition - Case ID: hiu-002" on my HP-G62 laptop, when I attach a usb based music player to a usb port, banshee music player does not open, but nautilus opens instead.
All the files in the music player are displayed in natilus, if I click on a music file, banshee then opens.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: ALC270 Analog [ALC270 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: letozaf 1412 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xd4400000 irq 43'
   Mixer name : 'Intel IbexPeak HDMI'
   Components : 'HDA:10ec0270,103c1425,00100100 HDA:80862804,80860101,00100000'
   Controls : 20
   Simple ctrls : 11
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=bd9ecec1-a6ab-4a10-b29b-096f53cfc0dc
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110803.1)
MachineType: Hewlett-Packard HP G62 Notebook PC
Package: linux (not installed)
ProcEnviron:
 LANG=it_IT.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-7-generic root=UUID=d705c249-4a7d-45a6-93d7-06aa7ce963ed ro quiet splash vt.handoff=7
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-7-generic N/A
 linux-backports-modules-3.0.0-7-generic N/A
 linux-firmware 1.56
StagingDrivers: mei
Tags: oneiric running-unity staging
Uname: Linux 3.0.0-7-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 01/25/2010
dmi.bios.vendor: Hewlett-Packard
dmi.bios.version: F.06
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: 1425
dmi.board.vendor: Hewlett-Packard
dmi.board.version: 54.12
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnHewlett-Packard:bvrF.06:bd01/25/2010:svnHewlett-Packard:pnHPG62NotebookPC:pvr049D100000202710000020000:rvnHewlett-Packard:rn1425:rvr54.12:cvnHewlett-Packard:ct10:cvrN/A:
dmi.product.name: HP G62 Notebook PC
dmi.product.version: 049D100000202710000020000
dmi.sys.vendor: Hewlett-Packard

Carla Sella (carla-sella) wrote :
Carla Sella (carla-sella) wrote :

With lsusb the usb based music player is identified as:
Bus 002 Device 012: ID 10d6:1101 Actions Semiconductor Co., Ltd D-Wave 2GB MP4 Player / AK1025 MP3/MP4 Player

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 826806

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected oneiric running-unity staging
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Ming Lei (tom-leiming) wrote :

There is no the Actions music player in your lsusb.txt.

Please plug your music player into usb port and run 'lsusb -v', then post the result to lauchpad.

thanks,

Carla Sella (carla-sella) wrote :

Here is the result of lsusb -v (in the attached text file)

Ming Lei (tom-leiming) wrote :

Hi Carla,

I see your problem now.

You may think the banshee player will be opened automatically if the mp4 player is plugged into
usb port.

 In fact, for ubuntu linux package, the mp4 player is just a simple usb mass storage device, so
you can see files in shell or file manager. And it is not a problem inside "linux" package.

Also maybe ubuntu is not so intelligent to search and identify your music files and run music
player to play it. Even windows don't do too, but not sure, :-)

Ming Lei (tom-leiming) wrote :

Looks like it is not a bug at all

Changed in linux (Ubuntu):
status: Confirmed → Invalid
Carla Sella (carla-sella) wrote :

But I'm sure that with natty, when this music player is plugged in, a window opens asking me with what I want to open the device, and banshee media player is proposed.
This does not happen with Oneiric alpha 3, only nautilus opens immediately.

Changed in linux (Ubuntu):
status: Invalid → Confirmed
Carla Sella (carla-sella) wrote :

I have the same problem with Oneiric Beta 1, with Natty when this music player was connected a window opened asking with what to open the device, now instead nautilus opens and to start banshee you have to double click on a music file.
Testcase: http://testcases.qa.ubuntu.com/Hardware/ExpansionPorts/USB on Test Port Recognition - Case ID: hiu-002 says "Verify that the files it contains are displayed within Banshee".

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel currently in the release pocket than the one you tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-11.18
Carla Sella (carla-sella) wrote :

With all the updates done I still have the same problem.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Changed in linux (Ubuntu):
importance: Undecided → Low
Changed in linux (Ubuntu):
importance: Low → Undecided

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.19
Carla Sella (carla-sella) wrote :

I'm testing Oneirc Beta 2 with all latest updates and I am still having the same problem:
when I attach a usb based music player to a usb port, banshee music player does not open, but nautilus opens instead.
All the files in the music player are displayed in natilus, if I click on a music file, banshee then opens.
I am sure that with Natty when this music player was connected a window opened asking with what to open the device, now instead nautilus opens and to start banshee you have to double click on a music file.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed

Thank you for taking the time to file a bug report on this issue.

However, given the number of bugs that the Kernel Team receives during any development cycle it is impossible for us to review them all. Therefore, we occasionally resort to using automated bots to request further testing. This is such a request.

We have noted that there is a newer version of the development kernel than the one you last tested when this issue was found. Please test again with the newer kernel and indicate in the bug if this issue still exists or not.

If the bug still exists, change the bug status from Incomplete to Confirmed. If the bug no longer exists, change the bug status from Incomplete to Fix Released.

Thank you for your help, we really do appreciate it.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
tags: added: kernel-request-3.0.0-12.20
Carla Sella (carla-sella) wrote :

Testing Oneiric with all updates I'm still having the same problems.
http://laptop.qa.ubuntu.com/qatracker/result/7063/896

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the release candidate kernel versus the daily build. Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

tags: added: needs-upstream-testing
Mark Nighswonger (marknigh) wrote :

This did work in Maverick and Natty. For some reason the detection was dropped but the laptop testing question still expects a music player to be detected as such. If it is decided that it is no longer desirable or feasible to detect a media player specifically we can redo the test question so it will not fail. Windows does recognize media players as such, not that that has anything to do with our standards.

Carla Sella (carla-sella) wrote :

I installed the kernel downloaded from:

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2011-10-19-oneiric/linux-headers-3.1.0-999-generic_3.1.0-999.201110190711_amd64.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2011-10-19-oneiric/linux-headers-3.1.0-999_3.1.0-999.201110190711_all.deb

http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2011-10-19-oneiric/linux-image-3.1.0-999-generic_3.1.0-999.201110190711_amd64.deb

I installed it and rebooted my laptop selecting in the boot menu the new kernel.
When I inserted the based music player to a usb port nothing happened, so I re-attached the based music player to a usb port and got the output from /var/log/syslog:

Oct 19 21:40:36 HP-G62-Notebook-PC udevd[543]: timeout: killing '/sbin/modprobe -bv usb:v10D6p1101d0100dc00dsc00dp00ic08isc05ip50' [11795]
Oct 19 21:40:51 udevd[543]: last message repeated 14 times
Oct 19 21:40:51 HP-G62-Notebook-PC kernel: [ 3414.424820] usb 2-1.2: new high speed USB device number 5 using ehci_hcd
Oct 19 21:40:51 HP-G62-Notebook-PC udevd[543]: timeout: killing '/sbin/modprobe -bv usb:v10D6p1101d0100dc00dsc00dp00ic08isc05ip50' [11795]
Oct 19 21:41:22 udevd[543]: last message repeated 31 times
Oct 19 21:42:23 udevd[543]: last message repeated 61 times
Oct 19 21:43:24 udevd[543]: last message repeated 61 times

tags: removed: needs-upstream-testing
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report at bugzilla.kernel.org? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

If you are comfortable with opening a bug upstream, It would be great if you can report back the upstream bug number in this bug report. That will allow us to link this bug to the upstream report.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
tags: added: kernel-bug-exists-upstream
Carla Sella (carla-sella) wrote :

At the moment bugzilla.kernel.org is not available as there has been a recent security breach in kernel.org and the different kernel.org systems will be brought up over the next few weeks.
I suppose i have to wait, if you have an alternative please let me know.

Carla Sella (carla-sella) wrote :

I've reported the bug upstream on LKML: http://marc.info/?l=linux-kernel&m=132050133928956&w=2

I'm not sure why anyone thinks this is a kernel bug. The kernel is basically just responsible for providing setting up and providing interfaces for user software for reading and writing to the device. The fact that you can play your music in Banshee means that the kernel sets up your device just fine.

Thus, this is not a "linux (Ubuntu)" bug. It's a bug (or maybe just misconfiguration) for nautilus media handling.

Unity has screwed with all kinds of things, so it's hard to find the right way to configure this (I think they intend not to autostart anything from USB for safety reasons). I think on 11.10, you can find a "Removable Devices" configuration page under the System Settings (or type "Removable Devices" into the Dash search bar). Be sure to uncheck: "Never prompt or start programs on media insertion" and then choose Banshee under "Music player".

On older systems, you might be able to run:

nautilus-file-management-properties

Under the "Media" tab, see if the options for "Music Player" are helpful. For your case, you would want choose "Open Banshee Media Player."

BTW, just because a problem exists when running the upstream kernel doesn't mean that it's a problem with the upstream kernel.

affects: linux (Ubuntu) → ubuntu

Marking this bug Incomplete until the reporter tries the suggested configuration methods.

Changed in ubuntu:
status: Triaged → Incomplete
Carla Sella (carla-sella) wrote :

I will try what is written in #41 as soon as I get home and let you know.

Carla Sella (carla-sella) wrote :

Dear Brian,
I went to system settings, removable media and the ""Never prompt or start programs on media insertion" was already unchecked, under music player I selected "banshee" there was "ask what to do", but everything is still the same: upon inserting the usb media player nautilus opens, showing it's content as it was a usb key, i I click on a mp3 file on the usb media player then banshee opens.
I could not find nautilus-file-management-properties on my system but searching in software centre I found "Nautilus-Actions configuration tools" but when I tried to launch it nothing happens, I launched it in terminal window a get this output: "Rilevato trace/breakpoint" (Rilevato means detected, I've got Italian language installed).

Changed in ubuntu:
status: Incomplete → Confirmed

Hmm, have you tried other types of media that should be affected by the options under the "Removable Media" configuration? For instance, a digital camera? Or a different media player? Audio CDs? And what sort of icon shows up in the sidebar? Just a USB key icon? Or something else?

GNOME may not be detecting your player as a media player anymore - just as a removable drive. Or maybe the whole automount system has a bug. Narrowing this down is important for your bug report to have any chance of finding its way to the right developer, let alone being fixed. Right now, it's just a generic "Ubuntu" bug.

Carla Sella (carla-sella) wrote :

As for the icon, I'm attaching an image of the icon that shows up, to me it seems the correct one.

Carla Sella (carla-sella) wrote :

If it can help, while inserting the usb player I get this output on dmesg:

[ 711.418587] usb 2-1.2: new high speed USB device number 8 using ehci_hcd
[ 711.512623] scsi9 : usb-storage 2-1.2:1.0
[ 712.511328] scsi 9:0:0:0: Direct-Access ACTIONS HS USB FlashDisk 2.00 PQ: 0 ANSI: 0 CCS
[ 712.512761] sd 9:0:0:0: Attached scsi generic sg2 type 0
[ 712.514208] sd 9:0:0:0: [sdb] 8016817 512-byte logical blocks: (4.10 GB/3.82 GiB)
[ 712.514826] sd 9:0:0:0: [sdb] Write Protect is off
[ 712.514836] sd 9:0:0:0: [sdb] Mode Sense: 00 c0 00 00
[ 712.515721] sd 9:0:0:0: [sdb] Write cache: disabled, read cache: disabled, doesn't support DPO or FUA
[ 712.584613] sdb:
[ 712.587184] sd 9:0:0:0: [sdb] Attached SCSI removable disk

and on /var/log/syslog:

[ 711.418587] usb 2-1.2: new high speed USB device number 8 using ehci_hcd
[ 711.512623] scsi9 : usb-storage 2-1.2:1.0
[ 712.511328] scsi 9:0:0:0: Direct-Access ACTIONS HS USB FlashDisk 2.00 PQ: 0 ANSI: 0 CCS
[ 712.512761] sd 9:0:0:0: Attached scsi generic sg2 type 0
[ 712.514208] sd 9:0:0:0: [sdb] 8016817 512-byte logical blocks: (4.10 GB/3.82 GiB)
[ 712.514826] sd 9:0:0:0: [sdb] Write Protect is off
[ 712.514836] sd 9:0:0:0: [sdb] Mode Sense: 00 c0 00 00
[ 712.515721] sd 9:0:0:0: [sdb] Write cache: disabled, read cache: disabled, doesn't support DPO or FUA
[ 712.584613] sdb:
[ 712.587184] sd 9:0:0:0: [sdb] Attached SCSI removable disk

Carla Sella (carla-sella) wrote :

Under "Removable Media", configuration I tried to put banshee on Audio DVD, music player, software and Audio CD but nothing changes, the window you see in the attached image "IconDisplayed" (nautilus).
I do not have other choices related to audio or music to put banshee as a choice.

So your player is still detected properly in Oneiric, but GNOME does not launch any software at mount time. This is an issue.

I was not interested only in Removable Media choices that involve Banshee; I wanted to see if other devices follow the options you specify in Removable Media. If so, then this is a fairly general system bug (although this bug doesn't appear on my system with my devices). If not, then it's somehow tied to the properties of your device.

So can you see if anything appears (displaying software options or opening photo software automatically, for example) for other devices when they are plugged in?

Carla Sella (carla-sella) wrote :

Dear Brian,
I inserted an audio CD and banshee opened correctly, I attached my camera and shotwell opened correctly and I inserted a video DVD and Totem opened correctly.
I tried again with my usb player, but nautilus opens.
Thanks for your help.
Carla

Timokl (timokl) wrote :

When I plug in my Android phone, there is a selection what to do: a) open in Nautilus b) open in Shotwell - but anything regarding to Banshee or music is missing. When I start Banshee manually, it recognizes the phone as Music Player device.

affects: ubuntu → gnome-control-center (Ubuntu)
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu laptop testing tracker.

A list of all reports related to this bug can be found here:
http://laptop.qa.ubuntu.com/qatracker/reports/bugs/826806

tags: added: laptop-testing
Carla Sella (carla-sella) wrote :

During the test of my laptop on Precise Pangolin Beta 2 I'm having the same problem.
When I attach a music player to my laptop rythmbox does not open, nautilus opens instead.

Carla Sella (carla-sella) wrote :

Other problem: no suggestion box opens when I attach my usb music player.

Bob Merhebi (bobmerhebi) wrote :

I confirm this bug too. When I attached my usb music player nautilus *automatically* (no suggestion box) opens to display the files. Only when I open rythmbox (counter to the testcases' "banhsee") does the player appear in the devices. Another related bug is: 969746.

Sebastien Bacher (seb128) wrote :

the issue was a gvfs one and got fixed on thurday, upgrade and it should work

affects: gnome-control-center (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
importance: Undecided → Low
status: Confirmed → Fix Released
Carla Sella (carla-sella) wrote :

I am testing Precise Pangolin final release and now when I insert my usb music player a suggestion box opens and it askes me what to do, from the drop down box I can select rythmbox and everything is ok now.
The only little difference with the test case is that when the suggestion box opens instead of suggesting banshee/rythmobox, it asks me what to do, but I do not think this is realy a bug.

Carla Sella (carla-sella) wrote :

I'm attaching a screenshot of the suggestion box.

Carla Sella (carla-sella) wrote :

On Quantal alpha 2 nothing happens when you attach a USB music player, you have to open nautilus and on the left side click on the device for mounting it, after mounting it you can see all it's contents.

Carla Sella (carla-sella) wrote :

As the problem occured also with a USK key, I rebooted my laptop, and after that, when attaching the USB music player I did not get a suggestion box but only nautilus opened showing it's contents.
So I think it's a regresion.

Changed in gvfs (Ubuntu):
status: Fix Released → Confirmed
Sebastien Bacher (seb128) wrote :

don't reopen closed bugs, the issue you had was fixed, the quantal one is a new one and should get a new report

Changed in gvfs (Ubuntu):
status: Confirmed → Fix Released
Carla Sella (carla-sella) wrote :

Ok, sorry.
I will open a new report.

Carla Sella (carla-sella) wrote :

I reported the problem on bug #1020276

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers