gvfsd-cdda crashed with signal 5 in _g_dbus_oom()

Bug #819304 reported by Timo Aaltonen on 2011-08-01
288
This bug affects 78 people
Affects Status Importance Assigned to Milestone
Rhythmbox
New
Undecided
Unassigned
Sound Juicer
Unknown
Unknown
gvfs
Fix Released
Medium
gvfs (Ubuntu)
Medium
Unassigned
Precise
Low
Unassigned

Bug Description

[Impact]

sound-juicer doesn't work right when gvfs-cdda is crashing underneath

[Test case]

open sound-juicer
insert a cd with a CDTEXT entry with non-ascii text

--

I desperately need sound-juicer for cd ripping, and while it doesn't find the disc unless I open it in nautilus first, this crash happens often when I either start s-j after mounting it with nautilus or reread the disc contents from s-j.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gvfs-backends 1.9.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-7.9-generic 3.0.0
Uname: Linux 3.0.0-7-generic x86_64
Architecture: amd64
CrashCounter: 1
Date: Mon Aug 1 16:43:48 2011
ExecutablePath: /usr/lib/gvfs/gvfsd-cdda
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: /usr/lib/gvfs/gvfsd-cdda --spawner :1.1 /org/gtk/gvfs/exec_spaw/9
ProcEnviron:
 SHELL=/bin/zsh
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
Signal: 5
SourcePackage: gvfs
StacktraceTop:
 _g_dbus_oom () from /usr/lib/gvfs/libgvfscommon.so
 _g_dbus_append_file_attribute () from /usr/lib/gvfs/libgvfscommon.so
 _g_dbus_append_file_info () from /usr/lib/gvfs/libgvfscommon.so
 ?? () from /usr/lib/gvfs/libgvfsdaemon.so
 ?? () from /usr/lib/gvfs/libgvfsdaemon.so
Title: gvfsd-cdda crashed with signal 5 in _g_dbus_oom()
UpgradeStatus: Upgraded to oneiric on 2011-07-05 (27 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Timo Aaltonen (tjaalton) wrote :
visibility: private → public

StacktraceTop:
 _g_dbus_oom () at gvfsdbusutils.c:35
 _g_dbus_append_file_attribute (iter=0x7f50b14d3870, attribute=0x16146e0 "xattr::org.gnome.audio.title", status=<value optimized out>, type=<value optimized out>, value_p=0x1614690) at gvfsdaemonprotocol.c:266
 _g_dbus_append_file_info (iter=0x7f50b14d3900, info=0x15f3af0) at gvfsdaemonprotocol.c:303
 create_reply (job=<value optimized out>, connection=<value optimized out>, message=<value optimized out>) at gvfsjobqueryinfo.c:198
 send_reply (job=0x160aa80) at gvfsjobdbus.c:166

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Changed in gvfs (Ubuntu):
status: New → Confirmed
GNAServicesInc (gnaservicesinc) wrote :

Same problem for me.

hcmeyer (hcmeyer) wrote :

I have this bug occurring, but it is caused by a particular CD, Ry Cooder's "Pull Up Some Dust". The CD has a CDTEXT entry, and it confuses things.

This seems related to bug #902573 , but I'm not sure if we should dupe them.

Sasa Paporovic (melchiaros) wrote :

It is also in precise updated to 26.1.2012:

I have inserted a audio cd in DVD drive. The unity "what to do" dialog pops up and I select to open it with Rhythembox.
Just after rythembox comes up, the crash happends.

It is easy reproducible on just starting Rhythembox with insertet audio cd in drive.

Ville Ranki (ville-ranki) wrote :

This bug breaks sound-juicer - see https://bugzilla.gnome.org/show_bug.cgi?id=663459 . I'd raise the priority on this one as sound-juicer is Gnome's default audio ripper and the only one i've found that supports MusicBrainz submitting.

Ross Burton (ross) wrote :

Can someone press the magic button to push this to gnome please?

Changed in gvfs:
importance: Unknown → Medium
status: Unknown → New
tags: added: precise
Timo Aaltonen (tjaalton) wrote :

while testing ripping with the old and new sound-juicer (3.3.90) I can't reproduce this anymore.. can someone else?

Changed in gvfs (Ubuntu):
status: Confirmed → Incomplete
mathieg2 (graeme-salsaholics) wrote :

Still happening for me - on precise. Just done an update - problem still here. Not able to rip two of my cds at all due to this issue.

Changed in gvfs (Ubuntu):
status: Incomplete → Triaged
Sasa Paporovic (melchiaros) wrote :

I hit this in a different way on Ubuntu 12.04 64bit updated to 7.4.2012

After inserting a audio cd and starting rhythembox the crash happends also from there.

---------------------------------------------------------------------------------------------------------------------------

In respect that rhythembox is the substituent for banshee and one of the default progams for Ubuntu, this bug should be nominated for ubuntu12.04 serie.

I have this crash when trying to open an Audio CD in Rhythmbox in Ubuntu 12.04 amd64

Sasa Paporovic (melchiaros) wrote :

Still happends with the latest updates 12.4.2012

Hendrik Knackstedt (hennekn) wrote :

Please raise importance to "critical"! This bug prevents several programs from reading Audio-CDs. What's the status on this? Upstream seems to consider this an issue with Ubuntu patches.

Hendrik Knackstedt (hennekn) wrote :
tags: added: i386
Sebastien Bacher (seb128) wrote :

seems like a gvfs upstream issue, we don't patch gvfs-cdda in Ubuntu

Hendrik Knackstedt (hennekn) wrote :

Workaround for this: Use Banshee (instead of Rhythmbox) or RipOff (instead of Sound Juicer). They both work since they are using different software to read Audio-CDs.

Rabe (ralf-bell) wrote :

Another Workaround: Switch off network connection before starting sound juicer.

Hendrik Knackstedt (hennekn) wrote :

The workaround from comment #20 doesn't work for me.

Sasa Paporovic (melchiaros) wrote :

It is also on Ubuntu12.10 64bit Quantal

tags: added: quantal
Changed in gvfs:
status: New → Fix Released
Sebastien Bacher (seb128) wrote :
Changed in gvfs (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Low
Changed in gvfs (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.13.6-0ubuntu1

---------------
gvfs (1.13.6-0ubuntu1) quantal; urgency=low

  * New upstream version:
    - cdda: Fix abort with non-ASCII text (lp: #819304)
  * debian/patches/build_old_libgphoto.patch:
    - revert upstream patch for libgphoto 2.5 support it breaks build
 -- Sebastien Bacher <email address hidden> Wed, 08 Aug 2012 15:56:06 +0200

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
Ville Ranki (ville-ranki) wrote :

Any plans to backport the fix to Precise? Still a couple of months until Quantal release.

Timo Aaltonen (tjaalton) wrote :

the fix is queued for precise-proposed

Changed in gvfs (Ubuntu Precise):
status: Triaged → In Progress
Timo Aaltonen (tjaalton) on 2012-09-07
description: updated

Hello Timo, or anyone else affected,

Accepted gvfs into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gvfs/1.12.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gvfs (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Ville Ranki (ville-ranki) wrote :

I just managed to rip a CD using sound juicer, which hasn't been possible on Ubuntu for at least a year. So far looks good for the proposed fix. I'll test with different CD's later if needed. Thanks!

Timo Aaltonen (tjaalton) wrote :

confirming that ripping many Finnish cd's works without issues now

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.12.1-0ubuntu1.1

---------------
gvfs (1.12.1-0ubuntu1.1) precise-proposed; urgency=low

  * fix-abort-with-cdtext-outside-ascii.patch:
    CD-Text doesn't specify encoding, but in practice some discs have
    strings with extended characters. Using those directly will make D-Bus
    choke with invalid data. Fixed by assuming latin-1.
    (LP: #819304)
  * use-g-clear-objec-properly.patch:
    fix FTBFS, backported from 1.12.3.
 -- Timo Aaltonen <email address hidden> Thu, 06 Sep 2012 14:43:52 +0300

Changed in gvfs (Ubuntu Precise):
status: Fix Committed → Fix Released

I'm using gvs Version: 1.12.1-0ubuntu1.1 and the bug persists

tellapu (tellapu) wrote :

Same for me. I have 1.12.1-0ubuntu1.1 and the bug persists, but rhythmbox 2.98 crashes when having an Audio CD in the drive and opening Rhythmbox in Ubuntu 12.04 amd64.

Derick Turner (turf) wrote :

I have been getting this error with gvfs version 1.12.1 on 12.04 and also on gvfs 1.14.0 on 12.10.

Andrew Turner (aaturner) wrote :

Get this error in file manager (Nautilis) too if audio cd in tray. Music players can still access the cd through their own file browser. Pretty annoying bug though as it generates errors on every start up and access attempt.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.