gvfsd-dav crashed with SIGSEGV in g_vfs_backend_get_daemon()

Bug #811761 reported by Br. Francis Therese Krautter on 2011-07-17
408
This bug affects 78 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Critical
gvfs (Ubuntu)
High
Michael Terry
Oneiric
High
Michael Terry

Bug Description

crashed while attempting to use webdav

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gvfs-backends 1.9.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-5.6-generic 3.0.0-rc7
Uname: Linux 3.0.0-5-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Sat Jul 16 23:07:20 2011
ExecutablePath: /usr/lib/gvfs/gvfsd-dav
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: /usr/lib/gvfs/gvfsd-dav --spawner :1.1 /org/gtk/gvfs/exec_spaw/14
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7ff5762dfae4 <g_vfs_backend_get_daemon+4>: mov (%rax),%rax
 PC (0x7ff5762dfae4) ok
 source "(%rax)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 g_vfs_backend_get_daemon () from /usr/lib/gvfs/libgvfsdaemon.so
 ?? () from /usr/lib/gvfs/libgvfsdaemon.so
 ?? () from /usr/lib/gvfs/libgvfscommon.so
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 dbus_connection_dispatch () from /lib/x86_64-linux-gnu/libdbus-1.so.3
Title: gvfsd-dav crashed with SIGSEGV in g_vfs_backend_get_daemon()
UpgradeStatus: Upgraded to oneiric on 2011-07-14 (3 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

StacktraceTop:
 g_vfs_backend_get_daemon (backend=0x96f040) at gvfsbackend.c:281
 unregister_mount_callback (unmount_reply=<value optimized out>, error=<value optimized out>, user_data=<value optimized out>) at gvfsjobunmount.c:244
 handle_async_reply (pending=<value optimized out>, data=<value optimized out>) at gvfsdbusutils.c:1216
 complete_pending_call_and_unlock (connection=0x964c90, pending=0x9f2070, message=<value optimized out>) at ../../dbus/dbus-connection.c:2301
 dbus_connection_dispatch (connection=0x964c90) at ../../dbus/dbus-connection.c:4550

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
https://bugzilla.gnome.org/show_bug.cgi?id=654999

Changed in gvfs (Ubuntu):
status: New → Triaged
visibility: private → public
Changed in gvfs:
importance: Unknown → Critical
status: Unknown → New
Lacyc3 (lacyc3) wrote :

Same with SFTP.

Hans Kruse (kruse-nicenemo) wrote :

I get this when using deja-dup with sftp.livedrive.com.
Using sftp from Nautilus works.
sftp to a local server works. Also dejadup to a local server works.

Possible causes, wild guess:
Crashes with sftp when there is an @ encoded as %40 in the username
when passive is required, not sure. sftp to my local server works
my host is behind a NAT. When using my local server it is on on the same network so no NAT required.

For me SFTP is working quite well; I've had a crash when unmounting the remote server.

Happens for me after unmounting SMB folders from from a Samba server on our local network.

Drewe Zanki (piston9) wrote :

Same as users above - crash occurs when unmounting a mounted SMB share.

dz0ny (janez-troha) wrote :

Same as users above - in addition only permits one connection to server (SFTP). When connected with one user(www), second(git) fails. This worked in fresh beta1(11.10) install but now after upgrading does't anymore.

Changed in gvfs (Ubuntu):
assignee: nobody → Bratmaxe (jochen-belecki)
Guy Taylor (thebiggerguy) wrote :

This also happened with gphoto-fs (oneiric)

Sam_ (and-sam) wrote :

Actually getting different errors when unmounting different webdav in Nautilus.
Different outcome but same procedures here.
The other error is Bug #811049 where my dupe again either says:
gvfsd-cdda crashed with SIGSEGV in g_vfs_job_try()
or leading me here.

Confirmed crash with gphoto-fs on Oneiric up to date.
Increasing importance to High due to the number of duplicates and affected people.

Changed in gvfs (Ubuntu Oneiric):
assignee: Bratmaxe (jochen-belecki) → Canonical Desktop Team (canonical-desktop-team)
importance: Medium → High
Matthias Schmidt (mschmidt) wrote :

Can confirm this on Oneiric from today running amd64. Happens here with SFTP. Connect and up/download works, but the crash appears every time after I log out and is quite annoying.

Martin Pitt (pitti) on 2011-09-19
Changed in gvfs (Ubuntu Oneiric):
assignee: Canonical Desktop Team (canonical-desktop-team) → Michael Terry (mterry)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.9.5-0ubuntu2

---------------
gvfs (1.9.5-0ubuntu2) oneiric; urgency=low

  * debian/patches/06_no_crash_on_unmount.patch:
    - Don't crash when unmounting a volume (LP: #811761)
 -- Michael Terry <email address hidden> Mon, 19 Sep 2011 12:18:02 -0400

Changed in gvfs (Ubuntu Oneiric):
status: Triaged → Fix Released
Sam_ (and-sam) wrote :

Unmounting a webdav closes Nautilus window, tested with two different webdavs. Assume this isn't expected behaviour.
No crash report or any notes in syslog or .xsession-errors.
gvfs:
  Installed: 1.9.5-0ubuntu2
  Candidate: 1.9.5-0ubuntu2
  Version table:
 *** 1.9.5-0ubuntu2 0

uname -r
3.0.0-11-generic

Changed in gvfs:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.