Ubuntu

gvfsd-ftp crashed with SIGSEGV in g_vfs_job_try()

Reported by Ivan Akulov on 2011-07-15
682
This bug affects 135 people
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
High
gvfs (Ubuntu)
Medium
Unassigned
Oneiric
Medium
Unassigned

Bug Description

no extra information

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: gvfs-backends 1.9.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic i686
Architecture: i386
Date: Fri Jul 15 16:39:13 2011
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/lib/gvfs/gvfsd-ftp
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705)
ProcCmdline: /usr/lib/gvfs/gvfsd-ftp --spawner :1.1 /org/gtk/gvfs/exec_spaw/3
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=ru_UA:ru
 LANG=ru_UA.UTF-8
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 ?? ()
 ?? () from /usr/lib/gvfs/libgvfsdaemon.so
 g_vfs_job_try () from /usr/lib/gvfs/libgvfsdaemon.so
 g_vfs_daemon_queue_job () from /usr/lib/gvfs/libgvfsdaemon.so
 ?? () from /usr/lib/gvfs/libgvfsdaemon.so
Title: gvfsd-ftp crashed with SIGSEGV in g_vfs_job_try()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Ivan Akulov (gxoptg) wrote :
visibility: private → public

StacktraceTop:
 ?? ()
 try (job=0x89e5450) at gvfsjobunmount.c:222
 g_vfs_job_try (job=0x89e5450) at gvfsjob.c:216
 g_vfs_daemon_queue_job (daemon=0x89e2200, job=0x89e5450) at gvfsdaemon.c:462
 job_source_new_job_callback (job_source=0x89e4838, job=0x89e5450, daemon=0x89e2200) at gvfsdaemon.c:322

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
https://bugzilla.gnome.org/show_bug.cgi?id=655147

Changed in gvfs (Ubuntu):
status: New → Triaged
Changed in gvfs:
importance: Unknown → Critical
status: Unknown → New
Changed in gvfs:
status: New → Incomplete
Sam_ (and-sam) wrote :

Unable to view incomplete status, unless bugzilla updates the certificate.
According to Firefox:
bugzilla.gnome.org verwendet ein ungültiges Sicherheitszertifikat.
Das Zertifikat ist am 29.08.2011 04:34 abgelaufen. Die aktuelle Zeit ist 29.08.2011 22:57.
(Fehlercode: sec_error_expired_certificate)

Ydjluv-u (ydjluv-u) wrote :

This seemed to happen when I unmounted an ISO from a VFS..

Christopher Scoggin (cscoggin) wrote :

I have gotten this twice now ejecting a CD from within Banshee

Alessandro Losavio (alo21) wrote :

I have the same problem.

System update at: 6 September 2011-->20:36

Vadim Peretokin (vperetokin) wrote :

Crashed when it was stuck connecting to an FTP share.

Mark Murphy (mokmeister) wrote :

Happened to me as well when I ejected a CD from Banshee. Fully updated as of 19/09/11.

wompy (wompy-dompy) wrote :

I have the same problem while starting banshee with an ipod pluged in.
This is the console dump:

AppleDeviceSource is ignoring unmounted volume Dokumente auf wompy iPod2
Device 0 (VID=05ac and PID=1293) is a Apple iPod Touch 2nd Gen.
LIBMTP WARNING: no MTP vendor extension on device 14 on bus 2LIBMTP WARNING: VendorExtensionID: 00000000LIBMTP WARNING: VendorExtensionDesc: Device has no vendor extensionsLIBMTP WARNING: this typically means the device is PTP (i.e. a camera) but not an MTP device at all. Trying to continue anyway.LIBMTP PANIC: could not inspect object property descriptions!
LIBMTP PANIC: could not inspect object property descriptions!
LIBMTP PANIC: could not inspect object property descriptions!
Stacktrace:

Native stacktrace:

 banshee() [0x4911ea]
 banshee() [0x4e064f]
 banshee() [0x41b187]
 /lib/x86_64-linux-gnu/libpthread.so.0(+0x10040) [0x7f6f801d2040]
 /lib/x86_64-linux-gnu/libc.so.6(+0x128bef) [0x7f6f7ff4bbef]
 banshee(mono_string_new+0x1c) [0x56178c]
 [0x40fc518a]

Debug info from gdb:

Could not attach to process. If your uid matches the uid of the target
process, check the setting of /proc/sys/kernel/yama/ptrace_scope, or try
again as the root user. For more details, see /etc/sysctl.d/10-ptrace.conf
ptrace: Die Operation ist nicht erlaubt.
No threads.

=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================

Abgebrochen (Speicherabzug geschrieben)

Ron Campbell (1-ron-f) wrote :

I had just plugged in my iPhone, chose the option to eject, then, I chose the next option to open to view files.
The iPhone was in a 'locked' status.

bperkey (bsperkey) wrote :

Crashed when I tried to access an FTP share. FTP works fine otherwise.

Marc Graafman (mgraafmans) wrote :

Unmounting iPhone and iPad from Nautilus

description: updated
Le Gluon Du Net (legluondunet) wrote :

on my computer I obtain the same crash when I unmount a ftp folder in nautilus. I reproduce this bug on natty and oneiric.
Thanks for your help.

LGDN.

Johanneke (trippo10) wrote :

I mounted an ISO file in nautilus via ; Right click, Open with, Archive Mounter ... After unmounting in nautilus by clicking on the little Grey Unmount Icon, the error came up.

EricDHH (ericdhh) wrote :

Have a ftp link from dejadup and nautilus to my dns-323 box. With oneiric i cannot backup cause by this error and cannot umount this share from my computer.

Sam_ (and-sam) wrote :

Still reports crash unmounting Audio-CD in Nautilus via right click.
Sep 24 22:19:55 kernel: [ 4869.594146] gvfsd-cdda[6113]: segfault at 0 ip (null) sp 00007fffa4bdb088 error 14 in gvfsd-cdda[400000+6000]

gvfs:
  Installed: 1.9.5-0ubuntu2
  Candidate: 1.9.5-0ubuntu2
  Version table:
 *** 1.9.5-0ubuntu2 0

uname -r
3.0.0-11-generic

miked (miked11) wrote :

win7 wubi amd64 11.04 install upgraded to o.o. 11.10 beta 1/2 now

sev (sev-mail) wrote :

I disconnected iPhone3GS, and _after_ that clicked on iphone mounting point icons in unity and selected 'unmount'. It crashed.

Also receiving this error.

When using FTP to a NAS. First file transfer (up or down) works fine. However after starting the a second transfer after the first has completed the stream seems to stall partly through transfer and after cancelling receive this error. It appears that the stream is closing and ftp doesn't recognize it.

v2marco (marco-yuen) wrote :

I just search in Nautilus, it crash

Justin (justin-wzy) wrote :

crashed in 11.10 x64

André Barmasse (barmassus) wrote :

Trying to unmount an iphone with a right-click on its unity panel icon crashes gvfs. The icon remains. Clicking again on the iphone icon opens the iphone. Trying to unmount it again with a right-click on its panel icon does nothing: the icon is still there, no information in the status bar, nada! Has it been successfully unmounted? Can I unplug it? Nobody knows ...

Changed in gvfs:
status: Incomplete → New
Sam_ (and-sam) wrote :

No crash anymore here when unmounting an audio-cd or webdav.
gvfs-backends:
  Installed: 1.10.0-0ubuntu1
  Candidate: 1.10.0-0ubuntu1
  Version table:
 *** 1.10.0-0ubuntu1 0

Sam_ (and-sam) wrote :

Didn't have the crash since the fix of bug #811761

RobinJ (robinj) wrote :

Happened to me when clicking the eject uicon next to an FTP connection in Nautilus.
Ubuntu 11.10 all updates installed.

Gabor Toth (gabor-me) wrote :

i played an audio CD with Banshee and when complete then I've ejected it with the function within Banshee.
Ubuntu 11.10.

Evan Huus (eapache) wrote :

Just experienced this on the latest Precise when unplugging (not unmounting or ejecting) an iPod with iOS 5.

Ben A (8-roothorick-gmail-com) wrote :

Got this crash on Precise too. Was working with an FTP server, computer shut down due to low battery while it was still connected. On next boot, crash dialog came up. I was able to reconnect to the server fine.

Dmitry Shachnev (mitya57) wrote :

This seems to happen when ejecting any gvfs/fuse filesystem, like a ftp or mounted archive.

Gerry Boland (gerboland) wrote :

Reproduced in Precise today (just did an update). Was listening to music off iPod via Rhythmbox. Had just stopped playback, and selected 'Eject' in Rhythmbox to eject my iPod. Crash ensued.

jim galley (jim-galley) wrote :

also in unity bar rightclicked & selected "unmount" and it crashed.

Is there anyway to disable the icon from appearing in unity? Nice to have, but I don't want to have 2 icons taking up space on the launch bar that I never use.

Dmitry Shachnev (mitya57) wrote :

This was fixed upstream (commit e523572e14)

Changed in gvfs:
importance: Critical → Unknown
status: New → Unknown
Changed in gvfs (Ubuntu):
status: Triaged → Fix Committed
Changed in gvfs:
importance: Unknown → High
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.11.3-0ubuntu1

---------------
gvfs (1.11.3-0ubuntu1) precise; urgency=low

  * New upstream release:
    - Fix backends segfaulting on unmount (LP: #811049)
  * debian/watch: Watch for development versions.
 -- Martin Pitt <email address hidden> Wed, 08 Feb 2012 08:04:18 +0100

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.