Volumes on cards inserted in the Realtek card reader (PCI 10ec:5208) not automounted.

Bug #759963 reported by Ayan George on 2011-04-13
76
This bug affects 11 people
Affects Status Importance Assigned to Milestone
GNOME Disks
Fix Released
Medium
gvfs
Fix Released
Medium
udisks
Fix Released
High
gnome-disk-utility (Ubuntu)
Medium
Ayan George
Natty
Medium
Ayan George
gvfs (Ubuntu)
Medium
Unassigned
Natty
Medium
Ayan George
udisks (Ubuntu)
Undecided
Unassigned
Natty
Undecided
Martin Pitt

Bug Description

SRU Justificaiton
-----------------

Impact:

This bug prevents Realtek PCI SD card readers from being auto-mounted.

Fix:

gvfs has been updated to recognize properties named ID_DRIVE_FLASH* and if set to "1", will set the should_automount property to true.

In addition, we need the following udisks rule added to 80-udisks.rules:

DRIVERS=="rts_pstor", ENV{ID_DRIVE_FLASH_SD}="1"

Patch:

Changes have been applied to gvfs and gnome-disk-utility to utilize the ID_DRIVE_FLASH* properties for auto-mounting purposes.

The required udisks rule has been applied to the git master branch:

  http://cgit.freedesktop.org/udisks/commit/?id=cd0644df1279a9a04c5ff15220381a64de0224fa

Regression Potential:

There should be very little potential for regression.

TEST CASE:

* Insert a memory card in a machine with a Realtel PCI memory card reader.
  - An icon should appear on the unity launcher.
  - The volume should be auto-mounted.
  - A nautilus window should open.

------------------------

Binary package hint: udisks

Volumes on cards inserted into the Realtek card reader (PCI 10ec:5208) are not automounted by nautilus.

I'd like to see the results of ubuntu-bugs output after selecting "External or internal storage devices" -> "Removable storage device is not mounted automatically"

Ayan George (ayan) on 2011-04-13
summary: - Cards inserted in the Realtek card reader (PCI 10ec:5208) not
+ Volumes on cards inserted in the Realtek card reader (PCI 10ec:5208) not
automounted.
Keng-Yu Lin (lexical) on 2011-04-14
Changed in udisks (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in udisks:
importance: Unknown → High
status: Unknown → Confirmed
Keng-Yu Lin (lexical) wrote :

upstream fd.o has discussion about the auto-mount support of scsi devices. I added the udisks/fd.o bug number.

Keng-Yu Lin (lexical) wrote :
Chris Van Hoof (vanhoof) on 2011-04-14
Changed in udisks (Ubuntu):
assignee: nobody → Ayan George (ayan)
Ayan George (ayan) wrote :

Keng-Yu, try adding the following line to your udisks rules. I think "/lib/udev/rules.d/80-udisks.rules" would be the apropriate place.

SUBSYSTEMS=="pci", ATTRS{vendor}=="0x10ec", ATTRS{device}=="0x0461", ENV{ID_DRIVE_FLASH_MS}="1"

Keng-Yu Lin (lexical) wrote :

With the udev rule above, the SD card volume is now automounted. Attached the `udisks -moitor` result.

Keng-Yu Lin (lexical) wrote :
Jeremy Kerr (jk-ozlabs) wrote :

Ayan: should the ATTRS{device} not be 5208 there? or am I missing some other device that's affecting the automount?

Also, since this driver supports multiple flash card types, ENV{ID_DRIVE_FLASH_MS} might be better as ENV{ID_DRIVE_FLASH}. Keng-Yü: could you test that this works?

Ayan George (ayan) wrote :

Jeremy: Yes -- my mistake. I misread the lspci output in the apport log. I also agree that ID_DRIVE_FLASH is probably more appropriate.

Ayan George (ayan) wrote :

Okay -- I might have been wrong from the start. Kengyu, were you running gnome as root? If so, could you try testing as a non-privileged users?

Keng-Yu Lin (lexical) wrote :

my testing udev rule. automount does not work with it.

Keng-Yu Lin (lexical) wrote :

I think I mis-understood the automount behavior in comment #4. I tested with an SD card with FAT partition. The partition shows in Gnome "Places" menu, but in the terminal, `mount` does not shows it mounted in /media.

So I suppose this does not mean that "automount is working".

Keng-Yu Lin (lexical) wrote :

ubuntu@ubuntu-Latitude-2110:~$ udevadm monitor
monitor will print the received events for:
UDEV - the event which udev sends out after rule processing
KERNEL - the kernel uevent

KERNEL[1303783846.917600] change /devices/pci0000:00/0000:00:1c.2/0000:0d:00.0/host4/target4:0:0/4:0:0:0/block/sdb (block)
KERNEL[1303783846.921212] change /devices/pci0000:00/0000:00:1c.2/0000:0d:00.0/host4/target4:0:0/4:0:0:0/block/sdb (block)
KERNEL[1303783846.921357] add /devices/pci0000:00/0000:00:1c.2/0000:0d:00.0/host4/target4:0:0/4:0:0:0/block/sdb/sdb1 (block)
UDEV [1303783846.981849] change /devices/pci0000:00/0000:00:1c.2/0000:0d:00.0/host4/target4:0:0/4:0:0:0/block/sdb (block)
UDEV [1303783847.060260] change /devices/pci0000:00/0000:00:1c.2/0000:0d:00.0/host4/target4:0:0/4:0:0:0/block/sdb (block)
UDEV [1303783847.138262] add /devices/pci0000:00/0000:00:1c.2/0000:0d:00.0/host4/target4:0:0/4:0:0:0/block/sdb/sdb1 (block)

Keng-Yu Lin (lexical) wrote :

This is log of `udevadm test /devices/pci0000:00/0000:00:1c.2/0000:0d:00.0/host4/target4:0:0/4:0:0:0/block/sdb/sdb1`

From the log the udev rule we added is taking effect since "ID_DRIVE_FLASH=1" from the log.

Ayan George (ayan) wrote :

Okay -- after reviewing the code, I'm not sure how we could get internal PCI flash drive readers to automount without changes to gvfs and adding a udev rule. I've gotten nautilus to automount with the attached patch and the following udev rule:

SUBSYSTEMS=="pci", ATTRS{vendor}=="0x10ec", ATTRS{device}=="0x5208", ENV{ID_DRIVE_FLASH}="1"

Ayan George (ayan) wrote :

The following gvfs patch adds a check for a flash device when setting the gvfs 'should_automount' attribute.

tags: added: patch
Ayan George (ayan) wrote :
Martin Pitt (pitti) on 2011-05-03
affects: udisks (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
status: Confirmed → In Progress
Martin Pitt (pitti) wrote :
Changed in udisks (Ubuntu):
status: New → Fix Committed
Martin Pitt (pitti) wrote :
Changed in gvfs (Ubuntu):
status: In Progress → Fix Committed
Changed in gvfs:
importance: Unknown → Medium
status: Unknown → Fix Released
Martin Pitt (pitti) wrote :

I backported the patch to natty's gvfs, and uploaded to the natty-proposed queue, as per request from Ayan/OEM. Ayan, once Clint or another ubuntu-sru member reviews this, can you please test the proposed package, so that it can go into -updates?

Thanks!

Changed in udisks (Ubuntu Natty):
status: New → Triaged
Changed in gvfs (Ubuntu Natty):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Martin Pitt (pitti)
tags: added: hw-specific
Changed in gvfs (Ubuntu Natty):
assignee: Martin Pitt (pitti) → nobody
status: In Progress → Fix Committed
Martin Pitt (pitti) wrote :

Rejecting upload as per Ayan's request, he said he has a more generic solution for this.

Changed in gvfs (Ubuntu Natty):
status: Fix Committed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks - 1.0.3-1

---------------
udisks (1.0.3-1) unstable; urgency=low

  * New upstream release.
    - Recognize Realtek PCI card reader. (LP: #759963)
    - Stop polling CD drives with udev >= 172 (soon to be released), which
      will enable in-kernel polling. With older udevs, this bug is "wontfix".
      (Closes: #576954)
  * Drop 00git-sd-card-id.patch, 00git-udf-permissions.patch,
    11-remove-unused-probers.patch: Applied upstream.
  * Drop 10-ide-cd-support.patch. ide-cd is dead; squeeze already uses libata.
  * debian/copyright: Add missing "Format:" header.
  * debian/control: Drop libpolkit-backend-1-dev build dependency, not
    required by this upstream version any more.
  * debian/udisks.install: Drop polkit extension, not built by this version
    any more.
  * debian/control: Recommend "eject". (Closes: #626592)
  * debian/control: Bump Standards-Version to 3.9.2 (no changes necessary).
 -- Martin Pitt <email address hidden> Wed, 29 Jun 2011 16:56:49 +0100

Changed in udisks (Ubuntu):
status: Fix Committed → Fix Released
Ayan George (ayan) on 2011-06-30
Changed in gvfs (Ubuntu Natty):
assignee: nobody → Ayan George (ayan)
Changed in gnome-disk-utility:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-disk-utility:
status: New → Fix Released
Ayan George (ayan) wrote :

Testing the new gvfs, gdu, and udisks this morning to verify that the fix survived on its way downstream.

Chris Van Hoof (vanhoof) on 2011-07-18
Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → Medium
Changed in gnome-disk-utility (Ubuntu Natty):
importance: Undecided → Medium
Changed in gnome-disk-utility (Ubuntu):
assignee: nobody → Ayan George (ayan)
Changed in gnome-disk-utility (Ubuntu Natty):
assignee: nobody → Ayan George (ayan)
Ayan George (ayan) on 2011-07-18
Changed in gnome-disk-utility (Ubuntu):
milestone: none → natty-updates
Changed in gnome-disk-utility (Ubuntu Natty):
status: New → Fix Committed
Ayan George (ayan) on 2011-07-28
Changed in gnome-disk-utility (Ubuntu Natty):
milestone: none → natty-updates
Changed in gvfs (Ubuntu):
milestone: none → natty-updates
Changed in udisks (Ubuntu):
milestone: none → natty-updates
Ayan George (ayan) on 2011-07-28
description: updated
Ayan George (ayan) on 2011-08-01
description: updated
Martin Pitt (pitti) wrote :

I backported the udisks patch and uploaded to natty-proposed. Needs ubuntu-sru review now.

Changed in udisks (Ubuntu Natty):
assignee: nobody → Martin Pitt (pitti)
status: Triaged → Fix Released
status: Fix Released → Fix Committed

Hello Ayan, or anyone else affected,

Accepted udisks into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Changed in gnome-disk-utility (Ubuntu):
status: New → Confirmed
Ayan George (ayan) wrote :

Attached is a debdiff for the gvfs package.

Martin Pitt (pitti) wrote :

Sponsored gvfs into natty-proposed, thanks!

Changed in gvfs (Ubuntu Natty):
status: Triaged → Fix Committed
Martin Pitt (pitti) wrote :

Unsubscribing sponsors, as there are no other patches to sponsor right now.

Ayan George (ayan) wrote :

And finally, I need a rule added to udisks 1.0.2 for natty. This rule comes from the latest git head. I've attached a debdiff.

Martin Pitt (pitti) wrote :

Ayan, the udisks part is already in natty-proposed, awaiting testing feedback.

Martin Pitt (pitti) wrote :

Do we also need a gnome-disk-utility fix here? It's not even marked as fixed in oneiric.

quadra (info06) wrote :

Hi there, thank you for working on this bug. A fix for Ubuntu 10.04 (Lucid) would be appreciated, too.
I use Ubuntu 10.04 on a Dell Latitude 2110.
I have added the line suggested in post #13 to /lib/udev/rules.d/80-udisks.rules, but I don't see the SD card in nautilus nor in disk utility.

Chris Halse Rogers (raof) wrote :

Is the gvfs component of this bug fixed in Oneiric? It seems like it should be, but there's been enough activity on this bug that it's not clear to me whether it has been fixed or not.

Once that's been cleared up I'm happy for gvfs to go into -proposed.

Martin Pitt (pitti) wrote :

Yes, the patch is in oneiric's 1.9.3 (it was backported from upstream).

Changed in gvfs (Ubuntu):
assignee: Ayan George (ayan) → nobody
milestone: natty-updates → none
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Ayan, do we actually need to change anything in g-d-u? I don't think so, but please confirm.

Changed in gnome-disk-utility (Ubuntu Natty):
status: Fix Committed → Incomplete
Changed in gnome-disk-utility (Ubuntu):
status: Confirmed → Incomplete
milestone: natty-updates → none
Ayan George (ayan) wrote :

Martin,

No, we don't need g-d-u but we do need gvfs in Natty.

Martin Pitt (pitti) on 2011-08-24
Changed in gnome-disk-utility (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-disk-utility (Ubuntu Natty):
status: Incomplete → Invalid
milestone: natty-updates → none
Martin Pitt (pitti) wrote :

Hello Ayan, or anyone else affected,

Accepted gvfs into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Daniel Manrique (roadmr) wrote :

Hi Martin,

I tested this on two affected Dell Latitude 2110 systems with the Realtek card reader.

Prior to applying any updates, I'd insert an SD card which would be detected as sdb (visible on dmesg) but didn't automount. I'd have to manually go into Nautilus to mount the recognized filesystem.

After applying updates today (I did a dist-upgrade which updated gvfs among other things) I rebooted and tested, and now when inserting an SD card it gets detected and auto-mounted, an icon even appears in Unity and the device's Nautilus window opens automatically.

gvfs was updated to version 1.8.0-0ubuntu3.

Let me know if I can help by testing anything else.

Martin Pitt (pitti) wrote :

Thanks for testing!

tags: added: verification-done
removed: verification-needed
Ayan George (ayan) wrote :

Verified fixed in -proposed.

Ayan George (ayan) on 2011-08-31
tags: added: blocks-hwcert-enablement
tags: added: blocks-hwcert
removed: blocks-hwcert-enablement
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package udisks - 1.0.2-4ubuntu2

---------------
udisks (1.0.2-4ubuntu2) natty-proposed; urgency=low

  * Add 00git-rts_pstor-flash.patch: Mark all rts_pstor devices as card
    readers, to get proper automounting. Backported from 1.0.3.
    (LP: #759963)
 -- Martin Pitt <email address hidden> Tue, 09 Aug 2011 09:47:28 +0200

Changed in udisks (Ubuntu Natty):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.8.0-0ubuntu3

---------------
gvfs (1.8.0-0ubuntu3) natty-proposed; urgency=low

  * 10_flash_drive_autmount.patch: SRU of patch that allows gvfs to
    recognize ID_FLASH udisks attributes (lp: #759963)
 -- Ayan George <email address hidden> Tue, 16 Aug 2011 16:07:47 -0400

Changed in gvfs (Ubuntu Natty):
status: Fix Committed → Fix Released
tags: added: blocks-hwcert-enablement
Ayan George (ayan) wrote :

Marked as resolved in the upstream bug freedesktop-bugs #30381.

Changed in udisks:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.