Ubuntu

Repeated mount/unmount of network shares with nautilus fails

Reported by mikbini on 2010-04-02
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gvfs
New
Medium
gvfs (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gvfs

If you repeatedly mount, unmount, mount etc. network shares (I verified this with smb and webdav) from nautilus, sometimes you get:

"Error: DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)"

In order to trigger the error you should be quick: bookmarking the shares (saving their passwords) and then using the side pane helps a lot.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gvfs 1.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
Uname: Linux 2.6.32-19-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Fri Apr 2 19:05:08 2010
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gvfs

mikbini (mikbini) wrote :
axoin (axoin) wrote :

yes, same here. Also with gvfsd-sftp

mikeyphi (mikeyphi) wrote :

Recent updates fixed the 100%cpu issue however, network access is still broken -as above- unless one enters password etc and 'forget immediately'. So, if password is set to be remembered - there is no access to the share but if password is set to be forgotten immediately then access is OK.

mikbini (mikbini) wrote :

@mikephi: I'm not sure your issue is the same as the one I described above as I can mount the share even if the password is saved, provided I wait some time between two mounts.

PM (pm77) wrote :

Same here, with gvfsd-smb (have tried other protols).
It is identical to Mikeyphi - always when password is remembered network access is broken. Waiting for hours or rebooting does not help. I have to delete passwords from keyring.
Error message "Error: DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)"

PM (pm77) wrote :

Tried to delete all stored keys, but still the same er error message.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gvfs (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

thank you for sending the bug to GNOME

Changed in gvfs (Ubuntu):
status: New → Triaged
PM (pm77) wrote :

This bug does NOT only happen after repeated mount/unmount cycles. If I connect a network share (smb) with stored password, later mounting other shares on the same NAS-box failes with the error message "Error: DBus error org.freedesktop.DBus.Error.NoReply: Message did not receive a reply (timeout by message bus)".

Rebooting the system does not "solve" this, but deleting the stored passwords in <<Applications-Passwords and Encryption Keys" does. It's 100% reproducible on my updated and clean Ubuntu Lucid test partition. Everything works OK if I don't store passwords, aka "forget imidiately".

Are you sure this is the same bug? Is this an upstream bug? It is certainly a serious bug!

mikbini (mikbini) wrote :

I can definitely mount multiple shares (all from the same server, some are authenticated and some are not) although sometimes I get the "DBus error" message even if a lot of time passes between the mounts.

When this happens I can "solve" the problem by unmounting all the shares, waiting for some time and then mounting again. I should have stated this in the original report.

I didn't actually try to remove the password from seahorse because, as I stated above, some of the shares don't require authentication.

Peng (pengwg) wrote :

I have the problem exactly described by PM. No matter how long I wait once I save the credential I can no longer mount again.

Nikolaus Filus (nfilus) wrote :

Similar reports in ubuntu and upstream circle around https://bugzilla.gnome.org/show_bug.cgi?id=606902 which seems to solve the 100% CPU issue and is related to a dbus problem in gnome-keyring. Maybe the upstream fix is also relevant for this report? When and how will the patch get into ubuntu?

Nikolaus Filus (nfilus) wrote :

BTW: My problem is the one with beeing not able to mount shares on NAS after the password was saved in seahorse (DBUS timeout).

Sebastien Bacher (seb128) wrote :

the libgnome-keyring dbus cpu use issue change is already in lucid for over a week now

mikbini (mikbini) wrote :

I can confirm the bug, as described, still happens to me.

I don't know whether the many comments from other people complaining that they cannot mount even after waiting some time actually refer to this same problem or not, as waiting (although not quite acceptable, obviously) always let me mount the shares.

Nikolaus Filus (nfilus) wrote :

@mikbini: can you be more precise about what is "some" time for you. I'll try to check my issue then, but if this means minutes, then I definitely can't mount the share again whereas deleting the saved key works.

Should we split the issue?

How to debug this?

mikbini (mikbini) wrote :

@Nikolaus Filius: I wait some tens of seconds or a few minutes at most.

Peng (pengwg) wrote :

I found out I don't have this problem (not even need to wait) on a freshly installed system from lucid beta 2 64bit live cd ( with new /home partition).

mikbini (mikbini) wrote :

In my case the installation (and the user) where created by a fresh lucid beta1 install.

mikbini (mikbini) wrote :

Un-duping from bug #559523 as these are two distinct issues. People who can *never* mount after saving passwords please refer to bug #559523: this one involves occasional mount problems which go away after some time.

PM (pm77) wrote :

I can confirm that all is working now (as of 2010-04-15), This includes mounting/unmounting without delay.

mikbini (mikbini) wrote :

It works for me, too.

Changed in gvfs (Ubuntu):
status: Triaged → Fix Released
Changed in gvfs:
status: Unknown → New
Nikolaus Filus (nfilus) wrote :

With the updates until 2010-04-15 I can mount some shares sometimes when password is saved. But it still fails randomly for different shares at 5 out 10 cases. apport.log shows the alredy known crash in usr_lib_gvfs_gvfsd-smb.1000.crash

For me it's not fixed!

Nikolaus Filus (nfilus) wrote :

It's better, not fixed.

Changed in gvfs (Ubuntu):
status: Fix Released → In Progress
Nikolaus Filus (nfilus) wrote :

I'll attach my newest crash report showing the problem (using the latest libgnome-keyring0 2.30.0-0ubuntu4). Apport can't report it automatically because of an assertion error. The trace is similar to http://launchpadlibrarian.net/44156511/ExtractFile__usr_lib_gvfs_gvfsd_smb_1000_crash.txt from bug #559523.

Sebastien Bacher (seb128) wrote :

seems similar to bug #560588

Nikolaus Filus (nfilus) wrote :

Thanks to the wiki page from bug #560588 I installed dbgsym for libgnome-keyring and libc6-*. Hope the resulting trace helps more ...

PM (pm77) wrote :

It seems similair to bug 559523, as noted by Filus.

Changed in gvfs:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.