deja-dup-preferences crashed with SIGSEGV in g_file_get_child()

Bug #544306 reported by mikbini on 2010-03-22
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Déjà Dup
Critical
Unassigned
gvfs
Fix Released
High
gvfs (Ubuntu)
Undecided
Martin Pitt

Bug Description

Binary package hint: deja-dup

The preferences dialog opened for some moments and then crashed. Alas trying to recover the situation I zapped the whole configuration with gconf and now it works. I think the crash could be due to the fact that I added a non-existent windows share as the backup destination folder.

ProblemType: Crash
Architecture: i386
Date: Mon Mar 22 17:31:17 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/bin/deja-dup-preferences
InstallationMedia: Error: [Errno 13] Permission denied: '/var/log/installer/media-info'
NonfreeKernelModules: wl
Package: deja-dup 13.92-0ubuntu1
ProcCmdline: deja-dup-preferences
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SegvAnalysis:
 Segfault happened at: 0xa5e4a9 <g_file_get_child+41>: mov (%esi),%edx
 PC (0x00a5e4a9) ok
 source "(%esi)" (0xaaaaaaaa) not located in a known VMA region (needed readable region)!
 destination "%edx" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: deja-dup
StacktraceTop:
 g_file_get_child () from /usr/lib/libgio-2.0.so.0
 ?? () from /usr/lib/libgtk-x11-2.0.so.0
 ?? () from /usr/lib/libgio-2.0.so.0
 g_simple_async_result_complete ()
 ?? () from /usr/lib/libgio-2.0.so.0
Title: deja-dup-preferences crashed with SIGSEGV in g_file_get_child()
Uname: Linux 2.6.32-16-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
XsessionErrors:
 (polkit-gnome-authentication-agent-1:11073): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (bluetooth-applet:11076): Gtk-CRITICAL **: gtk_action_set_sensitive: assertion `GTK_IS_ACTION (action)' failed

Related branches

mikbini (mikbini) wrote :
visibility: private → public
Michael Terry (mterry) on 2010-03-25
Changed in deja-dup:
assignee: nobody → Michael Terry (mterry)
importance: Undecided → Critical
status: New → In Progress
Michael Terry (mterry) wrote :

Can you upload your gconf values?
gconftool-2 --dump /apps/deja-dup > /tmp/deja-dup.gconf

Changed in deja-dup:
status: In Progress → Incomplete
Michael Terry (mterry) wrote :

Nevermind about the gconf values. I managed to reproduce it. This appears to be a bug in GTK+. Filed a patch upstream.

Changed in deja-dup:
assignee: Michael Terry (mterry) → nobody
status: Incomplete → Invalid

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
ThreadStacktrace:

Changed in deja-dup (Ubuntu):
status: New → Invalid
Download full text (5.5 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate an useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

libgcc1: installed version 1:4.4.3-4ubuntu1, latest version: 1:4.4.3-4ubuntu5
mountall: installed version 2.8, latest version: 2.10
deja-dup: installed version 13.92-0ubuntu1, latest version: 14.0.1-0ubuntu1
libssl0.9.8: installed version 0.9.8k-7ubuntu6, latest version: 0.9.8k-7ubuntu8
libk5crypto3: installed version 1.8+dfsg~alpha1-7, latest version: 1.8+dfsg~alpha1-7ubuntu1
libudev0: installed version 151-5, latest version: 151-7
libxrandr2: installed version 2:1.3.0-2build1, latest version: 2:1.3.0-3
python2.6: installed version 2.6.5-1ubuntu2, latest version: 2.6.5-1ubuntu4
python-minimal: installed version 2.6.4-0ubuntu2, latest version: 2.6.5-0ubuntu1
libdbus-1-3: installed version 1.2.16-2ubuntu3, latest version: 1.2.16-2ubuntu4
libcups2: installed version 1.4.2-9, latest version: 1.4.2-10
libpango1.0-common: installed version 1.26.2-1, latest version: 1.28.0-0ubuntu1
libldap-2.4-2: installed version 2.4.21-0ubuntu2, latest version: 2.4.21-0ubuntu3
tzdata: installed version 2010e-1, latest version: 2010g-0ubuntu1
gvfs-fuse: installed version 1.5.5-0ubuntu1, latest version: 1.6.0-0ubuntu1
base-files: installed version 5.0.0ubuntu10, latest version: 5.0.0ubuntu14
libplymouth2: installed version 0.8.0~-17, latest version: 0.8.1-4
libgtk2.0-common: installed version 2.19.7-0ubuntu1, latest version: 2.20.0-0ubuntu3
klibc-utils: installed version 1.5.15-1ubuntu4, latest version: 1.5.17-4ubuntu1
libpango1.0-0: installed version 1.26.2-1, latest version: 1.28.0-0ubuntu1
libgdu0: installed version 2.30.0-1build1, latest version: 2.30.1-0ubuntu1
python: installed version 2.6.4-0ubuntu2, latest version: 2.6.5-0ubuntu1
dbus: installed version 1.2.16-2ubuntu3, latest version: 1.2.16-2ubuntu4
libglib2.0-0: installed version 2.23.5-1ubuntu3, latest version: 2.24.0-0ubuntu1
libappindicator0: installed version 0.0.17-0ubuntu1, latest version: 0.0.19-0ubuntu1
libklibc: installed version 1.5.15-1ubuntu4, latest version: 1.5.17-4ubuntu1
cpp-4.4: installed version 4.4.3-4ubuntu1, latest version: 4.4.3-4ubuntu5
libgvfscommon0: installed version 1.5.5-0ubuntu1, latest version: 1.6.0-0ubuntu1
gconf2: installed version 2.28.0-1ubuntu5, latest version: 2.28.1-0ubuntu1
libgssapi-krb5-2: installed version 1.8+dfsg~alpha1-7, latest version: 1.8+dfsg~alpha1-7ubuntu1
libparted0: installed version 2.2-1ubuntu3, latest version: 2.2-1ubuntu4
udisks: installed version 1.0.0-0ubuntu1, latest version: 1.0.0+git20100319-0git1
libuuid1: installed version 2.17-0ubuntu3, latest version: 2.17.2-0ubuntu1
sysv-rc: installed version 2.87dsf-4ubuntu15, latest version: 2.87dsf-4ubuntu17
util-linux: installed version 2.17-0ubuntu3, latest version: 2.17.2-0ubuntu1
gcc-4.4-base: installed version 4.4.3-4ubuntu1, latest version: 4.4.3-4ubuntu5
sensible-utils: installed version 0.0.1ubuntu1, latest version: 0.0.1ubuntu2
libgnome-keyring0: installed version 2.29.4git20100224-0ubuntu2, latest version: 2.30.0-0...

Read more...

tags: removed: need-i386-retrace
Martin Pitt (pitti) on 2010-04-14
affects: libgtk → gvfs
affects: deja-dup (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
status: Invalid → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.6.0+git20100414-0ubuntu1

---------------
gvfs (1.6.0+git20100414-0ubuntu1) lucid; urgency=low

  * New upstream git snapshot (since GNOME 2.30.1 will be too late for lucid):
    - afc: Detect iPad and set correct icon name
    - ftp: Parse PWD reply according to RFC
    - ftp: Add missing \n to debug message
    - Attach cancellable to async result and check in finish functions
      (LP: #544306)
    - Disable x-content-types for jailbroken iDevices
    - Translation updates.
  * Drop 04_dont_automount_internal_partitions.patch, it was fixed upstream a
    while ago with a different approach.
  * 02_music-player-mimetype.patch: Update to current patch tagging format.
  * debian/control.in: Bump Standards-Version to 3.8.4 (no changes necessary).
  * Add 01_dont_ignore_blank_cd_drives.patch: Extend the special casing of CD
    drives in should_drive_be_ignored() to also cover blank media. Otherwise
    we lose the drive for the blank media volume, and with it the possibility
    to eject it. (LP: #425104)
 -- Martin Pitt <email address hidden> Wed, 14 Apr 2010 11:02:59 +0200

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
Changed in gvfs:
status: Unknown → Fix Released
Changed in gvfs:
importance: Unknown → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.