openssh (or gvfs) asks for a password everytime I change directory in sftp

Bug #540280 reported by Jeff Fortin Tam on 2010-03-17
120
This bug affects 23 people
Affects Status Importance Assigned to Milestone
bzr-gtk (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Jeff Fortin Tam
Nominated for Maverick by TomasHermosilla
gvfs (Ubuntu)
Medium
Unassigned
Nominated for Lucid by Jeff Fortin Tam
Nominated for Maverick by TomasHermosilla

Bug Description

Binary package hint: gvfs

Even though my password is correctly saved in gnome keyring, openssh asks me to manually input it everytime I change directories in a sftp:// address with nautilus.

ProblemType: Bug
Architecture: i386
Date: Wed Mar 17 10:17:53 2010
DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100113)
Package: gvfs 1.5.5-0ubuntu1
ProcEnviron:
 LANG=en_CA.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-16.25-generic
SourcePackage: gvfs
Uname: Linux 2.6.32-16-generic i686

== To Reproduce this issue in 64bit Ubuntu ==

1. Open a sftp mounted volume (got asked for the PW) when hitting ENTER three times I get access to the volume
The .xsession-errors (bzr-installed-log.txt) shows some python errors and permission denied entries
2. then I uninstalled nautilus-bzr
3. killall nautilus (which results in a respawn of nautilus)
4. Open a ftp mounted volume. And the system just shows the volume (no log entries are produced)
5. Reinstalled nautilus-bzr => the error reappears

== Regression details ==
Discovered in version: bzr-gtk 0.98.0-1ubuntu1
Last known good version: bzr-gtk 0.97.0-0ubuntu3

Jeff Fortin Tam (kiddo) wrote :
Jeff Fortin Tam (kiddo) wrote :

I keep getting this to this day. Here's a screenshot of how it looks like. It really looks as if openssh client itself was interfering with gvfs or something.

To reproduce:
1. Use nautilus to connect to a password-based SSH server, such as sftp://user@server
2. When prompted if you want to remember the password, select "only for this session"
3. Move around. As soon as you change folders, this intrusive and modal openssh dialog will show up.

Jeff Fortin Tam (kiddo) wrote :

Actually, even if I tell it to "remember the password forever", it never does.

Jeff Fortin Tam (kiddo) on 2010-04-10
tags: added: regression-potential
Jeff Fortin Tam (kiddo) wrote :

Well heck, I couldn't figure out what was wrong, it was not a per-user account issue. I just wiped the computer off and clean-installed alpha 2, no problem anymore.

Marking incomplete in case someone else experiences this.

Changed in gvfs (Ubuntu):
status: New → Incomplete
Brian Murray (brian-murray) wrote :

I was unable to recreate this on a system that has been using Lucid for 62 days.

Laurens (laurenssss) on 2010-04-21
Changed in gvfs (Ubuntu):
status: Incomplete → Confirmed
Laurens (laurenssss) wrote :

I can confirm this bug in up to date lucid.
The strange thing is that you don't need to enter the right password.
You either click OK, Cancel or Close three times and you get into your new directory.
I tried it in a guest user session too. It's the same.

Laurens (laurenssss) wrote :

After the updates from last week. I don't have this bug anymore.

Changed in gvfs (Ubuntu):
status: Confirmed → Fix Released
Peter (pm-netzor) wrote :

Hi,

I'm using the stable Version of Ubuntu 10.04 (64 Bit). After a new install of the system with all updates, the above-mentioned problem appears in nautilus with gvfs. This is a link to the screenshot of the "abnormal" window, which asks for the ssh-password, everytime the ssh-adress changes or the folder is reloaded: http://www.ubuntu-pics.de/bild/89746/test_g6yETn.png - even when the "never forget the password option" is chosen.

I hope the problem can be solved here.

Best regards from germany,
Peter

Jeff Fortin Tam (kiddo) wrote :

Actually, doing a clean install solved this for me so I wasn't experiencing the issue since (32-bit install)

Reiner Jung (prefec2) wrote :

I am experiencing this on a 64-bit installation even after a clear install. So it might be a 64 bit problem. However, I have no clues how to analyze this problem. Is there any information available which explains the auth stuff of gvfs and gnome-keyring/ssh etc.

Reiner Jung (prefec2) wrote :

Very strange: I was able to fix this by uninstalling nautilus-bzr and the problem reappeared after installing nautilus-bzr.

I performed the following test:
1. Open a sftp mounted volume (got asked for the PW) when hitting ENTER three times I get access to the volume
The .xsession-errors (bzr-installed-log.txt) shows some python errors and permission denied entries
2. then I uninstalled nautilus-bzr
3. killall nautilus (which results in a respawn of nautilus)
4. Open a ftp mounted volume. And the system just shows the volume (no log entries are produced)
5. Reinstalled nautilus-bzr => the error reappears

Laurens (laurenssss) on 2010-07-27
Changed in gvfs (Ubuntu):
status: Fix Released → Confirmed
Laurens (laurenssss) wrote :

This Bug can be reproduced as Reiner Jung in comment #11 describes. Before marking this bug as fixed I uninstalled nautilus-bzr and didn't notice that it was just because of that.

Steps to reproduce:
1. sudo apt-get install nautilus-bzr
2. killall nautilus
3. Open any sftp folder. ssh wrongly asks tree times for the password.

To let the bug disappear:
4. sudo apt-get remove nautilus-bzr
5. killall nautilus
6. Open any sftp folder. Now ssh won't ask for a password.
And everything works as before

tags: added: lucid regression-release
removed: regression-potential
description: updated
Changed in bzr-gtk (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in gvfs (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Sarah Weiss (sam81452667) wrote :

Running Ubuntu 10.04 32-bit, Problem appeared a couple of hours ago, after installing Samba!
Removing Bazaar solved the problem.
Without installing Samba the problem never appeared.

rindlis (rindlis) wrote :

I have:
Ubuntu 10.10 release, 64-bit, fresh install, all updates.
Linux 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64 GNU/Linux
GNOME nautilus 2.32.0
bzr-gtk 0.99.0-1ubuntu1
bzr-dbus 01~bzr39-2
nautilus-bzr 0.99.0-1ubuntu1

Using an already open ssh connection to a remote server, I start nautilus from a terminal with the command:
nautilus sftp://username@server

Nautilus does not come up, no error message, no crash, it hangs, I cannot start another instance of nautilus
(second process hangs too), System Monitor shows one or more process nautilus with waiting channel: do_wait

To make nautilus working again, I have to "killall nautilus".

When I do:
sudo apt-get remove nautilus-bzr
killall nautilus

then the above command "nautilus sftp://username@server" brings up nautilus and the remote folder within a split second. All is OK.

I can do:
sudo apt-get install nautilus-bzr
killall nautilus
nautilus sftp://username@server

and it hangs again, etc.

I've got the same problem up until now. Is there any respond to this ????

Oh!! Sorry for the comment #15, I missed read the #14 comment

Thanks for the solution anyway.

Jelmer Vernooij (jelmer) on 2011-06-17
tags: added: nautilus-bzr
Beetroot Dog (beetrootdog) wrote :

This problem still exists in Natty 11.04.

Somehow I missed this bug and also reported it as Bug #799072. Now marked as a duplicate of this.
In Bug #799072 I attached logs from auth.log after putting sshd into "LogLevel DEBUG" both before and after nautilus-bzr was removed, which may help.

Beetroot Dog (beetrootdog) wrote :

OK this patch fixes it, although it probably stops you from using bazaar from nautilus over gvfs-mounted sftp locations.
Although that didn't appear to work anyway.

Patch for /usr/lib/nautilus/extensions-2.0/python/nautilus-bzr.py
package: nautilus-bzr
version: 0.100.0-2ubuntu2 (natty)

The problem was with the call to WorkingTree.open_containing(file) in function get_background_items. This was launching another sftp connection even though nautilus had already opened one. This resulted in a second prompt for the password on connection and when changing directories - although it didn't seem to matter whether you entered your password or not - the bazaar/nautilus integration didn't seem to work over sftp locations.

tags: added: patch
Basher Aobasher (aobasher) wrote :

I am experiencing this on a 64-bit installation even after a clear install.

Sasa Stamenkovic (umpirsky) wrote :

I'm getting this annoying popup after upgrade to 12.04.

No matter if I click cancel or ok it pops again a number of times. And it goes on and on for every dir change.

I uninstalled nautilus-bzr, problem still exists.

Sasa Stamenkovic (umpirsky) wrote :

Worked after killing nautius proces and runing nautilus again.

Sasa Stamenkovic (umpirsky) wrote :

But still, the bug is probably in nautilus-bzr, which I uninstalled.

Stefan Feilmeier (sfeilmeier) wrote :

This bug happened to me as well when I had nautilus-bzr installed. After uninstalling it and restarting nautilus the bug disappeared.

Thanks @Sasa Stamenkovic

Samuel Buffet (samuel-buffet) wrote :

The same bug here. To use sftp after having installed nautilus-bzr is failing with "openssh" asking for password again and again and again and again....

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers