banshee creative zen V mtp sync doesn't work at all

Bug #535268 reported by piratemurray on 2010-03-09
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
gvfs
Invalid
Undecided
Unassigned
libmtp
Invalid
Undecided
Unassigned
gvfs (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: banshee

I am confident that libmtp (1.0.2.1-ubuntu1) works since Rhythmbox can sync to the Creative Zen absolutely fine.

Banshee can not. This is frustrating since Banshee is much better than the other music players in so many ways. But I need music sync'ing.

Steps to reproduce:
1) Connect Creative Zen 4GB to computer via USB
2) Observe device entry in Places menu and on desktop
3) Open Banshee
4) Attempt to sync some song to this device in Banshee
(occasionally) 5) Close and reopen Banshee if device does not appear in Banshee first time

Expected result:
Tracks are sync'd successfully to the MTP device

Actual result:
Failure to sync anything to the device. Rhythmbox works fine. Output from Banshee when started in terminal is attached

Lucid Lynx alpha 3 64bit
Daily PPA of Banshee 1.5.5+git20100307
Creative Zen V 4GB

piratemurray (mez-pahlan) wrote :
piratemurray (mez-pahlan) wrote :

An update to this. I removed podsleuth since I don't have (or want) an iPod. And now Banshee doesn't recognise my Zen at all despite it being in the Places menu and ready to use.

The new output when run from the terminal is:

[Info 18:54:53.661] Running Banshee 1.5.5: [Ubuntu lucid (development branch) b1f45c7 (linux-gnu, x86_64) @ 2010-03-08 23:25:45 UTC]
[Warn 18:54:54.112] Hardware manager extension failed to load - Exception has been thrown by the target of an invocation.
[Warn 18:54:54.113] Service `Banshee.Hardware.HardwareManager' not started: No HardwareManager extensions could be loaded. Hardware support will be disabled.
[Warn 18:54:54.115] Caught an exception - No HardwareManager extensions could be loaded. Hardware support will be disabled. (in `Banshee.Services')
  at Banshee.Hardware.HardwareManager..ctor () [0x00000]
  at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000]
[Warn 18:54:55.246] Caught an exception - Object reference not set to an instance of an object (in `Banshee.AudioCd')
  at Banshee.AudioCd.AudioCdService.Initialize () [0x00000]
  at Banshee.ServiceStack.ServiceManager.StartExtension (Mono.Addins.TypeExtensionNode node) [0x00000]
[Warn 18:54:55.246] Extension `Banshee.AudioCd.AudioCdService' not started: Object reference not set to an instance of an object
[Warn 18:54:55.251] Caught an exception - Object reference not set to an instance of an object (in `Banshee.AudioCd')
  at Banshee.AudioCd.AudioCdService.Initialize () [0x00000]
  at Banshee.ServiceStack.ServiceManager.StartExtension (Mono.Addins.TypeExtensionNode node) [0x00000]
[Warn 18:54:55.251] Extension `Banshee.AudioCd.AudioCdService' not started: Object reference not set to an instance of an object
[Info 18:54:55.252] All services are started 1.327268s
[Info 18:54:56.221] nereid Client Started

Do I have to have iPod support sync my Creative? If need be I can reinstall podsleuth to aid with the trouble shooting.

Thanks

Gabriel Burt (gabaug) wrote :

Please run again and attach the log, but launching banshee-1 with --debug to get extra logging

piratemurray (mez-pahlan) wrote :

Here is what you have requested.

Still no Creative Zen popping up :(

Thanks for the help btw.

tags: added: kernel-series-unknown
tags: removed: kernel-series-unknown
Fabio Marconi (fabiomarconi) wrote :

Hello piratemurray

Is this issue present with the latest updated packages of Lucid ?

Thanks
Fabio

tags: added: lucid-alpha3
Changed in banshee (Ubuntu):
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in banshee (Ubuntu):
status: Incomplete → Invalid
Evan Derickson (derickson-e) wrote :

I'm getting this bug with Natty Narwhal beta 2, Banshee 2.0.0, and a Creative Zen V Plus 4GB.

Changed in banshee (Ubuntu):
status: Invalid → Confirmed
Kamus (kamus) wrote :

Evan, Please could you run in a terminal "banshee --debug" and attach all the output information in a separated file (while you are trying to reproduce this issue)? Thank you

Evan Derickson (derickson-e) wrote :

In this case, I connected the player first, then ran banshee --debug. Before running Banshee, the player mounts and displays on the desktop with a media player icon. I can browse in Nautilus without problems. Once I open Banshee, the player disappears from the desktop, but not from the Unity launcher. It never appears in Banshee itself. After I close Banshee, I can mount the player again by clicking in the Unity launcher, but I cannot do this while Banshee is open.

Kamus (kamus) wrote :

Evan, please could you install mtp-tools and then run in a terminal "mtp-detect" and attach the output information? because according to your logfile seems like an issue with libmtp package instead banshee.

Changed in banshee (Ubuntu):
importance: Undecided → Medium
tags: added: natty
tags: added: lucid
removed: banshee lucid-alpha3 mtp zen
Evan Derickson (derickson-e) wrote :

Output for mtp-detect:

evan@EVAND:~$ mtp-detect
libmtp version: 1.0.6

Listing raw device(s)
Device 0 (VID=041e and PID=4152) is a Creative ZEN V Plus.
   Found 1 device(s):
   Creative: ZEN V Plus (041e:4152) @ bus 2, dev 3
Attempting to connect device(s)
ignoring usb_claim_interface = -16ignoring usb_claim_interface = -22PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
inep: usb_get_endpoint_status(): Device or resource busy
outep: usb_get_endpoint_status(): Device or resource busy
usb_clear_halt() on IN endpoint: Device or resource busy
usb_clear_halt() on OUT endpoint: Device or resource busy
usb_clear_halt() on INTERRUPT endpoint: Device or resource busy
LIBMTP libusb: Attempt to reset device
ignoring usb_claim_interface = -16ignoring usb_claim_interface = -22LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0
OK.

Kamus (kamus) on 2011-05-02
Changed in banshee (Ubuntu):
status: Confirmed → Triaged
Marc Tommasi (marc-tommasi) wrote :

I got the same error with my creative Zen Mozaic. I think the bug is related to gvfs which conflicts with libmtp.

To avoid the bug, I use the following workaround (but I think it is not satisfactory :-) )
- quit banshee (not close, but quit)
- plug your zen
- open nautilus clicking on the zen icon in the dock
- umount the device !
- open banshee (be sure the mtp support extension is activated)

It works for me.

Marc.

Changed in banshee:
importance: Unknown → Medium
status: Unknown → New
Matthias (matthias-opennomad) wrote :

I can confirm the issue on Creative Zen:M. I finally got it working after un-mounting the device before trying to sync. It is running right now without any errors at this point.

The key to the workaround seem to be the unmount

Changed in banshee:
status: New → Incomplete
Arun S L (arun-sl) wrote :

I am also affected by this bug.

I am using creative zen v plus with Ubuntu 11.04

One more observation is that if i manual run mtp-detect or for that matter any other mtp- command second time it does not detect the device at all.

In the banshee I have also noticed that the bar showing is the free space is coing as orange indicating data. It is not able to identify the mp3's in my player.

I am also suspecting that this has something to do with gvfs. I get some error sometimes as unable to mount gphoto:// .....

Sorry at this point I am at work and my Samsung Laptop is not accessible to give the exact detail.

I am adding these thoughts as I also feel strongly that something has been broken which needs a fix in Ubuntu + Banshee for creative players to work properly.

\\ Regards,

Arun

Zigurds (zgstyle) wrote :

I have Creative ZEN V and I CAN'T use it wit Ubuntu.
When I connect it to my PC in a minute or so dialog box appears:
"You have jsut inserted a digital audio player. Choose what application to launch."
I choose "Open Banshee Media Player" and click on "Ok".
Banshee is being opened, but my players is not there.

mtp-detect shows:

libmtp version: 1.0.6

Listing raw device(s)
Device 0 (VID=041e and PID=4150) is a Creative ZEN V.
   Found 1 device(s):
   Creative: ZEN V (041e:4150) @ bus 2, dev 7
Attempting to connect device(s)
ignoring usb_claim_interface = -16ignoring usb_claim_interface = -22PTP_ERROR_IO: failed to open session, trying again after resetting USB interface
inep: usb_get_endpoint_status(): Device or resource busy
outep: usb_get_endpoint_status(): Device or resource busy
usb_clear_halt() on IN endpoint: Device or resource busy
usb_clear_halt() on OUT endpoint: Device or resource busy
usb_clear_halt() on INTERRUPT endpoint: Device or resource busy
LIBMTP libusb: Attempt to reset device
ignoring usb_claim_interface = -16ignoring usb_claim_interface = -22LIBMTP PANIC: failed to open session on second attempt
Unable to open raw device 0
OK.

--
Regards,
Zigurds

Changed in banshee:
status: Incomplete → Invalid
Chow Loong Jin (hyperair) wrote :

Reassigning to gvfs, as the upstream bug had been marked as a duplicate of a gvfs bug.

affects: banshee → gvfs
Changed in gvfs:
importance: Medium → Unknown
status: Invalid → Unknown
affects: banshee (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs:
importance: Unknown → Medium
status: Unknown → New
dino99 (9d9) wrote :

This version has expired

Changed in libmtp:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Changed in gvfs:
importance: Medium → Undecided
status: New → Invalid
Changed in gvfs (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.