Cannot see Windows shared folders

Bug #481865 reported by Natxo on 2009-11-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs
Expired
Medium
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Since upgraded to Ubuntu 9.10 (Karmic Koala) I can't see in nautilus windows shared folders. I know folders are there and somehow reachables, because I can see them in smbclient (see attched image)

nautilus: 1:2.28.1-0ubuntu2
smbclient: 2:3.4.0-3ubuntu5

When nautilus runs via terminal with nautilus --browser I get this output AFTER authentication:

natxoo@portnatxoo:~$ nautilus --browser

(nautilus:5855): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
Initializing nautilus-open-terminal extension

** (nautilus:5855): WARNING **: No marshaller for signature of signal 'UploadFinished'

** (nautilus:5855): WARNING **: No marshaller for signature of signal 'DownloadFinished'

** (nautilus:5855): WARNING **: No marshaller for signature of signal 'ShareCreateError'
Initializing nautilus-gdu extension

(nautilus:5855): GLib-GObject-CRITICAL **: g_type_instance_get_private: assertion `instance != NULL && instance->g_class != NULL' failed

** (nautilus:5855): CRITICAL **: dbus_g_proxy_begin_call: assertion `DBUS_IS_G_PROXY (proxy)' failed

(nautilus:5855): Gtk-WARNING **: Refusing to add non-unique action 'NautilusOpenTerminal::open_terminal' to action group 'ExtensionsMenuGroup'

--- Hash table keys for warning below:
--> natxoo
--> network:
--> inode/directory
--> Natxo Oyanguren
--> smb-server:server=visvr
--> l2053
--> smb-share:server=visvr,share=documentos

(nautilus:5855): Eel-WARNING **: "unique eel_ref_str" hash table still has 7 elements at quit time (keys above)

(nautilus:5855): Eel-WARNING **: "nautilus-directory.c: directories" hash table still has 5 elements at quit time
Shutting down nautilus-gdu extension
Shutting down nautilus-open-terminal extension

Natxo (natxooy) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low

Installed (clean) Karmic on 2 computers on home network; installed all updates to date including samba updates.

I designate a folder as 'shared' and the 'share' arrow icons show up. Restart computer... no icons and folder is not seen by other computer on network. When I check folder properties it is till set as 'shared'... but is not actually shared. (I think this is more than a 'low' importance... since I use a shared folder on another computer to back up the home folder before a new install, but cannot now access that info).

Natxo (natxooy) wrote :

Submitted to gnome bugzilla (https://bugzilla.gnome.org/show_bug.cgi?id=602119).

I also think it's more than low, i've had to downgrade my computer at work because of this.

Changed in gvfs (Ubuntu):
status: New → Triaged
Changed in gvfs:
status: Unknown → Confirmed
Nicolò Chieffo (yelo3) wrote :

I think that this is the problem of /etc/samba/smb.conf

use
name resolve order = lmhosts wins bcast host

and see what happens

Natxo (natxooy) wrote :

Upgraded again, and make changes in /etc/samba/smb.conf

Nothing new happens. It's really estrange, because I can see other shared folders in the same server...

Again attached screenshot and text archive with packages apt-cache policy (samba, smbclient, gvfs an nautilus)

Natxo (natxooy) wrote :

Upgraded again, and make changes in /etc/samba/smb.conf

Nothing new happens. It's really estrange, because I can see other shared folders in the same server...

Again attached screenshot and text archive with packages apt-cache policy (samba, smbclient, gvfs an nautilus)

Natxo (natxooy) wrote :

Here the text file

summary: - Cannot see windows shared folders
+ Cannot see Windows shared folders
Changed in gvfs:
status: Confirmed → Fix Released
Changed in gvfs:
status: Fix Released → Unknown
Changed in gvfs:
importance: Unknown → Medium
status: Unknown → New
Changed in gvfs:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.