Firewall blocks ability to browse shares. Error "unable to mount location - failed to retrieve share list from server" is displayed

Bug #474020 reported by Victor Wedge on 2009-11-04
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
gvfs
Expired
Medium
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

Going to Places > Nework returns "unable to mount location - failed to retrieve share list from server" when a firewall is enabled.

ProblemType: Bug
Architecture: i386
CheckboxSubmission: 1f5c1b345a479398e41afddddcf7836f
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Wed Nov 4 21:35:29 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.28.1-0ubuntu1
ProcEnviron:
 LANG=en_AU.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: nautilus
Uname: Linux 2.6.31-14-generic i686

Victor Wedge (victor-wedge) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
ojc (ocrawford) wrote :

Why is this so complicated? I like ubuntu. It usually just works. I need a straightforward way to get Ubuntu to talk to a bog standard windows network. In comparison to all the fantastic stuff that is in ubuntu this seems a fairly small thing. I've tried so many changes to the samba config file. This should be easy for us.

ojc (ocrawford) wrote :

I've installed GUFW (GUI for the 'uncomplicated' firewall). If I disable the firewall all is good. I'm working on getting this to be an exception rather than disabling the firewall but that's proving to be not 'uncomplicated'.

ojc (ocrawford) wrote :

It seems to work if I add a rule allowing 192.168.0.0/24 (IP adresses for my MSHOME network) in on TCP and UDP. I don't have a clue what UDP is and only the vaguest Idea what TCP is but it seems to work.

komputes (komputes) wrote :

I can confirm that in my case turning off ufw allowed me to receive responses from the samba broadcast (tested in GNOME's "Places > Network" and with smbtree). If you have a firewall enabled, try turning it off to see if you are able to see network shares instead of getting this error. I tried to close my firewall as much as possible and found that inbound udp ports 1024-65535 need to open to browse shares through Places > Network.

Changed in gvfs (Ubuntu):
status: New → Confirmed
description: updated
komputes (komputes) on 2010-05-11
summary: - unable to mount location - failed to retrieve share list from server
+ Firewall blocks ability to browse shares. Error "unable to mount
+ location - failed to retrieve share list from server" is displayed
Scunnered (scunnered) wrote :

This still appears to be a big problem. There are many asking the question why when we were able to access the Windows shares using Karmic is it impossible to do so in Lucid.

There are also reports that having tried going back to Karmic that they are now unable to resolve matter.

This needs to be urgently sorted as I and others are getting disgruntled at the inability of those in charge to resolve the problem

komputes (komputes) wrote :

I have linked to the upstream bug on GNOME's Bugzilla. I have also created Bug #579931 "ufw/gufw need a preset for samba-client". Scunnered, please contact me *off* this bug to troubleshoot the issue. Try not to comment on the importance of a bug, as it does not provide technical information for developers. There are forums for this type of communication. Thanks!

Changed in gvfs:
status: Unknown → New
Changed in gvfs (Ubuntu):
status: Confirmed → Triaged
Changed in gvfs:
importance: Unknown → Medium

Having problems with samba try;

stan@stan:~$ sudo ufw status
[sudo] password for me:
Status: active

To Action From
-- ------ ----
4662/tcp ALLOW Anywhere
4672/udp ALLOW Anywhere
139/tcp ALLOW Anywhere
445/tcp ALLOW Anywhere
137/udp ALLOW Anywhere
138/udp ALLOW Anywhere
The last 2 got it going. Ian.

Changed in gvfs:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.