can't list smb shares

Bug #469548 reported by Nicolò Chieffo on 2009-11-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
samba
Confirmed
Unknown
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs
samba (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gvfs

I'd like to browse (from nautilus) smb shares.

So what I do is:
- click places->network
- wait 20-30 seconds (only the first time)
- open "Windows Networks"
- open "Workgroup"
- wait 20-30 seconds

the error message is: Unable to mount location Failed to retrieve share list from server

I have a vista share configured in this way:
wireless network set to "home network"
network discovery = on
file sharing = on
public folder sharing = on
printer sharing = off
password protected sharing = off
media sharing = off

I can access directly the share by opening smb://192.168.5.4 without problems.

ProblemType: Bug
Architecture: amd64
Date: Sun Nov 1 22:31:59 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: gvfs 1.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: gvfs
Uname: Linux 2.6.31-14-generic x86_64

Nicolò Chieffo (yelo3) wrote :
Nicolò Chieffo (yelo3) wrote :

Of course from other windows installation I can list shares in less
than 1 second

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in gvfs (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Can you list those shares using smbclient?

can you help me on using smbclient?
I only know smbclient //192.168.5.4 but not a way to list all shares detected.
Thanks

Sebastien Bacher (seb128) wrote :

you can use "smbclient -L <hostname>", you might need to use -U <user> too

Changed in gvfs (Ubuntu):
status: New → Incomplete
Nicolò Chieffo (yelo3) wrote :

the problems is not that I can't see shares in hosts, it's that I
don't see anything in the nautilus network backend that lists all smb
hosts.

smbtree:
WORKGROUP
 \\VBOX-CHIEVO
cli_start_connection: failed to connect to VBOX-CHIEVO<20> (0.0.0.0).
Error NT_STATUS_UNSUCCESSFUL
 \\PORTATILE-HP-BA
cli_start_connection: failed to connect to PORTATILE-HP-BA<20>
(0.0.0.0). Error NT_STATUS_UNSUCCESSFUL

smbclient -L works only if I use the IP address, and fails with the
same error if I use the smb name

smbclient -L PORTATILE-HP-BA
Connection to PORTATILE-HP-BA failed (Error NT_STATUS_UNSUCCESSFUL)

smbclient -L 192.168.5.4
Domain=[PORTATILE-HP-BA] OS=[Windows Vista (TM) Home Premium 6002
Service Pack 2] Server=[Windows Vista (TM) Home Premium 6.0]

 Sharename Type Comment
 --------- ---- -------
 ADMIN$ Disk Amministrazione remota
 C$ Disk Condivisione predefinita
 D$ Disk Condivisione predefinita
 IPC$ IPC IPC remoto
 Public Disk
session request to 192.168.5.4 failed (Called name not present)
session request to 192 failed (Called name not present)
session request to *SMBSERVER failed (Called name not present)
NetBIOS over TCP disabled -- no workgroup available

Nicolò Chieffo (yelo3) wrote :

That seems to be a problem in samba, not in gvfs

Architecture: amd64
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
Package: samba-common 2:3.4.0-3ubuntu5.1
PackageArchitecture: all
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Uname: Linux 2.6.31-14-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Changed in gvfs (Ubuntu):
status: Incomplete → Invalid
Changed in samba:
status: Unknown → Confirmed

I manually compiled samba 3.4.3 and there is the same problem.

Chuck Short (zulcss) wrote :

Are you using opendns?

chuck

Nicolò Chieffo (yelo3) wrote :

No I don't. My nameservers are 193.70.152.15 193.70.152.25

And nmblookup can easily find the ip

Nicolò Chieffo (yelo3) wrote :

I've found a workaround to fix the smbtree problem

edit /etc/samba/smb.conf

find the line

; name resolve order = lmhosts host wins bcast

and change to

name resolve order = lmhosts wins bcast host

nautilus still can't list the shares, but maybe that's because I need to reboot

callMeTom (almighty-spork) wrote :

Seems it has something to do with the way Linux uses DNS versus the way Windows uses DNS, and having some DNSes (I'm using open DNS, Comcast's also, apparently, have an issue) try changing to Google's DNS 8.8.8.8, 8.8.4.4 - Worked for me and many others.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.