Ubuntu

nautilus crashed with SIGSEGV after connecting USB hard drive

Reported by mkrueger2002 on 2009-10-26
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gvfs (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

Hi,
this is my second attempt to report this bug.
This time I hope apport has collected appropriate information for those who know how to deal with the problem !
Summary: I'm using a MEDION Akoya 1212 netbook (same as MSI Wind 100) with UBUNTU Karmic Koala RC. After connecting a USB hard drive (Fujitsu handy drive 500) I see the icon of the drive, then nautilus crashes and all icons on the desktop disappear. The following entries are in /var/log/messages:

Oct 26 21:23:53 martin-netbook kernel: [ 134.388133] usb 1-2: new high speed USB device using ehci_hcd and address 3
Oct 26 21:23:53 martin-netbook kernel: [ 134.521665] usb 1-2: configuration #1 chosen from 1 choice
Oct 26 21:23:53 martin-netbook kernel: [ 134.523619] scsi5 : SCSI emulation for USB Mass Storage devices
Oct 26 21:23:58 martin-netbook kernel: [ 139.525322] scsi 5:0:0:0: Direct-Access FUJITSU HandyDrive500 0101 PQ: 0 ANSI: 0
Oct 26 21:23:58 martin-netbook kernel: [ 139.527394] sd 5:0:0:0: Attached scsi generic sg2 type 0
Oct 26 21:23:58 martin-netbook kernel: [ 139.530615] sd 5:0:0:0: [sdc] 976773168 512-byte logical blocks: (500 GB/465 GiB)
Oct 26 21:23:58 martin-netbook kernel: [ 139.534695] sd 5:0:0:0: [sdc] Write Protect is off
Oct 26 21:23:58 martin-netbook kernel: [ 139.547517] sdc: sdc1
Oct 26 21:23:58 martin-netbook kernel: [ 139.616098] sd 5:0:0:0: [sdc] Attached SCSI disk
Oct 26 21:24:08 martin-netbook kernel: [ 149.553369] nautilus[2231]: segfault at b4e77fec ip 06f24760 sp b4e77ff0 error 6 in libgvfsdbus.so[6f08000+24000]

I hope apport has now collected further information ! (see bug no. 459378)
In Ubuntu 9.04 everything worked fine with the same USB drive !

ProblemType: Crash
Architecture: i386
Date: Mon Oct 26 21:24:08 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/nautilus
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release Candidate i386 (20091020.3)
Package: nautilus 1:2.28.1-0ubuntu1
ProcCmdline: nautilus
ProcEnviron:
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
Signal: 11
SourcePackage: nautilus
StacktraceTop:
 ?? () from /usr/lib/gio/modules/libgvfsdbus.so
 ?? () from /usr/lib/gio/modules/libgvfsdbus.so
 ?? () from /usr/lib/gio/modules/libgvfsdbus.so
 ?? () from /usr/lib/gio/modules/libgvfsdbus.so
 ?? () from /usr/lib/gio/modules/libgvfsdbus.so
Title: nautilus crashed with SIGSEGV
Uname: Linux 2.6.31-14-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
SegvAnalysis:
 Segfault happened at: 0x6f24760: call 0x6f0f4a7
 PC (0x06f24760) ok
 source "0x6f0f4a7" (0x06f0f4a7) ok
 destination "(%esp)" (0xb4e77ff0) in non-writable VMA region: 0xb4e77000-0xb4e78000 ---p None
 Stack memory exhausted (SP below stack segment)
SegvReason: writing VMA None

StacktraceTop:meta_tree_init (tree=0xb6d2d318) at metatree.c:420
meta_tree_init (tree=<value optimized out>)
meta_tree_init (tree=<value optimized out>)
meta_tree_init (tree=<value optimized out>)
meta_tree_init (tree=<value optimized out>)

Changed in nautilus (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
affects: nautilus (Ubuntu) → gvfs (Ubuntu)
visibility: private → public
Doughy (doughywilson) wrote :

I'm having a similar problem, only I have no USB mounted. Every time I turn on my computer, nautilus crashes and I get no icons on the desktop, nor can I browse my files with nautilus. When I do a "dmesg" I find these kinds of errors:

[3711.470374] nautilus[5866]: segfault at b6f4afec ip 023dc760 sp b6f4aff0 error 6 in libgvfsdbus.so[23c0000+24000]

I did start having this problem when I had a USB device plugged in when I booted. Now I'm stuck with the problem and can't figure out how to get out of it.

JuanDA (juandeandres) wrote :

I'm having the same problem with a NTFS disk.
Error is:
nautilus[2800]: segfault at b6cb2fec ip 00caa760 sp b6cb2ff0 error 6 in libgvfsdbus.so[c8e000+24000]

astro_dave (dra-astro) wrote :

Doughy and perhaps JuanDA will probably benefit from this:
http://ubuntuforums.org/showthread.php?t=1322002#6

To quote from 'teh_lukes' linked post:
"the folder ~/.local/share/gvfs-metadata became corrupted. deleting it solved the problem. don't know which file exactly."

After upgrading to Karmic Koala, I had noticed that my desktop icons had disappeared. That fix worked for myself (and 2 people on ubuntuforums).

sirald66 (sirald66) wrote :

Moving ~/.local/share/gvfs-metadata to *_OLD worked.

Following is problem I was having:

Ubuntu 9.10
Linux 2.6.31-20-generic
Gnome 2.28.1
Compiz 1:0.8.4-0ubuntu2.1
Nautilus 1:2.28.1-0ubuntu3

EXPECTED: Launch of File Manager (trash can, and desktop).

ACTUAL: File Manager shows wait pointer for awhile, but then disappears; trash can shows 'maximize' framing animation, but no content; desktop not showing files stored in Desktop directory.

DIAG: This began when I used Simple CompizConfig Settings Manager to change open window animation from Glide 2 to Glide 3 which froze desktop basically when any window was opened [resolved by setting appearance visual effects to None].

To address this problem, renamed following files to _OLD extension and restarting. Didn't make any apparent change.

  ~/.cache/compizconfig
  ~/.compiz
  ~/.config/compiz
  ~/.gconf/apps/compiz
  ~/.gconf/apps/compizconfig

When I try to launch the File Manager or my Recycle Bin - the kern.log, syslog, and messages log update with these lines:

Feb 13 00:24:53 TOBY kernel: [10417.224943] nautilus[8957]: segfault at b6e47fdc ip 06bf5760 sp b6e47fe0 error 6 in libgvfsdbus.so[6bd9000+24000]
Feb 13 00:25:27 TOBY kernel: [10451.208646] nautilus[8963]: segfault at b6ed5fdc ip 00748760 sp b6ed5fe0 error 6 in libgvfsdbus.so[72c000+24000]
Feb 13 00:25:46 TOBY kernel: [10469.660972] nautilus[8970]: segfault at b6ddcfdc ip 00ccf760 sp b6ddcfe0 error 6 in libgvfsdbus.so[cb3000+24000]
Feb 13 00:25:59 TOBY kernel: [10482.795663] nautilus[8978]: segfault at b6ef6fdc ip 00f16760 sp b6ef6fe0 error 6 in libgvfsdbus.so[efa000+24000]

I am assuming one suggestion may be to reinstall libgvfsdbus.so and anything that says Nautilus. That sounds rather core and dangerous.

[Someone did suggest I reinstall all Nautilus and then Dbus if needed. But before I did that, I deleted ~/.local/share/gvfs-metadata as suggested here and it works]

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Is this reproducible with Lucid? Please test and provide us of feedback about it, Thanks in advance..

Changed in gvfs (Ubuntu):
status: New → Incomplete
importance: Medium → Low

Hello, Pedro,

no -- the beta1-version of Lucid works without any problems.

Martin Krüger

Am 06.04.2010 21:56, schrieb Pedro Villavicencio:
> Thank you for taking the time to report this bug and helping to make
> Ubuntu better. Is this reproducible with Lucid? Please test and provide
> us of feedback about it, Thanks in advance..
>
> ** Changed in: gvfs (Ubuntu)
> Status: New => Incomplete
>
> ** Changed in: gvfs (Ubuntu)
> Importance: Medium => Low
>
>

Janus (reslayer-mail) wrote :

For me, it shows this:

Apr 15 18:20:15 ubuntu kernel: [ 1430.025258] nautilus[7075]: segfault at b6f5bfdc ip 00d23760 sp b6f5bfe0 error 6 in libgvfsdbus.so[d07000+24000]

after system crashed. How could I get it fixed?

Janus (reslayer-mail) wrote :

Then, deletion of
~/.local/share/gvfs-metadata
helped radically. &^__^&

Kees Cook (kees) on 2010-04-22
description: updated
tags: added: stack-exhaustion
Launchpad Janitor (janitor) wrote :

[Expired for gvfs (Ubuntu) because there has been no activity for 60 days.]

Changed in gvfs (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers