Nautilus cannot write to shared Vista/Win7 folders with desktop.ini file

Bug #447695 reported by robled on 2009-10-10
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Undecided
Unassigned
gvfs
Fix Released
High
gvfs (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

Expectation: To be able to share a folder on a Vista/Win7 PC and have full read/write access to that folder from a Ubuntu PC via the Nautilus file manager.

Actual result: Nautilus cannot gain write access to shared Vista/Win7 folders that contain a desktop.ini file.

Steps to reproduce:

1. Right-click a newly created folder on a Vista/Win7 PC and select "Share with".
2. Use the following dialog to grant network users write access to the folder. At this stage the folder is empty and Nautilus can successfully write to the folder.
3. Right-click the same Vista/Win7 folder and navigate to the "Customize" tab.
4. From the "Optimize this folder..." drop-down menu pick any of the available options. This will add a Windows system file called "desktop.ini" to the folder.
5. Go to a Ubuntu 9.04 PC and browse to the Vista/Win7 PC using the "Network" option in the "Places" menu in Nautilus.
6. Double-click the Vista/Win7 folder you shared to mount it.
7. Attempt to create a new folder or file within the shared folder. Access will be denied.

Interesting notes:

If you go to the ~/.gvfs path via command line and browse to the same mounted network share you will have write access via command line.

This same issue occurs with the smb4k program in KDE4, but not the built-in Samba server browser in Konqueror.

Newly-created shared folders on a Vista/Win7 PC that do not contain a desktop.ini file can be successfully written to with Nautilus.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.26.2-0ubuntu2
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
Uname: Linux 2.6.28-15-generic x86_64

Related branches

robled (robled) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
robled (robled) wrote :

Bug report forwarded upstream.

Sebastien Bacher (seb128) wrote :

thank you for sending the issue to GNOME

Changed in nautilus (Ubuntu):
status: New → Triaged

Reassigning to match the product of the upstream bug.

affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Changed in nautilus:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Changed in gvfs:
importance: Unknown → High
status: Unknown → New
Sebastien Bacher (seb128) wrote :

the issue has been fixed upstream and the fix will be in Oneiric

Changed in gvfs (Ubuntu):
status: Triaged → Fix Committed
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
Changed in gvfs:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.10.0-0ubuntu1

---------------
gvfs (1.10.0-0ubuntu1) oneiric; urgency=low

  [ Adam Glasgall ]
  * debian/gvfs-backends.install: Install AFP backend

  [ Martin Pitt ]
  * New upstream release:
    - smb: Ignore read-only attribute for directories (LP: #447695)
    - gdu volume monitor: Mark bootable mounts as such
    - Translation updates
 -- Martin Pitt <email address hidden> Tue, 27 Sep 2011 07:04:01 +0200

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.