Ubuntu

gvfs-gdu-volume-monitor assert failure: libgdu:ERROR:gdu-pool.c:1253:device_recurse: assertion failed: (depth < 100)

Reported by Andy Duffell on 2009-09-23
80
This bug affects 15 people
Affects Status Importance Assigned to Milestone
gnome-disk-utility (Ubuntu)
Low
Unassigned
gvfs (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: gvfs

Crash reported by apport at login.

ProblemType: Crash
Architecture: amd64
AssertionMessage: libgdu:ERROR:gdu-pool.c:1253:device_recurse: assertion failed: (depth < 100)
CrashCounter: 1
Date: Wed Sep 23 09:32:34 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/gvfs/gvfs-gdu-volume-monitor
NonfreeKernelModules: nvidia
Package: gvfs 1.4.0-0ubuntu1
ProcCmdline: /usr/lib/gvfs/gvfs-gdu-volume-monitor
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_GB.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
Signal: 6
SourcePackage: gvfs
StacktraceTop:
 raise () from /lib/libc.so.6
 abort () from /lib/libc.so.6
 g_assertion_message_error ()
 ?? () from /usr/lib/libgdu.so.0
 ?? () from /usr/lib/libglib-2.0.so.0
Title: gvfs-gdu-volume-monitor assert failure: libgdu:ERROR:gdu-pool.c:1253:device_recurse: assertion failed: (depth < 100)
Uname: Linux 2.6.31-10-generic x86_64
UserGroups: adm admin audio cdrom dialout dip fax fuse lpadmin netdev plugdev sambashare tape vboxusers video

Andy Duffell (andy-duffell) wrote :

StacktraceTop:*__GI_raise (sig=<value optimized out>)
*__GI_abort () at abort.c:92
g_assertion_message_error ()
?? () from /usr/lib/libgdu.so.0
?? () from /usr/lib/libglib-2.0.so.0

Changed in gvfs (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Martin Pitt (pitti) on 2009-11-11
visibility: private → public
Changed in gvfs (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2009-11-12
Changed in gvfs (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Medium → High
Martin Pitt (pitti) on 2010-02-22
Changed in gvfs (Ubuntu):
assignee: Martin Pitt (pitti) → nobody
Nicolò Chieffo (yelo3) wrote :

This is not the only application that crashes with the same message. (update-manager, palimpsest)

Nicolò Chieffo (yelo3) wrote :

ops, update-notifier, not update-manager

Nicolò Chieffo (yelo3) wrote :

Adding gnome-disk-utility, since the error specifies "libgdu".
Anyway this bug needs attention, I can't mount external storage devices

dino99 (9d9) wrote :

karmic32 updated

This has reared its head on Maverick too...

OK, so I've spent a few hours trying to track down a possible cause of this bug as it also affects palimpsest (Disk Utility); when run both would exit with the device_recurse error. However, a Maverick install in a VirtualBox VM didn't have these issues, hence it must be hardware-dependent (I also tried Debian squeeze versions of g-d-u and libgdu).

I have a Dell Studio 17 (1749) into which I have connected an external USB keyboard and mouse - and with a sudden flash of inspiration I unplugged both and tried running palimpsest. Surprise - runs correctly. Even when I plugged both back in palimpsest ran correctly, as did gvfs-gdu-volume-monitor. I normally boot with both devices connected, hence the error will occur when the machine is started.

Could it be that g-d-u is trying to find filesystems on USB peripherals?

lspci is attached.

lsusb

After rebooting with neither USB device connected I was greeted by my internal NTFS drives mounted with labels, and USB drive auto-mounting working. No problem when I reconnected my keyboard and mouse either.

OK, so I rebooted with both devices attached and all seems good. I wonder if it is down to having the devices connected during installation? (Somewhere along the line it thinks keyboard and mouse are system devices, but there is something else plugged into the USB ports?)

Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version. Thanks in advance and sorry for the late response.

Changed in gnome-disk-utility (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Changed in gvfs (Ubuntu):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers