"Blank CD-R Disc" dialog shows an "unmount" button instead of "Eject"

Bug #425104 reported by Oded Arbel on 2009-09-06
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Nautilus
Invalid
Undecided
Unassigned
gvfs
Fix Released
Low
gvfs (Ubuntu)
Low
Martin Pitt

Bug Description

Binary package hint: gnome-mount

This is a regression in Karmic, though I'm not sure about the correct package.

With Jauny when the "detected a blank CD-ROM in your drive" message comes up it features a big "Eject" button at the bottom left corner with an appropriate graphic. The same dialog in Karmic offers a cryptic "Unmount" option with not graphical hint as to what it means (see attached screenshot). The new behavior is less understandable to human beings.

ProblemType: Bug
Architecture: amd64
Date: Sun Sep 6 10:56:20 2009
DistroRelease: Ubuntu 9.10
Package: gnome-mount 0.8-2ubuntu1
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-9.29-generic
SourcePackage: gnome-mount
Uname: Linux 2.6.31-9-generic x86_64

Related branches

Oded Arbel (oded-geek) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

affects: gnome-mount (Ubuntu) → nautilus (Ubuntu)
Changed in nautilus (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

confirmed here, I've sent this upstream at: https://bugzilla.gnome.org/show_bug.cgi?id=598554 ; Thanks for reporting.

Changed in nautilus (Ubuntu):
status: New → Triaged

Reassigning to match the product of the upstream bug.

affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Changed in nautilus:
importance: Unknown → Undecided
status: Unknown → New
status: New → Invalid
Martin Pitt (pitti) on 2010-04-13
Changed in gvfs (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Patch sent upstream.

Changed in gvfs (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gvfs - 1.6.0+git20100414-0ubuntu1

---------------
gvfs (1.6.0+git20100414-0ubuntu1) lucid; urgency=low

  * New upstream git snapshot (since GNOME 2.30.1 will be too late for lucid):
    - afc: Detect iPad and set correct icon name
    - ftp: Parse PWD reply according to RFC
    - ftp: Add missing \n to debug message
    - Attach cancellable to async result and check in finish functions
      (LP: #544306)
    - Disable x-content-types for jailbroken iDevices
    - Translation updates.
  * Drop 04_dont_automount_internal_partitions.patch, it was fixed upstream a
    while ago with a different approach.
  * 02_music-player-mimetype.patch: Update to current patch tagging format.
  * debian/control.in: Bump Standards-Version to 3.8.4 (no changes necessary).
  * Add 01_dont_ignore_blank_cd_drives.patch: Extend the special casing of CD
    drives in should_drive_be_ignored() to also cover blank media. Otherwise
    we lose the drive for the blank media volume, and with it the possibility
    to eject it. (LP: #425104)
 -- Martin Pitt <email address hidden> Wed, 14 Apr 2010 11:02:59 +0200

Changed in gvfs (Ubuntu):
status: Fix Committed → Fix Released
Oded Arbel (oded-geek) wrote :

Thanks for the update - I didn't really understand what was going on until the last comment.

These "change list" reports in the bug mail are really helpful to us clueless users who want to know what's going on. Please keep on doing those :-)

Changed in gvfs:
status: Unknown → Fix Released
Changed in gvfs:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.