Ubuntu

Nautilus 'Computer' displays redundant labels

Reported by Propagation of Sound on 2009-06-18
60
This bug affects 10 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Low
Sérgio Faria
gvfs
Invalid
Medium
gvfs (Ubuntu)
Low
Sérgio Faria

Bug Description

Binary package hint: nautilus

I am running Karmic Alpha 2

In previous versions of Ubuntu, when navigating to the 'Computer' directory, nautilus would display the label of the partition, and if it didn't have one, then the size of the media.

However, now (2.27.1) when I navigate to 'Computer', it displays too much information, such as the name of the drive etc.

For example, before it would say:
GENTOO

Now it says:
41 GB ATA Maxtor 6E040L0: GENTOO

and instead of saying:
BACKUP

it says:
500 GB ATA WDC WD5000AAKS-0: BACKUP

ProblemType: Bug
Architecture: i386
Date: Thu Jun 18 11:34:19 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/nautilus
Package: nautilus 1:2.27.1-0ubuntu1
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
SourcePackage: nautilus
Uname: Linux 2.6.30-8-generic i686

David Stansby (dstansby) wrote :

Please can you update to the latest version of nautilus (2.27.2) and see if you can still reproduce this bug. If you can, please mark it as new again.

Changed in nautilus (Ubuntu):
status: New → Incomplete

This bug is still reproducible in nautilus 2.27.2 and all upgrades as of UTC 18:07 18/06/09

Changed in nautilus (Ubuntu):
status: Incomplete → New

Here is a screenshot of the bug in nautilus 2.27.2

Sebastien Bacher (seb128) wrote :

that's an upstream choice not really a bug

affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
importance: Undecided → Low

Architecture: i386
DistroRelease: Ubuntu 9.10
Package: gvfs 1.3.3-0ubuntu1
PackageArchitecture: i386
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_IN
ProcVersionSignature: Ubuntu 2.6.31-5.24-generic
Uname: Linux 2.6.31-5-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

tags: added: apport-collected
tags: added: regression-potential
summary: - Nautilus displays too much data when viewing 'Computer'
+ Nautilus 'Computer' displays redundant labels
Vish (vish) wrote :

This maybe an upstream decision , but such labels are redundant and *not user-friendly* .

Maybe it can be reverted in gvfs(Ubuntu).

Changed in hundredpapercuts:
status: New → Confirmed
Rich Jones (richwjones) wrote :

Ooo, yeah, that's nasty, get rid of those!

Vish (vish) on 2009-08-13
Changed in hundredpapercuts:
status: Confirmed → Triaged
importance: Undecided → Low
Vish (vish) wrote :

David , Could you take a decision on this. Upstream has changed the "Computer" appearance

This would affect Bug #386517 [which is scheduled for round 6]

Changed in hundredpapercuts:
assignee: nobody → David Siegel (djsiegel)
Vish (vish) on 2009-08-22
Changed in hundredpapercuts:
milestone: none → round-10

Yes, this is ugly, I noticed this.

I think it's reasonable to try to display the following names as the volume label, in order:

  1. Volume label
  2. MANUFACTURER SIZE Disk
  2. SIZE Disk

If this was the previous behavior, we should revert to it.

Changed in hundredpapercuts:
assignee: David Siegel (djsiegel) → nobody
Changed in gvfs:
status: Unknown → New
Changed in gvfs (Ubuntu):
status: New → Triaged
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
Matthew Paul Thomas (mpt) wrote :

It looks like a short-term improvement would be to revert that change. It's not clear from the Gnome bug report why David Zeuthen wanted the manufacturer name etc shown by default (perhaps someone could ask him?:-). But probably it could be shown somewhere optional, separate from the label. For example, in icon view, it could be shown as secondary text below the label when you zoom in (like sizes are currently). And in list view, it could be an optional column separate from the Name column.

Sebastien Bacher (seb128) wrote :

I will try to ping davidz about that change but maybe somebody could contact the nautilus or gvfs upstream lists about that it would probably get replies there

Vish (vish) wrote :

I believe this issue is fixed now. the Label is now : " Manufacturer drive_label [or] Manufacturer disk_Size : volume_label"
ex: "Sony storage media : Sony Vault" ... "120GB hard Disk : Windows"

Changed in hundredpapercuts:
status: Triaged → Fix Released
Vish (vish) wrote :

Sebastien Bacher , if the "Fix released" status is wrong , kindly revert

I believe the present method achieves the balance of arranging the drive partitions together[which was why this seems to have been done in the first place] and yet not being too complex for a new user.

Changed in gvfs (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
status: Triaged → Fix Released
smurf (luca-dgh) wrote :

when I open the Computer window I find this http://img41.imageshack.us/img41/8625/computerwindow.png
In spanish "Disco duro" means Hard Disk.

Actually I don't like a lot that description because (for me) it makes hard to localize quickly the partition I'm looking for, so I wish to know if is possible to have only the partition label in the legend, as it was up to jaunty.

pt123 (pt123) wrote :

Is there anyway of removing the eyesore "500 GB Hardisk:" in front of the
drives. It is rather unnecessary and takes the focus from most info the
Name/Label/MountPoint of the partition.
Or it should be shown in a smaller and lighter text below the
Name/Label/MountPoint.

Do I really need to see 500GB so many times, I bought the hard disk I know it
is 500GB, I don't need to be reminded of it every day.

When one has given a label for a partition there is no need to mention how
large the drive the partition sits on, after all it is limited by the partition
size.

pt123 (pt123) wrote :

before on Jaunty

Durand D'souza (durand1) wrote :

I would also love to see this behaviour reverted. I have my main hard drive partitioned into about 15 partitions and all I see when I go to the Computer is 15 instances of 250GB Hard Disk... while the rest has been truncated. This does not help me choose the right icon. It does not even give me useful information. If it gave me the size of the partition, it might help. I don't really care about how big the overall medium is, I just want to know how much spcae is available to me and it is silly to assume that the size of the drive is the same as the space availabe. I also really think that this is just an eye sore and completely unnecessary. If anyone needs to know how big their hard drive is, they can easily right click on the icon and go to properties or simply use the System Manager.

Although the drive labels were tamed a bit, the presentation is still horrendous and the paper cut cannot be considered fixed.

Changed in hundredpapercuts:
status: Fix Released → Confirmed
Changed in gvfs (Ubuntu):
status: Fix Released → Confirmed
Changed in gvfs (Ubuntu):
status: Confirmed → Triaged
Vish (vish) wrote :

Upstream does not want to change the current behavior and has marked the upstream bug as "Not a bug".

Unless we are going to distro patch this , this probably wont be fixed upstream.

Changed in hundredpapercuts:
milestone: round-10 → none
status: Confirmed → Triaged
pt123 (pt123) wrote :

is there any mentioning upstream why they think incorrectly labeling a partition with size of the disk it is on appropriate?

C de-Avillez (hggdh2) on 2010-08-24
tags: removed: regression-potential
Changed in gvfs:
importance: Unknown → Medium
status: New → Invalid
Changed in hundredpapercuts:
assignee: nobody → Sérgio Faria (sergio91pt)
Changed in gvfs (Ubuntu):
assignee: nobody → Sérgio Faria (sergio91pt)
Sérgio Faria (sergio91pt) wrote :

I just added a patch for natty (for a askubuntu.com question) that reverts the commit pointed by #12.
I'm gonna add a branch for Oneiric soon.

pt123 (pt123) wrote :

Sweet, is it possible to post a screenshot of the result from this patch?

Its Attached.
Forgot to leave a link to the question:
http://askubuntu.com/questions/35955/how-to-hide-hard-disk-size-in-volume-name

2011/7/10 pt123 <email address hidden>

> Sweet, is it possible to post a screenshot of the result from this
> patch?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/388904
>
> Title:
> Nautilus 'Computer' displays redundant labels
>
> Status in GVFS:
> Invalid
> Status in One Hundred Paper Cuts:
> Triaged
> Status in “gvfs” package in Ubuntu:
> Triaged
>
> Bug description:
> Binary package hint: nautilus
>
> I am running Karmic Alpha 2
>
> In previous versions of Ubuntu, when navigating to the 'Computer'
> directory, nautilus would display the label of the partition, and if
> it didn't have one, then the size of the media.
>
> However, now (2.27.1) when I navigate to 'Computer', it displays too
> much information, such as the name of the drive etc.
>
> For example, before it would say:
> GENTOO
>
> Now it says:
> 41 GB ATA Maxtor 6E040L0: GENTOO
>
> and instead of saying:
> BACKUP
>
> it says:
> 500 GB ATA WDC WD5000AAKS-0: BACKUP
>
> ProblemType: Bug
> Architecture: i386
> Date: Thu Jun 18 11:34:19 2009
> DistroRelease: Ubuntu 9.10
> ExecutablePath: /usr/bin/nautilus
> Package: nautilus 1:2.27.1-0ubuntu1
> ProcEnviron:
> LANG=en_GB.UTF-8
> SHELL=/bin/bash
> ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
> SourcePackage: nautilus
> Uname: Linux 2.6.30-8-generic i686
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gvfs/+bug/388904/+subscriptions
>

tags: added: patch
Marc Deslauriers (mdeslaur) wrote :

I'm curious what will happen with this patch and removable usb drives. When I now insert a random Kingston USB key, it displays as "Kingston DataTraveler 2.0: 4.0 GB Filesystem" and not by the volume label, which is random and doesn't mean anything "E762-C972".

Sérgio Faria (sergio91pt) wrote :

@Marc, the patch just removes the the first part ("%s: " from "%s: %s"), but it had an error. I'm gonna attach some screenshots for comparison and the fixed version for Natty (for oneiric its in the branch bug-388904-2).

Sérgio Faria (sergio91pt) wrote :
Sérgio Faria (sergio91pt) wrote :
Sérgio Faria (sergio91pt) wrote :
Sérgio Faria (sergio91pt) wrote :
Marc Deslauriers (mdeslaur) wrote :

Right, so my kingston USB key would display as "E762-C972". I don't consider this patch to be much of an improvement for people using usb devices...

Sérgio Faria (sergio91pt) wrote :

@Marc, if it displayed "Kingston DataTraveler 2.0: 4.0 GB Filesystem" then the patch would make it display "4.0 GB Filesystem" like on the Devices side-Panel. So "E762-C972" should be the mount point and the label is unset.

However if you label it "E762-C972" it will display as "E762-C972", again, like on the devices side-panel.

Sérgio Faria (sergio91pt) wrote :

I'm gonna remove the merge porposal since we're past the UI freeze.

Chris Wilson (notgary) on 2013-05-27
Changed in hundredpapercuts:
milestone: none → papercuts-s-nautilus
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Patches

Remote bug watches

Bug watches keep track of this bug in other bug trackers.