wrong file name after restoring from trash

Bug #350172 reported by Victor Osadci on 2009-03-28
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gvfs
Fix Released
Low
gvfs (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: nautilus

To reproduce:

* Create two directories - "dir1" and "dir2";
* In each directory, create a file the same name (ex. "foo.bar")

  The directory structure should look like
dir1/foo.bar
dir2/foo.bar

* Move both files to the trash
  Now the trash contains two files with the same name.

* Restore each file from the trash using "Edit->Restore"

Result:

The name of one of the files is "foo.2.bar", so it looks like
dir1/foo.bar
dir2/foo.2.bar

>> Hi My name is amit
i try this sequence several times but i didn't face this problem.

Amit Jain (amitj) on 2009-03-28
description: updated
Sebastien Bacher (seb128) wrote :

what ubuntu version do you use?

Changed in nautilus (Ubuntu):
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Victor Osadci (victor-os) wrote :

Sebastien,

Up-to-date 9.04

affects: nautilus (Ubuntu) → gvfs (Ubuntu)
Changed in gvfs (Ubuntu):
status: Incomplete → New
Andreas Moog (ampelbein) wrote :

I can reproduce.

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: http://bugzilla.gnome.org/show_bug.cgi?id=577155

Changed in gvfs (Ubuntu):
status: New → Triaged
Changed in gvfs:
status: Unknown → New

This happens to directories as well.
i.e delete dirA
restoring dirA
Will result in dirA1

I'm busy going through 60 odd directories to manually "restore" them.

Changed in gvfs:
importance: Unknown → Low
Changed in gvfs:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.