gvfsd-trash crashed with SIGSEGV in pthread_cond_wait@@GLIBC_2.3.2()

Bug #325701 reported by Bogdan Butnaru on 2009-02-05
18
Affects Status Importance Assigned to Milestone
gvfs
Expired
Critical
gvfs (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gvfs

Not sure what caused it. I found the report behind other windows after a suspend/resume. I had just killall'd sshfs (which sometimes is frozen after a resume). May or may not be related to bug #317540, which I also encounter occasionally.

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/lib/gvfs/gvfsd-trash
NonfreeKernelModules: nvidia
Package: gvfs 1.1.5-0ubuntu1
ProcCmdline: /usr/lib/gvfs/gvfsd-trash --spawner :1.5 /org/gtk/gvfs/exec_spaw/0
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
Signal: 11
SourcePackage: gvfs
StacktraceTop:
 pthread_cond_wait@@GLIBC_2.3.2 ()
 g_static_rw_lock_writer_lock ()
 ?? ()
 g_closure_invoke ()
 ?? () from /usr/lib/libgobject-2.0.so.0
Title: gvfsd-trash crashed with SIGSEGV in pthread_cond_wait@@GLIBC_2.3.2()
Uname: Linux 2.6.28-6-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev pulse-rt sambashare

Bogdan Butnaru (bogdanb) wrote :

StacktraceTop:pthread_cond_wait@@GLIBC_2.3.2 ()
IA__g_static_rw_lock_writer_lock (lock=0x1841340)
trash_root_thaw (root=0x1841340) at trashitem.c:294
IA__g_closure_invoke (closure=0x187d2b0,
signal_emit_unlocked_R (node=0x183ead0, detail=0,

Changed in gvfs:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=570663

Changed in gvfs:
assignee: nobody → desktop-bugs
status: New → Triaged
desrt (desrt) wrote :

Hi Bogdan

If you can remember: how long had you been logged in when the crash occurred?

Although this is flagged as being a crasher in version 1.1.5, I am suspicious of the accuracy of that information. Séb packaged 1.1.5 on the 2nd and this bug is reported on the 5th. Even if you are very good about doing updates, I guess it wouldn't be until the 3rd or 4th until you had 1.1.5 on your machine. If you had been logged in from before that time then you would have actually been running 1.1.4 (or earlier).

1.1.4 had a known heap corruption bug in it that was fixed in 1.1.5. If you were really running 1.1.5 then this is another bug still unsolved. If you were using 1.1.4 or earlier, though, then I'd like to close this bug as it is very likely already fixed.

Cheers

Bogdan Butnaru (bogdanb) wrote :

I can't remember exactly that day. I think I found the message when I turned on the computer in the morning, so I had been logged in for at least a day.

Assuming that apport can get confused as you say, it's quite plausible that it did: Although I typically update at least once daily, I tend to reboot only once every few days, so unless the update restarts whatever service it's replacing, the old version can run for a while.

desrt (desrt) wrote :

Thanks for your reply. I'm going to assume, then, that this is a duplicate of #318661.

If you get any additional crashers please report them.

Cheers

Changed in gvfs:
status: Triaged → Fix Released
Changed in gvfs:
status: Unknown → Invalid
Sebastien Bacher (seb128) wrote :

there has been a new duplicate on bug #351936 using 1.2.0

Changed in gvfs (Ubuntu):
status: Fix Released → Triaged
Changed in gvfs:
status: Invalid → New
Changed in gvfs:
importance: Unknown → Critical
Changed in gvfs:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.